5,603,729 Members 37,862 Now Online
XDA Developers Android and Mobile Development Forum

Unable to remove Wi-Fi network

Tip us?
 
spice123
Old
(Last edited by spice123; 29th December 2013 at 12:19 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Default Unable to remove Wi-Fi network

Hi, I would like to remove a Wi-Fi network from my list. It's listed as "not in range"
A long press then "forget" sequence returns "cannot forget".
After resetting the phone, the entry is unaffected.


How do I remove the entry (Z736563757265).

thanks nb
 
dealmaster00
Old
(Last edited by dealmaster00; 18th February 2014 at 05:53 AM.)
#2  
Junior Member
Thanks Meter 0
Posts: 18
Join Date: Jun 2011
Quote:
Originally Posted by spice123 View Post
Hi, I would like to remove a Wi-Fi network from my list. It's listed as "not in range"
A long press then "forget" sequence returns "cannot forget".
After resetting the phone, the entry is unaffected.


How do I remove the entry (Z736563757265).

thanks nb
Hey, I encountered the same issue (I have this exact SSID saved that cannot be forgotten, "failed to forget network" - where did this SSID come from????) and spent some time figuring out how to remove it. Well, I actually fixed it with the 'attwifi' network but I assume the following steps would apply for you too. I have an LG G2 running stock android 4.2, rooted. Note that you will need a rooted phone in order to do this. Here are the steps I took:

1.) Get a text editor capable of running as root (I used 920 text editor, there is a permissions issue with it though that I detail later).

2.) Open /data/misc/wifi/wpa_supplicant.conf using your text editor. Make a backup of this file while you're at it.

3.) Find the 'attwifi' entry and rename it (I renamed it to 'attwifi2'.) You could also probably remove the entry but I didn't try that.

4.) Turn off and turn on Wifi
* Note, I couldn't turn on wifi at first once I changed wpa_supplicant's conf file. It turned out to be a permission issue - my text editor did not save the file with the correct permissions. I had to run 'chmod 777 /data/misc/wifi/wpa_supplicant.conf' in a terminal window to give permissions back (it probably just needs chmod 666).

5.) Find 'attwifi2' in your saved wifi list and 'forget network'. It should now be forgetten. There is no more attwifi or attwifi2.

If this doesn't work for you, then you are probably using a different version of android where the conf file is in a different path. Try grepping for attwifi via a terminal window. Another thing you can try is to run 'dmesg' in a terminal window to see the system log - this could give you a clue as to what is going wrong. Best of luck!
 
klaus ita
Old
#3  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Apr 2014
Default Wifi issue on note2

I have a wifi issue, wifi I is not turning on after flashed the hd revolution on my note 2 pls help me
 
justmpm
Old
#4  
justmpm's Avatar
Forum Moderator
Thanks Meter 2138
Posts: 2,738
Join Date: Dec 2010
Location: Jumpston Junction
Quote:
Originally Posted by klaus ita View Post
I have a wifi issue, wifi I is not turning on after flashed the hd revolution on my note 2 pls help me
I think your best bet is to ask your question in this thread: http://forum.xda-developers.com/show....php?t=2055736

Thanks!
THREAD CLOSED
Subscribe
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes