Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,099 Members 45,965 Now Online
XDA Developers Android and Mobile Development Forum

[Q] symlinks failed when installing CM 11 KitKANG

Tip us?
 
FriendlyPear
Old
#1  
FriendlyPear's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Location: Copenhagen
Default [Q] symlinks failed when installing CM 11 KitKANG

Hi,

I am trying to flash CM 11 KitKANG to my Desire, but without succes so far.

The installation log from 4EXT reads:

Installing KitKANG
Installing Gapps to /data
Creating symliks
symlink: some symlinks failed
E:Error in /sdcard/cm-11-kitkang-20140208-v0.5:slim.zip
(status 7)

Does anyone know what is causing this and what I can do to resolve it?

I have followed instructions and got a 1024mb ext4 sd-ext partition and AlphaRev Jelly Hboot; as well as tried both the latest 4EXT and twrp recoveries. This is the only ROM so far that I have tried installing that fails.

All help appreciated, thanks.
 
Tonal4Nagual
Old
#2  
Member
Thanks Meter 8
Posts: 42
Join Date: Apr 2011
Location: Zagreb
Are You sure that You have AlphaRev Jelly hboot?Boot in 4ext recovery and check info tab.
Size of your system partition must be 250 mb.
 
FriendlyPear
Old
#3  
FriendlyPear's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Location: Copenhagen
Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?
 
jmcclue
Old
#4  
jmcclue's Avatar
Recognized Contributor
Thanks Meter 1307
Posts: 3,392
Join Date: Apr 2012
Quote:
Originally Posted by FriendlyPear View Post
Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?
Yh try flashing latest 4ext (1.0.0.6 RC1)
The Following User Says Thank You to jmcclue For This Useful Post: [ Click to Expand ]
 
FriendlyPear
Old
#5  
FriendlyPear's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Location: Copenhagen
Quote:
Originally Posted by jmcclue View Post
Yh try flashing latest 4ext (1.0.0.6 RC1)
Where do I find that?

I guess your "4eXT Recovery Touch ... as PB99IMG" thread is linking to the older version, which is the same I get from the 4EXT app.
 
Tonal4Nagual
Old
#6  
Member
Thanks Meter 8
Posts: 42
Join Date: Apr 2011
Location: Zagreb
Quote:
Originally Posted by FriendlyPear View Post
Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?
I managed to install this rom with this version of 4ext.
Maybe is something wrong with your sd partition.Somewhere on the forums I saw that guys solved that problem by
mounting sd-ext in recovery before installing rom.
The Following User Says Thank You to Tonal4Nagual For This Useful Post: [ Click to Expand ]
 
FriendlyPear
Old
#7  
FriendlyPear's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Location: Copenhagen
Quote:
Originally Posted by Tonal4Nagual View Post
I managed to install this rom with this version of 4ext.
Maybe is something wrong with your sd partition.Somewhere on the forums I saw that guys solved that problem by
mounting sd-ext in recovery before installing rom.
Got it to work with the new v0.6!

Think you are right about the SD card being the problem. I removed it from the phone and reformatted with my PC using a card reader. Strange thing is that I have been formatting the card many times, also after I first saw the symlink failure, but always from phone recovery.So maybe one of the recoveries created an error that the following ones didn't...

Thanks for your help.
 
Tonal4Nagual
Old
#8  
Member
Thanks Meter 8
Posts: 42
Join Date: Apr 2011
Location: Zagreb
Quote:
Originally Posted by FriendlyPear View Post
Got it to work with the new v0.6!

Think you are right about the SD card being the problem. I removed it from the phone and reformatted with my PC using a card reader. Strange thing is that I have been formatting the card many times, also after I first saw the symlink failure, but always from phone recovery.So maybe one of the recoveries created an error that the following ones didn't...

Thanks for your help.
I'm glad you made it.
Partitioning SD card is always better to do with 4ext or gparted with sim inserted in phone.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Browse the Internet with the Innovative Atlas Web Browser

For the most part, Chrome, Firefox, and Dolphin Browser have no real rivals among … more

Choose from Over a Thousand Battery Styles with 3Minit Battery Mod

The battery style in stock Android looks pretty dull. It doesn’t … more

Organize Your Cloud Storage Files with Unclouded

Cloud storage services like Dropbox or Google Drive have grown in popularity dramatically … more

XDA Xposed Tuesday: Blur Your System Notification Panel – XDA Developer TV

Listen, we love innovative applications and modules that … more