5,603,646 Members 36,965 Now Online
XDA Developers Android and Mobile Development Forum

HTC Incredible won't boot, orange light blinks

Tip us?
 
SomeNamelessGuy
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Feb 2014
Default HTC Incredible won't boot, orange light blinks

My HTC Incredible hasn't been used for a while, so when I tried to use it, it wouldn't turn on. The orange blinking light blinks and it vibrates once if I press the power button, but then it stops doing anything. If I charge it long enough the light turns green but then if I press the power button, it vibrates once and stops blinking. Do I need a new battery?
 
pball52998
Old
#2  
pball52998's Avatar
Senior Member
Thanks Meter 53
Posts: 297
Join Date: Jan 2014
What was the last thing you did to the phone? Did you recently flash something? Try booting into fastboot: power volume down, if it boots to that your savable, but not even the HTC screen shows up when turning on?

Sent from my Rezound using xda-developers app. CyanogenMod 11. S-off
Main Phone:
HTC Rezound:PAC-Man 4.4.2 With SENSE!, Cyanogenmod 11, Sense 5
S-OFF using Rumrunner.
TWRP: 2.3.6.0/PhilZ Advanced CWM

iPad 1st Generation Jailbroken with Green pois0n . iOS 5.1.1
Droid Incredible: Stock (not for long hehe)
HTC EVO 4G the Original OG 4G: Everolv 4.2.2 ;D
 
SomeNamelessGuy
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Feb 2014
My phone hasn't been used for a long time, was stock after restoring to factory settings when last used. (used to be rooted with a custom ROM) Worked fine when last used, only stopped now. Can't boot into fastboot or recovery. Screen stays black.
 
AGKdrOId
Old
#4  
AGKdrOId's Avatar
Junior Member
Thanks Meter 0
Posts: 10
Join Date: Sep 2013
Location: Verde Valley, AZ
Quote:
Originally Posted by SomeNamelessGuy View Post
My phone hasn't been used for a long time, was stock after restoring to factory settings when last used. (used to be rooted with a custom ROM) Worked fine when last used, only stopped now. Can't boot into fastboot or recovery. Screen stays black.
the only time I've had this problem it was because I flashed an incompatible hboot... had to drop a PB31IMG.zip on sd card and shoot in the dark to install it. If you haven't done anything with the Hboot, then IDK. try dropping Hboot .92, 1.02, or 1.07 on sd card as PB31IMG.zip... when you boot, hold down vol - and power on. be patient, because you can't see....wait about 30 seconds and push vol+ to install the parsed hboot and then wait about 30 seconds more and push vol+ to reboot..hold down the vol- to hopefullly get into a visible bootloader. Other than that...maybe looking at a hardware problem...open up all the motherboard covers and see if anything is fried...Good luck! and be gentle with the ribbons if you tear it down!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes