Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Xperia Z1 C6903 Fully working but Black Screen / No Displaay??

OP Az-Tech

16th February 2014, 10:46 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
Hello Forum,

Newbie so excuse me if wrong section. I picked up a Xperia Z1 C6903 from eBay as spares/repairs (so I do not know history) turns out the phone is in working order (mirrored actions with my Xperia Z) but the screen display is black with no visuals (touch screen works).

Can someone tell me if they have experienced the same problem with the Z1 C6903 and if they managed to solve it?
(quite a few XZUltra mention SOD (Sleep Of Death) on forum but with no fix - but my problem is the phone is still active but no diplay)

I hoping this is a firmware issue and will attempt to root to original firmware as it is currently on the latest 257 FW - I have managed to take screenshot from the service menu.

So can i get advice - what is the best way to root it to original firmware (bootloader locked) with minimal risk of bricking it as i have never rooted a phone before but I am tech savy & quick learner - PC companion or Flash tool?

Thanks in advance

(http://forum.xda-developers.com/show....php?t=2574764)
(http://forum.xda-developers.com/show....php?t=2452814)



Last edited by Az-Tech; 17th February 2014 at 02:32 AM.
16th February 2014, 11:30 PM   |  #2  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 617
 
2,984 posts
Join Date:Joined: Jun 2008
How did you do the screenshots if the Display is Black all the time? or is not? Is sometime still working like in boot when the logo Sony appear that mean is not faulty and is software related.

Use Flashtool and flash a Stock Generic Unbranded FTF for your model. Let's see if the display will be back.
The Following User Says Thank You to eclyptos For This Useful Post: [ View ]
17th February 2014, 02:17 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
The screen is always black but responsive to touch - I placed the Xperia Z1 beside my Xperia Z and mirrored each touch to get to the service menu - it took a few attempts but I managed to take screenshot and NFC image to my Xperia Z

I think the problem is with display maybe hardware or software as i am not sure how it may have been caused as i do not know the history - but strange how it still operates

will read more in depth on flashing before attempting to do it as i have no experince in this field YET and do not want to brick it
17th February 2014, 11:37 AM   |  #4  
funky0308's Avatar
Recognized Themer
Flag Osijek
Thanks Meter: 5,543
 
6,789 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by Az-Tech

The screen is always black but responsive to touch - I placed the Xperia Z1 beside my Xperia Z and mirrored each touch to get to the service menu - it took a few attempts but I managed to take screenshot and NFC image to my Xperia Z

I think the problem is with display maybe hardware or software as i am not sure how it may have been caused as i do not know the history - but strange how it still operates

will read more in depth on flashing before attempting to do it as i have no experince in this field YET and do not want to brick it


Hehe...nice idea how to take a screenshots :thumbup:

BTW - just go to flash mode and flash via flashtool 257 firmware.

Sent from my C6903 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes