FORUMS

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

Droid Turbo Lollipop OTA, 2015 Moto G Leaked – XDA TV

Android Lollipop for the Droid Turbo has been released. That and much more … more

Omnirom stuck in bootanimation for Galaxy Mega 6.3

2,773 posts
Thanks Meter: 4,690
 
By Silesh.Nair, Senior Member on 19th February 2014, 06:59 AM
Post Reply Subscribe to Thread Email Thread
Hi,

I have been trying to get omnirom to work for the Galaxy Mega 6.3, but its stuck in bootanimation. The first build I tried worked, but none of the build that I compiled this month worked.

The logcat shows displayeventreceiver / activedisplay errors mainly.

Code:
E/DisplayEventReceiver(  890): Display event receiver pipe was closed or an error occurred.  events=0x9
E/FlpHardwareProvider(  890): Error hw_get_module 'flp': -2
W/InputDispatcher(  890): channel '418a3790 ActiveDisplayView (server)' ~ Consumer closed input channel or an error occurred.  events=0x9
E/InputDispatcher(  890): channel '418a3790 ActiveDisplayView (server)' ~ Channel is unrecoverably broken and will be disposed!
W/InputDispatcher(  890): channel '418ac6b8 StatusBar (server)' ~ Consumer closed input channel or an error occurred.  events=0x9
E/InputDispatcher(  890): channel '418ac6b8 StatusBar (server)' ~ Channel is unrecoverably broken and will be disposed!
Can someone help me?
Attached Thumbnails
Click image for larger version

Name:	device-2014-02-19-121722.png
Views:	87
Size:	44.1 KB
ID:	2587950  
Attached Files
File Type: txt log.txt - [Click for QR Code] (485.7 KB, 18 views)
 
 
19th February 2014, 09:06 PM |#2  
Senior Recognized Developer
Flag Owego, NY
Thanks Meter: 25,289
 
Donate to Me
More
The massive amount of null fd spam should've been obvious as the root problem, although admittedly how to solve it isn't entirely obvious. (to be honest, needs to be in the wiki...)

https://github.com/omnirom/android_k...245bc9632a3cae

You'll need to clobber after revering that aosp frankendisplay commit
Last edited by Entropy512; 19th February 2014 at 09:10 PM.
The Following User Says Thank You to Entropy512 For This Useful Post: [ View ]
20th February 2014, 05:59 AM |#3  
OP Senior Member
Thanks Meter: 4,690
 
More
Thanks @Entropy512!!!!

Got it to boot. Now next issue. No touchscreen input. Any inputs to sort that.
Attached Files
File Type: txt log.txt - [Click for QR Code] (382.1 KB, 4 views)
The Following User Says Thank You to Silesh.Nair For This Useful Post: [ View ]
20th February 2014, 01:58 PM |#4  
lagloose's Avatar
Senior Member
Thanks Meter: 3,006
 
Donate to Me
More
Obviously got the same problem with my build for Nexus S here...
ROM does not boot or booted once and can't be rebooted anymore (stuck in boot loop) Attached 'reboot' parts of logcat... No idea at the moment where the problem is. All my builds worked fine before. Last working build was created at 5.th of February...
Attached Files
File Type: txt logcat.txt - [Click for QR Code] (412.8 KB, 3 views)
21st February 2014, 02:39 PM |#5  
lagloose's Avatar
Senior Member
Thanks Meter: 3,006
 
Donate to Me
More
Solved. There seems to be a Problem with the new bootanimation for some devices. Just remove it or exchange with old one...

Gesendet von meinem Nexus S mit Tapatalk
21st February 2014, 04:09 PM |#6  
Senior Recognized Developer
Flag Owego, NY
Thanks Meter: 25,289
 
Donate to Me
More
Quote:
Originally Posted by lagloose

Solved. There seems to be a Problem with the new bootanimation for some devices. Just remove it or exchange with old one...

Gesendet von meinem Nexus S mit Tapatalk

ok that's WEIRD
21st February 2014, 11:35 PM |#7  
OP Senior Member
Thanks Meter: 4,690
 
More
OK. Solved all but one issue. HW decoder.
Last edited by Silesh.Nair; 22nd February 2014 at 12:05 AM.
24th February 2014, 07:38 AM |#8  
jeffsf's Avatar
Recognized Contributor
Flag San Francisco
Thanks Meter: 982
 
Donate to Me
More
There is a fix in the works so that low-memory devices can have the flashy, new boot animation and not crash.

https://gerrit.omnirom.org/#/c/5597/

---
Posted from whatever phone booted today
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes