Default HTC ONE softbricked flashing wrong firmware

I am creating this thread as suggested by @nkk71 to solve a softbricked HTC ONE. I usually deal with samsung and Sony androids so this is to find community help.

Issue, I have recently received an HTC ONE which has been rooted, TWRP installed and was S-ON. The baseband was lost, with 4.4.2 verizone version flashed.

Here are the details:

 
version: 0.5
version-bootloader: 1.54.0000
version-baseband: 1.12.42.1104
version-cpld: None
version-microp: None
version-main:
version-misc: PVT SHIP S-ON
serialno: HT36xxxxxxxxxxx <----removed
imei: 35xxxxxxxxxxxxx < ---removed
meid: 00000000000000
product: m7_ul
platform: HBOOT-8064
modelid: PN0712000
cidnum: GOOGL001
battery-status: good
battery-voltage: 4317mV
partition-layout: Generic
security: on
build-mode: SHIP
boot-mode: FASTBOOT
commitno-bootloader: dirty-94cf81a8fd
hbootpreupdate: 11
gencheckpt: 0



Some initial remarks from @nkk71 :

1- radio is a CDMA version (from the looks of it)
2- version-main is missing
3- the device is now S-ON, very likely it was S-OFF at one point, and s(he) went S-On because of panic (which was probably the worst idea ever)


---
Notes:
I did re-flash CWM touch and also flashed a CWM flashable stock ROM
Code:
Stock_Rooted_4.4.2_KOT49H.H1_Odex.zip
I also relocked the boot (as seen in the pic, to hopefully flash a stock RUU


Current status:
The phone boots
I can also access the OS fully load but reboot just about a second or two on home screen.
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	1039
Size:	75.6 KB
ID:	2588225