Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,206 Members 43,760 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Anyone have ethernet access for N7 LTE working yet?

Tip us?
 
AlexParx
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Jan 2009
Default [Q] Anyone have ethernet access for N7 LTE working yet?

Hi

I am trying to get ethernet access on the N7 LTE using a USB OTG cable and USB-Ethernet adapter. Has anyone had success with patching the stock images, or is there a development ROM that has this available.

Thanks

Alex

 
Pandae
Old
#2  
Pandae's Avatar
Senior Member
Thanks Meter 45
Posts: 183
Join Date: Dec 2013
Yes. Take a look here. http://code.google.com/p/android/issues/detail?id=58868

There's a lot to go through, but the condensed version is that a fellow made a new boot image that supports Ethernet connections via USB OTG. Your bootloader must be unlocked in order to flash the boot image.
 
AlexParx
Old
(Last edited by AlexParx; 10th February 2014 at 12:19 PM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Jan 2009
Thanks, but it is still not working.

I have downloaded the N7 LTE patched boot image from the thread and flashed it. My N7 boots successfully but using the OTG cable + USB ethernet adapter the ethernet is not recognised (I am using a USB 2.0 ethernet adapter from the company 'Plugable')

I have also tried to extract, edit and repack an official rom, but I get an error during the repack stage. I am trying to use Android kitchen and cygwin.

So I am stuck. Help!
 
AlexParx
Old
(Last edited by AlexParx; 11th February 2014 at 12:45 AM.)
#4  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Jan 2009
Update.

Using the patched boot image, then rooting, and then issuing the command 'dhcpcd eth0' in terminal I can browse the internet in Chrome. However GMail and Play store don't work connect correctly
 
AlexParx
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Jan 2009
Everything seems to work now except Youtube app.

Frustrating thing is that I have to connect to a wifi source, disconnect, and then ethernet works (I am not using a sim). If I dont connect first to wifi, the apps dont see the connection!
 
AlexParx
Old
(Last edited by AlexParx; 19th February 2014 at 05:06 PM.)
#6  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Jan 2009
I went to use the Microsoft Remote Desktop app over ethernet and the device does not see a network! Would have thrown the device in the garbage disposal shute (if I had one).

Finally there is a solution to get ethernet working on the Nexus 7 2013 LTE with all apps without connecting to Wifi first and praying to the heavens. I found that installing the latest stable Cyanogen Rom works, so I can now use this needlessly hampered device for what I purchased it for.

Hope this saves someone some valuable time, unnecessarily wasted by ? at Goggle for reasons unfathomable.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Run, Jump, and Shoot in Tales of Ciaxia

There are certain types of games that have become paramount of the portable gaming world. As we have … more

Samsung Gear Live Stock Firmware Image Pulled, Temp Root

Just yesterday,XDA Recognized Developer and TV ProducerAdamOutlertore apart … more

Draw a Line and Let Your Device Do the Rest with LineitApp

Over the years, since evenbefore Android entered the scene, we have striven to … more

[APK] Chrome Beta 37 Brings First Traces of Material Design

With Android L on the horizon, it’s no surprise that Google’s … more