FORUMS

[Q] Using transparent sys bars without breaking compatibility with older versions

35 posts
Thanks Meter: 2
 
By domiq123, Member on 19th February 2014, 08:37 PM
Post Reply Subscribe to Thread Email Thread
Hi,
I'm developing an app and to make it look better I would like to use transparent system bars on kitkat devices but when I set it up it forces me to move the minimum api level to kitkat (19) but that means my app is only gonna show up on kitkat devices, right? So I was searching around the web to see if it's possible to use it on kitkat while keeping the compatibility for ics or jb. I couldn't find anything so I'm posting here.


EDIT 1:
it is possible, pushbullet features that functionality while compatible with ics
Last edited by domiq123; 19th February 2014 at 08:52 PM. Reason: research
 
 
20th February 2014, 09:48 AM |#2  
sak-venom1997's Avatar
Senior Member
Flag Lucknow
Thanks Meter: 414
 
Donate to Me
More
if(Build.VERSION.SDK_INT >= 19)
{
// your kitkat specific code
}

also add SupressLint("NewApi")
annotation to your method

voilla no more compiler issues

Sent from my GT-S5302 using Tapatalk 2
Post Reply Subscribe to Thread

Tags
kitkat, transparent system bars

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes