5,596,066 Members 33,450 Now Online
XDA Developers Android and Mobile Development Forum

Xperia Z1 DEAD after updating to latest firmware

Tip us?
 
eclyptos
Old
#211  
eclyptos's Avatar
Senior Member
Thanks Meter 477
Posts: 2,482
Join Date: Jun 2008
Location: Planet Earth
Quote:
Originally Posted by Rekoil View Post
Makes sense if he has a branded device.
No difference because he can flash directly 4.3 Generik UK. There is no sense update to 4.3 via PC Compagnion when he will use Flashtool anyway.
IF I HELPED DO NOT SAY THANKS, CLICK IT.
My Evolution: Sony Xperia Z1 - UB + 4.3 Rooted + Deodexed, HTC HD2, HTC Diamond 2, HTC HD Blackstone, Nokia 7070 Prism, Qtek 9100, Nokia 3100, Motorola T720i, Nokia 3310, Sony Ericson PF 768 (Blue)
 
Rekoil
Old
#212  
Rekoil's Avatar
Senior Member
Thanks Meter 327
Posts: 904
Join Date: May 2008
Location: Göteborg
Quote:
Originally Posted by eclyptos View Post
No difference because he can flash directly 4.3 Generik UK. There is no sense update to 4.3 via PC Compagnion when he will use Flashtool anyway.
I think he meant he felt safer using PC Companion when doing the 4.2 -> 4.3 transition, and then just flashing an unbranded ROM after the upgrade has completed. Makes sense to me.
sony xperia z1 c6903 metallic purple

previous phones
sony xperia z c6603 royal purple - faulty backplate, returned
samsung galaxy s3 lte (gt-i9305n) marble white - sold... no more samsungs for me
htc one x glacier white - dead :'(
apple iphone 4s white - sold
 
eclyptos
Old
#213  
eclyptos's Avatar
Senior Member
Thanks Meter 477
Posts: 2,482
Join Date: Jun 2008
Location: Planet Earth
Quote:
Originally Posted by Rekoil View Post
Makes sense to me.
Tell me how it make sense if he will wipe the update using flashtool?
IF I HELPED DO NOT SAY THANKS, CLICK IT.
My Evolution: Sony Xperia Z1 - UB + 4.3 Rooted + Deodexed, HTC HD2, HTC Diamond 2, HTC HD Blackstone, Nokia 7070 Prism, Qtek 9100, Nokia 3100, Motorola T720i, Nokia 3310, Sony Ericson PF 768 (Blue)
 
Rekoil
Old
#214  
Rekoil's Avatar
Senior Member
Thanks Meter 327
Posts: 904
Join Date: May 2008
Location: Göteborg
Quote:
Originally Posted by eclyptos View Post
Tell me how it make sense if he will wipe the update using flashtool?
Because we don't know what PC Companion does that maybe FlashTool misses. Perhaps some magic is happening behind the scenes that FlashTool just gets plain wrong. Only flashing the system partition is a simple task that I'll gladly leave to FlashTool, but when doing bootloader stuff I'd rather use the official means.
sony xperia z1 c6903 metallic purple

previous phones
sony xperia z c6603 royal purple - faulty backplate, returned
samsung galaxy s3 lte (gt-i9305n) marble white - sold... no more samsungs for me
htc one x glacier white - dead :'(
apple iphone 4s white - sold
 
xasbo
Old
#215  
Senior Member
Thanks Meter 44
Posts: 250
Join Date: Feb 2012
Quote:
Originally Posted by Rekoil View Post
Because we don't know what PC Companion does that maybe FlashTool misses. Perhaps some magic is happening behind the scenes that FlashTool just gets plain wrong. Only flashing the system partition is a simple task that I'll gladly leave to FlashTool, but when doing bootloader stuff I'd rather use the official means.
@gavinlew wasn't even talking about unlocking the bootloader, though. I see what you're after, but hundreds of folks have flashed/unlocked/relocked plenty of times without having problems. FlashTool is pretty damn stable at this point.
 
gallardo5
Old
#216  
gallardo5's Avatar
Senior Member
Thanks Meter 206
Posts: 943
Join Date: Apr 2011
Location: Glasgow
Quote:
Originally Posted by Rekoil View Post
Because we don't know what PC Companion does that maybe FlashTool misses. Perhaps some magic is happening behind the scenes that FlashTool just gets plain wrong. Only flashing the system partition is a simple task that I'll gladly leave to FlashTool, but when doing bootloader stuff I'd rather use the official means.






Quote:
Originally Posted by xasbo View Post
@gavinlew wasn't even talking about unlocking the bootloader, though. I see what you're after, but hundreds of folks have flashed/unlocked/relocked plenty of times without having problems. FlashTool is pretty damn stable at this point.
It is pretty stable yet it still bricks some devices. It also makes sense to me as I bricked my xperia z1 flashing with flashtool. I bought another one, this time upgraded with PC companion and then used flashtool, and everything went fine, it just feels much safier after bricking one phone already

Sent from my C6903 using XDA Premium 4 mobile app
SE T290i>SE K700i>SE K750i>SE W580i>SE P900i>SE C902>Nokia 5230>HTC Wildfire>SE Xperia X10 mini>SE Xperia Arc S>HTC Wildfire>HTC Sensation>Sony Xperia S>HTC One X>LG Nexus 4>Sony Xperia Z1

And birth on 1994
 
rezaswandira
Old
#217  
Senior Member
Thanks Meter 22
Posts: 138
Join Date: May 2012
Location: Denpasar
Reading this thread makes me thinks.. I've read every single post here.
First of all i successfully flashed my phone, it boots up, it worked flawlessly with a new FW, though the battery goes from 80's to 20's (i forget the exact number)
Now from reading this thread, i assume that sony did something to the bootloader along with the update.
Why? Because it fixed the camera-bootloader bug.
This phone's camera use something called "BIONZ image processing engine", which is similar to BE/X-reality. This BIONZ manages the camera to work. The BE had lost with the DRM keys since xperia arc while unlocking bootloader.
With 4.2.2 the BIONZ image processor is lost with the X-Reality engine and the DRM. While on 4.3, the BIONZ is not lost with them.

Got my point?
Why is the BIONZ engine doesnt lost with 4.3? And im pretty sure it is protected with DRM because it's sony's property and sony for sure doesnt want to this feature ported to another phone

I think the camera bug bootloader fix causes this issue

Sent from my C6903 using Tapatalk
The Following User Says Thank You to rezaswandira For This Useful Post: [ Click to Expand ]
 
Jorge Luis Silva
Old
#218  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2014
Default Help! Xperia z1 c6943

Help me! My Xperia Z1 6943 C, when connected to the battery he ascends the LEDs, but not power. I've tried the flashtools, unable to connect for 2 times only gave a side effect of the volume and turn right buttons did not work, then tried making new updates with other ROMs and now I can not connect again.
I look.
 
HeinekenAmstel
Old
#219  
Member
Thanks Meter 1
Posts: 37
Join Date: May 2012
Location: Athens
Quote:
Originally Posted by eclyptos View Post
After flashing you have to wait long time before he run up. So I don't know how long you just wait after that. I got different problem, I connect the phone via flashtool, I star the flash but the phone turn on by its self and the flash is cancelled. The best thing, nothing happen to my phone. What's that?
I get the same prob. I think you need to prepare the firmware for flashing before you connect the phone and when the window promting you to connect it pops up, you connect it and all goes great

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes