Best Alarm App for Android?

There are tons of choices to choose from when looking for a great alarm app for Android. While the stock … more

Unofficial CM12.1 Available for Moto E 2014

While Motorola is yet to release a final 5.0.2 build for the Moto E 2014, XDA Senior … more

Pinsy Brings Social Sketching To Your Watch & Phone

Did you watch Apple’s VP draw on his wrist during the Apple Watch announcement … more

CyanogenMod 12.1 for Samsung Galaxy S5

Android 5.1 is slowly putting its mark in the custom ROM world. CyanogenMod 12.1 is available to … more
Post Reply Subscribe to Thread Email Thread

Need help for rooting, how to enable USB ADB Access

5th February 2014, 09:34 PM   |  #1  
OP Member
Thanks Meter: 1
 
66 posts
Join Date:Joined: Jul 2010
When I connect the phone (SCH-I545, verizon) to the PC, I see two choices shown under the pulldown menu: Connect as Media Device (MTP), or Camera (PTP). And the MTP choice is checked automatically.

I believe my phone has the latest OTA update. And I have turned on the Developer Option, check the "USB Debugging".

Did I miss anything? Please help.
5th February 2014, 09:47 PM   |  #2  
k1mu's Avatar
Recognized Contributor
Flag Virginia
Thanks Meter: 1,592
 
1,925 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Quote:
Originally Posted by newshook

When I connect the phone (SCH-I545, verizon) to the PC, I see two choices shown under the pulldown menu: Connect as Media Device (MTP), or Camera (PTP). And the MTP choice is checked automatically.

I believe my phone has the latest OTA update. And I have turned on the Developer Option, check the "USB Debugging".

Did I miss anything? Please help.

Are the drivers installed?
When you plugged in your phone, did the permission prompt for ADB appear?
What devices show up in the Windows device manager? (Windows/Break, then device manager.) You should see a "Samsung Android ADB Interface" appear if all is correct.
5th February 2014, 10:13 PM   |  #3  
OP Member
Thanks Meter: 1
 
66 posts
Join Date:Joined: Jul 2010
Yes, the drivers are installed. I first installed the samsung usb driver, I installed the kies package given I don't see the USB debugging permission message. Just tried the same thing in ubuntu, same result.

I must have missed something.... Just don't know what it is ....

The phone's developer option is on and debugging is checked,
On PC side the driver is installed. In fact, when I tested this in ubuntu, I ran "adb devices", it saw the phone ....

Quote:
Originally Posted by k1mu

Are the drivers installed?
When you plugged in your phone, did the permission prompt for ADB appear?
What devices show up in the Windows device manager? (Windows/Break, then device manager.) You should see a "Samsung Android ADB Interface" appear if all is correct.

5th February 2014, 10:19 PM   |  #4  
OP Member
Thanks Meter: 1
 
66 posts
Join Date:Joined: Jul 2010
Got it!

The message showed up after I toggled between those two choices. It was done in ubuntu. Thanks very much.

Quote:
Originally Posted by k1mu

Are the drivers installed?
When you plugged in your phone, did the permission prompt for ADB appear?
What devices show up in the Windows device manager? (Windows/Break, then device manager.) You should see a "Samsung Android ADB Interface" appear if all is correct.

21st February 2014, 12:12 PM   |  #5  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
This device is not supported. HELP!
Hi!

I have done everything mentioned above, but I get an error during the install. Have attached a print screen from the install.
Please help me.

Without working SIM atm because operator lock code recieved from my mobile operator doesn't work.

Best regards

Oscar.
Attached Thumbnails
Click image for larger version

Name:	SAMSUNG SUG.jpg
Views:	95
Size:	120.2 KB
ID:	2592138  
21st February 2014, 12:38 PM   |  #6  
Mistertac's Avatar
Recognized Contributor
Flag Springfield, Ma
Thanks Meter: 2,578
 
4,581 posts
Join Date:Joined: Oct 2013
More
Deleted
Sent From My Verizon S4
Last edited by Mistertac; 21st February 2014 at 12:40 PM.
21st February 2014, 03:55 PM   |  #7  
k1mu's Avatar
Recognized Contributor
Flag Virginia
Thanks Meter: 1,592
 
1,925 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Quote:
Originally Posted by 92oscbra

Hi!

I have done everything mentioned above, but I get an error during the install. Have attached a print screen from the install.
Please help me.

Without working SIM atm because operator lock code recieved from my mobile operator doesn't work.

Best regards

Oscar.

The "this device is not supported" message means that your phone (m0? What's that?) is patched by the vendor to fix the flaw that Saferoot uses to root it.
You'll have to find another tool to root your phone.
21st February 2014, 08:28 PM   |  #8  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
Thank you! :)
Quote:
Originally Posted by k1mu

The "this device is not supported" message means that your phone (m0? What's that?) is patched by the vendor to fix the flaw that Saferoot uses to root it.
You'll have to find another tool to root your phone.

Okei! Thank you for your help. It is a Galaxy SIII.

Just managed to update to Android 4.3 Jellybean at the same time as I changed mobile network operator. Mobile was locked and the NCK code from operator didn't work. Probably need the MCK (Defreeze) code to unlock which operator doesn't have access to. So no mobile phone for me atm.

I used VRoot and used a change-to-SuperSu guide and it worked. Couldn't find anyway to remove the network lock though..


Couldn't post the links on how I rooted and changed to SuperSu since I'm a n00b at this site.


And sorry for maybe posting this in wrong thread!


Best regards

Oscar

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes