5,597,707 Members 34,301 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Hardware key lights turn on when screen off

Tip us?
 
creativeusernamea
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 19
Join Date: Dec 2013
Default [Q] Hardware key lights turn on when screen off

Hi,
I've been using the stable version of CM 10.1.3 since Christmas and have experienced no issues whatsoever, it's worked flawlessly...until today. I woke up this morning to find my phone charging as I had left it, but the hardware lights were turned on. Thinking it was odd, I turned the screen on then off again and the lights turned back off as they should. When I came back after breakfast however, they were on again! This has been happening all day; I'd check my phone and find that the lights had turned on. I can't seem to find any pattern (like always 2 minutes after screen off) and it doesn't even happen all the time - I left it for half an hour and they didn't turn on, but the next time I turned off the screen they turned on again after a few minutes.
Has anyone else experienced this issue and, if so, how did you fix it? I haven't yet done a factory reset as I was hoping someone else would have a good fix that doesn't mean I have to reconfigure everything.
I've also noted signal dropping a lot today, but after turning the phone off and reinserting the SIM card it seems to be back for good (well, an hour at least). Could this be related?
Any help would be great
 
joaoumbelino
Old
#2  
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Jan 2014
Quote:
Originally Posted by creativeusernamea View Post
Hi,
I've been using the stable version of CM 10.1.3 since Christmas and have experienced no issues whatsoever, it's worked flawlessly...until today. I woke up this morning to find my phone charging as I had left it, but the hardware lights were turned on. Thinking it was odd, I turned the screen on then off again and the lights turned back off as they should. When I came back after breakfast however, they were on again! This has been happening all day; I'd check my phone and find that the lights had turned on. I can't seem to find any pattern (like always 2 minutes after screen off) and it doesn't even happen all the time - I left it for half an hour and they didn't turn on, but the next time I turned off the screen they turned on again after a few minutes.
Has anyone else experienced this issue and, if so, how did you fix it? I haven't yet done a factory reset as I was hoping someone else would have a good fix that doesn't mean I have to reconfigure everything.
I've also noted signal dropping a lot today, but after turning the phone off and reinserting the SIM card it seems to be back for good (well, an hour at least). Could this be related?
Any help would be great

I have the same problem. But i have CM11. Help please
 
creativeusernamea
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 19
Join Date: Dec 2013
Quote:
Originally Posted by joaoumbelino View Post
I have the same problem. But i have CM11. Help please
This was really strange. The day after making this post I did a factory reset, which didn't help so I flashed a 4.4.2 Vanir Nightly. After a while this issue developed again on there, so I decided to change to official CM 11. The issue continued for an afternoon, but overnight it fixed itself - I haven't dropped signal or had the light issue for a few days now. I'd still like to know what the issue was though in case it happens again! Here's hoping yours fixes itself too
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes