Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Relay 4g proximity sensor fix?

OP d4dd7wh0

22nd February 2014, 01:37 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: May 2012
Hello again everyone! Has anyone else had an issue during calls with the proximity sensor? When I take the phone away frorm my ear the screen does not away come back on.. I have googled it wihtout much luck. Does anyone know any tips to use to recalibrate it on cm11 with a relay 4g? The only thing I found was this link [I can't post links, but google 'calibrate proximity sensor android legend' should be 1st result] but towards the end the *#0*# dialer code used to test it doesnt work so im not sure if the fix will work or not. Since I expect all of you to be using your Relay 4g's as a phone, you guys must have done something. What do you all suggest? Thank you all for your help!!

Dominic
22nd February 2014, 03:14 AM   |  #2  
REV3NT3CH's Avatar
Recognized Contributor
Flag Oroville
Thanks Meter: 5,068
 
2,787 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Quote:
Originally Posted by d4dd7wh0

Hello again everyone! Has anyone else had an issue during calls with the proximity sensor? When I take the phone away frorm my ear the screen does not away come back on.. I have googled it wihtout much luck. Does anyone know any tips to use to recalibrate it on cm11 with a relay 4g? The only thing I found was this link [I can't post links, but google 'calibrate proximity sensor android legend' should be 1st result] but towards the end the *#0*# dialer code used to test it doesnt work so im not sure if the fix will work or not. Since I expect all of you to be using your Relay 4g's as a phone, you guys must have done something. What do you all suggest? Thank you all for your help!!

Dominic

is it doing it for you in any rom or just one rom in particular?
22nd February 2014, 03:38 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by REV3NT3CH

is it doing it for you in any rom or just one rom in particular?

CM11-M3 is the only one I've had the issue with.. It's happened during the day, but I spoke to my wife on the phone tonight and outside at night it worked fine. I have been using this rom for 2days so far and i dont make too many phone calls, but its happened roughy half the time..
22nd February 2014, 03:53 AM   |  #4  
REV3NT3CH's Avatar
Recognized Contributor
Flag Oroville
Thanks Meter: 5,068
 
2,787 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Quote:
Originally Posted by d4dd7wh0

CM11-M3 is the only one I've had the issue with.. It's happened during the day, but I spoke to my wife on the phone tonight and outside at night it worked fine. I have been using this rom for 2days so far and i dont make too many phone calls, but its happened roughy half the time..

ok that ensures its the Rom and not hardware...ill lok into it a bit more but its an issue in hex coding within /system/lib/hw/ and was built with this issue from source....had this issue on my last device and was fixed
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes