Post Reply

[Q] How to Flash TWRP with no filesystem.(CWM will talk adb, but Fastboot won't)

23rd February 2014, 01:53 AM   |  #11  
Gizmoe's Avatar
Senior Member
Flag Spokane
Thanks Meter: 827
 
2,056 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by disconnecktie

His recovery is the latest cwm actually. The issue he is getting (status 7) is because the format of the updater script in the rom zips isn't acceptable for the recovery. See this post from Phil.

http://forum.xda-developers.com/show...php?p=43707326

Sent from my HTC6500LVW using Tapatalk

That basically was my point but I suppose it read a little different. The version of cwm doesn't accept the new format of 5 arguments. Philz and twrp do. I dont know the status of the current version of cwm but assumed they would have fixed that by now.
The Following User Says Thank You to Gizmoe For This Useful Post: [ View ]
23rd February 2014, 01:55 AM   |  #12  
disconnecktie's Avatar
Senior Member
Thanks Meter: 1,178
 
5,023 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by Gizmoe

That basically was my point but I suppose it read a little different. The version of cwm doesn't accept the new format of 5 arguments. Philz and twrp do. I dont know the status of the current version of cwm but assumed they would have fixed that by now.

He could try doing like Phil suggests and try swapping the updater-binary with one from a newer Rom to see if that would make it flash.

Sent from my HTC6500LVW using Tapatalk
The Following User Says Thank You to disconnecktie For This Useful Post: [ View ]
23rd February 2014, 01:58 AM   |  #13  
Gizmoe's Avatar
Senior Member
Flag Spokane
Thanks Meter: 827
 
2,056 posts
Join Date:Joined: Sep 2011
More
@wantasmartcookie yes you should try a newer update binary and see what happens as @disconnecktie suggested.

Sent from my HTC6500LVW using Tapatalk
23rd February 2014, 05:16 AM   |  #14  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by cmlusco

You need to find a rom that has an updated updater script. I assume the status 7 error you get is (got 4 arguments, expects 5). You also said it shows up as a galaxy when in cwm. This leads me to believe you have the wrong driver installed. http://vzw1files.dyndns.org/ADB/ADB_Drivers.zip And as you already figured out usb3 doesnt play nice with adb.

Just installed the drivers on my old PC (w/usb 2.0) and got the SDK installed and running. I was able to get Fastboot to respond. I flashed the latest TWRP 2.6.3.3 (and 2.6.3.0) and it goes into a boot loop. I see the HTC w/red text saying it boots into recovery. Screen goes black. normal HTC boot screen comes back an boot loops to that scream. I believe a few cuss words are in order at this point. At least I'm able to flash recoveries now. Going to go try Philz and possibly go back to CWM and see if I can get an image with the correct install format.

Appreciate the help from everyone in this thread so far.
23rd February 2014, 05:19 AM   |  #15  
cmlusco's Avatar
Senior Member
Flag Michigan City, IN
Thanks Meter: 922
 
3,138 posts
Join Date:Joined: Nov 2010
Donate to Me
More
Try this before you flash the recovery use the command
Code:
fastboot erase recovery
If that dosent work, flash back to stock recovery, reboot the phone, then flash back to twrp. By the way the latest twrp is 2.6.3.4. http://vzw1files.dyndns.org/RECOVERIES/ You could also flash twrp thru RUU mode with the zip file from that site.
Last edited by cmlusco; 23rd February 2014 at 05:25 AM.
The Following User Says Thank You to cmlusco For This Useful Post: [ View ]
23rd February 2014, 05:43 AM   |  #16  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Feb 2014
Just recovered my phone! I was able to install the latest Philz recovery. Unchecked the "do not use old installer" option (after getting the expected 5 got 4 arg error) and installed Ecliptic 1.3. Thank you everyone for your help!
23rd February 2014, 06:30 AM   |  #17  
Gizmoe's Avatar
Senior Member
Flag Spokane
Thanks Meter: 827
 
2,056 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by wantasmartcookie

Just recovered my phone! I was able to install the latest Philz recovery. Unchecked the "do not use old installer" option (after getting the expected 5 got 4 arg error) and installed Ecliptic 1.3. Thank you everyone for your help!







Quote:
Originally Posted by wantasmartcookie

Just installed the drivers on my old PC (w/usb 2.0) and got the SDK installed and running. I was able to get Fastboot to respond. I flashed the latest TWRP 2.6.3.3 (and 2.6.3.0) and it goes into a boot loop. I see the HTC w/red text saying it boots into recovery. Screen goes black. normal HTC boot screen comes back an boot loops to that scream. I believe a few cuss words are in order at this point. At least I'm able to flash recoveries now. Going to go try Philz and possibly go back to CWM and see if I can get an image with the correct install format.

Appreciate the help from everyone in this thread so far.

Congrats. I figured it was a pc issue being unable to use fastboot. Glad you got your phone back.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes