Exclamation [HELP]4G not working

OK this one is going to be a little weird I have an T-Mobile HTC ONE S 2 of them
Both show 4G however one gives 4g Speeds and the other well doesn't I get EDGE speeds instead

when I dial *#*#4636#*#*

I get

Network type HSDPA

But when i change the bands to USA it only gives me EDGE which leads me to assume that I was never on a 4g network

So what can I do

I followed this method and doesn't seem to work


Code:
Originally Posted by billydroid  View Post
Holy ****!! I got it working! Thus it is proved this is not hardware related. It just got borked from a bad flash.

I tried following the previously stated steps with no success. This is how i did it.

This was all done without my SIM card in.

im S-off with a tmo cid and im in the USA so just make sure your flashing the appropriate stuff for your region.

First i used the 3.14 Tmo Ruu.exe (returning to stock sense jb)

then flashed the latest twrp recovery for the ville (s4)

Moved the mmcblk0p20 over to the root of my sdcard (i actually pulled this file from make fathers already working device)

Rebooted into twrp (custom recovery)

I ran the adb shell and issued the command "dd if=/sdcard/mmcblk0p20 of=/dev/block/mmcblk0p20". But for good measure.While i was in adb shell i also issued "cp /sdcard/mmcblk0p20 /dev/block/"

Then rebooted in fastmode mode.

Then once there issue "fastboot oem rebootRUU" 

Then "fastboot flash zip firmware.zip" ( Region Specific)

Then "fastboot reboot-bootloader"

Then from Hboot menu booted back in twrp (custom recovery)

Wiped my internal memory (this was per the instructions of the original thread w/ this fix)

rebooted system, let it fully boot and sit for a few mins

powered down and put my SIm back in and rebooted

Now i have full working 4G service 

Im not sure if all the stuff i did was necessary, some was redundant, but it works. So whatever.