Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,869 Members 39,302 Now Online
XDA Developers Android and Mobile Development Forum

Samsung Apps/TTS issues

Tip us?
 
arnemetis
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Oct 2013
Default Samsung Apps/TTS issues

Hello everyone,I'll start with some quick background. I finally updated my S4 from ME7 to MK2, and rooted it using saferoot. For a while, I haven't been able to update samsung apps, such as s health. I figured it was related to me being behind, but now it doesn't appear so.

Samsung App store just doesn't work for me. No matter if i try to update an existing app, or get any new app, when I click the free button (which I presume installs and/or updates the app), the app dims and there is a spinning circle in the middle of the screen. I see this same circle when loading new parts of the app store for the first time, so it is certainly indicating something is loading. I have even tried gettign a small game that was only 1MB and let it sit for 20 minutes, came back and it was still spinning. I updated the app by going to samsungapps.com in the browser, I tried clearing the cache or the data of the app, nothing seems to work.

S Voice/TTS - Upon firing up S voice, I was greeted with a very unpleasant robotic voice I had never heard before. Going into my language settings, I find it is using the samsung regular english us voice, not the high quality one. If I go to install voice data, and sample english (united states), it's the voice I'm used to! unfortunately it wants me to download the voice file, which is in Samsung Apps. Which doesn't work. Oddly, if I fire up google maps and have the navigation start taking me somewhere, it's using the proper voice! So that must mean I still have the voice file somewhere on the phone!

TL;DR
Samsung App Store hangs when trying to install/update any app
Samsung high quality TTS voice gone from s voice, yet still in use in maps/nav

Any help would be appreciated, thanks!
 
nolethemole
Old
#2  
Junior Member
Thanks Meter 2
Posts: 25
Join Date: Nov 2013
Location: Plaistow
Quote:
Originally Posted by arnemetis View Post
Hello everyone,I'll start with some quick background. I finally updated my S4 from ME7 to MK2, and rooted it using saferoot. For a while, I haven't been able to update samsung apps, such as s health. I figured it was related to me being behind, but now it doesn't appear so.

Samsung App store just doesn't work for me. No matter if i try to update an existing app, or get any new app, when I click the free button (which I presume installs and/or updates the app), the app dims and there is a spinning circle in the middle of the screen. I see this same circle when loading new parts of the app store for the first time, so it is certainly indicating something is loading. I have even tried gettign a small game that was only 1MB and let it sit for 20 minutes, came back and it was still spinning. I updated the app by going to samsungapps.com in the browser, I tried clearing the cache or the data of the app, nothing seems to work.

S Voice/TTS - Upon firing up S voice, I was greeted with a very unpleasant robotic voice I had never heard before. Going into my language settings, I find it is using the samsung regular english us voice, not the high quality one. If I go to install voice data, and sample english (united states), it's the voice I'm used to! unfortunately it wants me to download the voice file, which is in Samsung Apps. Which doesn't work. Oddly, if I fire up google maps and have the navigation start taking me somewhere, it's using the proper voice! So that must mean I still have the voice file somewhere on the phone!

TL;DR
Samsung App Store hangs when trying to install/update any app
Samsung high quality TTS voice gone from s voice, yet still in use in maps/nav

Any help would be appreciated, thanks!
Sorry to hear about your problem. If I understand correctly, you went to the Samsung website and tried to update the app? Here is the download link for Samsung apps application. I would re-install the Samsung Apps application and try to install the voice file.
http://content.samsung.com/mobile/us...MobileIntro.do
 
arnemetis
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Oct 2013
Hi nolethemole, thanks for the suggestion. Unfortunately, that did not help. i tried re installing, but it didn't work at first. I went into app manager, and uninstalled updates (can't remove it), and then I was able to install the file again. I followed your link, even though that's where I got it before, I figured maybe the download was bad. I am thinking perhaps something is left over from before the update. The update installed optical reader too, but upon firing it up it says it needs additional files, which of course, it can't download from the app store. I hate it, but I'm going to have to do a 100% wipe and reflash the full update. If that doesn't do it I guess I'll be returning it to Verizon as defective. Too many problems with this phone.
 
nolethemole
Old
#4  
Junior Member
Thanks Meter 2
Posts: 25
Join Date: Nov 2013
Location: Plaistow
Quote:
Originally Posted by arnemetis View Post
Hi nolethemole, thanks for the suggestion. Unfortunately, that did not help. i tried re installing, but it didn't work at first. I went into app manager, and uninstalled updates (can't remove it), and then I was able to install the file again. I followed your link, even though that's where I got it before, I figured maybe the download was bad. I am thinking perhaps something is left over from before the update. The update installed optical reader too, but upon firing it up it says it needs additional files, which of course, it can't download from the app store. I hate it, but I'm going to have to do a 100% wipe and reflash the full update. If that doesn't do it I guess I'll be returning it to Verizon as defective. Too many problems with this phone.
Try clearing your cache and data. Then, remove your samsung account then add it again.
 
arnemetis
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Oct 2013
Well I tried clearing data and cache, before you mentioned it and after, to no avail. As far as I can tell, there's no way to remove the samsung account. I gave up and did the full flash, phone is like new now. I'm starting the high quality download, and it's actually working. Something wonky must have carried over with the no wipe option for the update. Oh well, in the future I'll know to always do a full wipe.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes