5,605,250 Members 39,215 Now Online
XDA Developers Android and Mobile Development Forum

Sixaxis controller is here!

Tip us?
 
Brzina
Old
#1461  
Member
Thanks Meter 16
Posts: 61
Join Date: Oct 2013
Smile fake works great

Hello, I have just bought this fake "sony" controler, and everything is working great What is this new vibrate function ? My phone vibrates, but not controler How to make controler to vibrate ? thanks
Here are the pictures. Is this controler good ? Because, it works like original :P https://www.dropbox.com/sc/c6w44bamh5uwmft/-S698guKCO
 
bodziobsz
Old
(Last edited by bodziobsz; 28th December 2013 at 11:37 AM.)
#1462  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Dec 2007
Not working on HTC one mini they can't find bluetooth address. I have unlocked, rooted and soff.

Now working very well on new 4.3 rom

Wysłane z mojego HTC One mini przy użyciu Tapatalka
 
AGoberg
Old
(Last edited by AGoberg; 3rd December 2013 at 10:23 AM.) Reason: Removed my mac address
#1463  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Quote:
Originally Posted by c0ntagi0 View Post
Hi,
I've recently tried to use the instructions for pairing the dualshock controller to a Xperia S (rooted). I've noted the following issues with the whole installation process:
  1. The attached file (sixpair) doesn't download as a file, rather it opens up as a page as it doesn't have a file extension. Upon downloading, .txt extension is suffixed and it took some research on the web to figure out that it needs a '.c' extension to be added to it to run.
  2. The instructions point to 'ellert' website for downloading the libusb components, however, that website has gone ahead and updated it's libraries to support the latest mac os. Therefore, when it is executed, the sixpair.c file looks for the older version of the libusb libraries and therefore, fails.
  3. The entire process for the Mac seems to be an hunting exercise for libraries, correct versions, clarifying instructions, commandline etc. Meanwhile, over a ---, there are straightforward instructions and one sixaxis pair tool to pair dualshocks to ios devices as long as they're jailbroken. Simple and over in a matter of minutes. Would it be a lot to ask for a similar experience for paying Mac customers of dancing pixels tool?
Thanks

c0ntagi0
Have you had any luck? I can't get it to work, and I don't really have access to a PC so would like to be able to do it on OS X. When I run the ./sixpair MACADDRESS command all I get is this:

Code:
dyld: Library not loaded: /usr/local/lib/libusb-0.1.4.dylib
  Referenced from: /Users/path/sixpair
  Reason: image not found
Trace/BPT trap: 5
logout
I'm pretty sure I've installed libusb, but it might be in the wrong directory or something, but how would I change that?
 
ctomgee
Old
#1464  
Senior Member
Thanks Meter 901
Posts: 3,564
Join Date: Dec 2010
I am an LG Optimus 4x HD user. I just upgraded to v20b Europe Open, (4.1.2 Jellybean) and it broke SixAxis.

I have heard that SixAxis 0.5.7 works with this version of my firmware I just updated to. I'd love to be able to use SixAxis 0.5.7, but don't have a backup of it. I am a legitimate user of the app - I bought it full price from the Play Store. Any advice on where I can get a legit copy of 0.5.7 from?
I never wanted to have a signature, but it seems I must. Please do not PM me directly for technical support. I mean it! No exceptions! Thank you.

Everyone (esPECIALLY n00bs) should read this.
 
Damieok
Old
(Last edited by Damieok; 28th December 2013 at 12:39 AM.)
#1465  
Junior Member
Thanks Meter 5
Posts: 24
Join Date: Feb 2012
Has anyone had luck with the Moto G? It doesn't seem to recognize the inputs, but some apps like USB host controller do see the controller. Does Sixaxis Controller have its own implementation so that the controller will work even if the inputs are not recognized natively?

More information on my question here: Link

Edit: It works with Bluetooth once rooted just fine!
 
bloodhawk758
Old
#1466  
Junior Member
Thanks Meter 1
Posts: 10
Join Date: Dec 2013
Default Mtk6592

Ain't working on the new MTK6592, getting "Listening for controllers..."

Possible to fix this?
 
JamsMusicPlayer
Old
#1467  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Definitely gonna check this out.
 
crushking0
Old
#1468  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2014
Location: karachi
Unhappy i am so sad sixaxis controller not work

Quote:
Originally Posted by razor_blade View Post
Still, no dice. I will keep trying. Windows 7 32 bit.
my asus memo pad 173x rooted superdraggonpt v-1.1 r2 . ps3 controller not work with otg cable
 
invisiblek
Old
#1469  
invisiblek's Avatar
Recognized Developer
Thanks Meter 3142
Posts: 1,211
Join Date: Feb 2010
Location: Minnesota

 
DONATE TO ME
@sir_earl

We recently moved to a 3.4-based kernel on the HP Tenderloin for CyanogenMod builds. (we actually have a 3.0 kernel as well but experience the same issue).

The compatibility app says we should be good to go, and bluetooth works normally with other devices, but obviously the Sixaxis app does something strange being that it has to turn bluetooth off in order to work.

I'm wondering if you can shed some light on what exactly we need to support in our kernel/bt stack in order to get this working.

Currently the app just sits "Listenting for controllers..."
(It's not a user issue, I can set the MAC for my phone and it connects right up )

Thanks in advance.


#verizons3 | #sgs4 | #cm-htc @ freenode

READ THIS


 
wilflare
Old
#1470  
Senior Member
Thanks Meter 53
Posts: 770
Join Date: Sep 2013
thanks for the amazing work @sir_earl
thanks to you, my Note3 has become a pseudo nVidia Shield (with a DS3 as the controls)

I'm currently facing some input lag issues with my Dpad and Buttons while using Kainy
not sure if this is a Kainy issue or Sixaxis issue :/

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes