5,603,646 Members 36,860 Now Online
XDA Developers Android and Mobile Development Forum

MotoWpNoMo works for the Maxx permanent Write Protection Off

Tip us?
 
MicroMod777
Old
#31  
MicroMod777's Avatar
Recognized Contributor
Thanks Meter 1821
Posts: 3,988
Join Date: Apr 2010
Location: Los Angeles

 
DONATE TO ME
Were can get a custom recovery?

Sent from my VS980 4G using Tapatalk
 
Einsteindks
Old
#32  
Senior Member
Thanks Meter 44
Posts: 184
Join Date: Feb 2011
Used safestrap if you have a locked bootloader, Fish around and use Google To find one if you don't.

fat-fingered and Maxx-ed out.
 
bluh5d
Old
#33  
bluh5d's Avatar
Member
Thanks Meter 6
Posts: 54
Join Date: Dec 2010
Location: !Cloud Hack!
Worked on my Droid Maxx !!!
The Following User Says Thank You to bluh5d For This Useful Post: [ Click to Expand ]
 
Brenardo
Old
#34  
Senior Member
Thanks Meter 58
Posts: 509
Join Date: Nov 2010
I am having some trouble with the MotoWpNoMo.

I run and everything works until the final step. I get a FATAL: error.

Sent from my XT1080 using Tapatalk
 
braunyaur
Old
#35  
Junior Member
Thanks Meter 1
Posts: 2
Join Date: Feb 2014
Default Worked on XT1080

Went from rooted 4.2.2 to rooted 4.4 using the methods from jcase.

I had some issues with MotoWpNoMo, where it would finish, but not set WP to 0. To resolve, I did this in order -

1. rebooted my phone,
2. cycled USB Debugging,
3. plugged USB cable directly into computer,
4. moved all need files into a root folder with no spaces (c:\upgd) and no other folders,
5. made sure my cmd prompt was running as administrator (win7),
6. made sure that my phone's screen locks and timeouts were all off.

After that, all was golden.

An aside on post 4.4 ADB -
I was using Android Debug Bridge version 1.0.29, but after 4.4, had to use Android Debug Bridge version 1.0.31. Phone showed as offline in the old version.

1.0.29 -
c:\stage>adb devices
adb server is out of date. killing...
* daemon started successfully *
List of devices attached
TA*******WUA offline

1.0.31 -
c:\stage>adb devices
adb server is out of date. killing...
* daemon started successfully *
List of devices attached
TA*******WUA device

I also noticed that ES File Explorer may be a little hobbled. Had to do some other file permission work in Root Browser.
 
JarMagic
Old
#36  
Junior Member
Thanks Meter 0
Posts: 14
Join Date: Jan 2014
Default Still get "1"

Quote:
Originally Posted by bigv5150 View Post
Ok guys it looks like Jcase did it again he created an exploit that gets write protecton off for good or until an OTA. He states this will survive even an FXZ or factory data reset.

Here is what I did took about 15 min. go here ---->http://forum.xda-developers.com/show....php?t=2551113 down load the exploit follow the instructions it's very easy the exploit does it all. I am not sure if I needed to do this or not but I did to be safe I used fastboot and put stock recovery back. Just take the recovery.img from the FXZ and open a command prompt type in this command------> fastboot flash recovery recovery.img

You must be in fastboot obviously it will flash recovery back and you lose WP off. You then run MotoWpNoMo and it bypasses WP protection for ever or until OTA from what I have read. Open a command prompt and type in this command------> adb shell getprop ro.boot.write_protect to check if write protection is disabled it will return a value of "0". No more having to boot into recovery to make system changes that require writer protection off this is true root. Great job Jcase!!!!!!!!!!!!!!!!!!!!

Oh and we have stock recovery back and I beleive that voodoo ota root keeper works on 4.2.2 so I think we will have a very easy time upgrading to 4.4 and not have to re-root this is just a theory at this point.

I just tweeted Jcase looks like he tested this method it was the rumrunner team (beaups and fuses) that created this exploit.

I ran the program, several times, and when I run the test, I am still getting "1", write protection is still enabled. Have a Droid Maxx, running stock 4.2.2 rooted. Any thoughts?
 
djnikko
Old
#37  
djnikko's Avatar
Senior Member
Thanks Meter 8
Posts: 122
Join Date: Mar 2007

 
DONATE TO ME
Yes this wpo survived an fxz of 4.4 on maxx. I did however lose root, I'm screwed 4 now.

Sent from my Nexus 10 using Tapatalk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes