Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,310 Members 45,390 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Backup stuff to install Custom Rom.

Tip us?
 
dawgdoc
Old
#11  
Member
Thanks Meter 24
Posts: 79
Join Date: Nov 2013
Quote:
Originally Posted by SterneSchreien View Post
How can I flash clockwork mod recovery? And if in the end it does not work with my phone will it become bricked?
You will most likely trip the flash counter when you install the custom recovery, it may matter to you. If it does you can use the Triangle Away tool to reset. [Howto] Install a Recovery discusses manually, using either adb or terminal emulator, installing a recovery and links to other threads with automated installations. The most recent CWM for the SGS3 is 6.0.4.7 you can get it from http://www.clockworkmod.com/rommanager Using the manual method you can install recovery without using Odin or Heimdall.

Since you are rooted, GooManager would work for you. A number of people with Canadian versions of the SGS3 have reported that they used GooManager to flash the d2att version of CWM with complete success.

To install with Odin or Heimdall you will need a version of the recovery packaged as a .tar.md5 or .tar. Be sure to get the most recent version of CWM. It can be found with a search of the forums. There are tutorials available about using Odin, in short put the .tar.md5 into the PDA slot. Bear in mind that I don't use Odin, read about it for before using. Caveat, some older ROMs may require an older version of the recovery.

(I edited my previous post to correct a misstatement on my part, I changed bootloader to recovery)

SGS3 SGH-i747

TW 4.1.2, stock, rooted,
TiBu frozen

Samsung Captivate SGH-i897
Currently CyanogenMod 10.1.3
resurrected from softbrick using 4-2ndtwin's Heimdall OneClick to stock Gingerbread - 2.3.5 - kk4
ROM history Eclair > Froyo > Gingerbread > CM9
The Following User Says Thank You to dawgdoc For This Useful Post: [ Click to Expand ]
 
SterneSchreien
Old
#12  
SterneSchreien's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Nov 2013
I used the Terminal Emulator method this thread showed and it worked without problems, thanks a lot!

Just another queston : Can i flash a 4.2/4.3/4.4 Rom (such as AOKP) without updating the "bootloader" and installing Knox on my cellphone and still be able to return to 4.1.2?
 
dawgdoc
Old
#13  
Member
Thanks Meter 24
Posts: 79
Join Date: Nov 2013
Quote:
Originally Posted by SterneSchreien View Post
Just another queston : Can i flash a 4.2/4.3/4.4 Rom (such as AOKP) without updating the "bootloader" and installing Knox on my cellphone and still be able to return to 4.1.2?
You would have to check the requirements of the ROM you select for flashing.

There are two 4.3 bootloaders discussed in the ROM threads. Either will work with ROMs requiring a 4.3 bootloader. If the ROM you choose requires a 4.3 bootloader you can still go back to 4.1.2 IF YOU CHOOSE WISELY.

The MJ2 bootloader is from the leaked version of the 4.3 update. It will not prevent you from going back to 4.1.2. It does not have Knox.
The MJB bootloader is from the official 4.3 release. It will prevent you from going back to 4.1.2. It does have Knox.
(Both of these are for the AT&T 1747, Canadian variants use different bootloaders. Particulars for those devices are unfamiliar to me.)

SGS3 SGH-i747

TW 4.1.2, stock, rooted,
TiBu frozen

Samsung Captivate SGH-i897
Currently CyanogenMod 10.1.3
resurrected from softbrick using 4-2ndtwin's Heimdall OneClick to stock Gingerbread - 2.3.5 - kk4
ROM history Eclair > Froyo > Gingerbread > CM9
The Following User Says Thank You to dawgdoc For This Useful Post: [ Click to Expand ]
 
SterneSchreien
Old
#14  
SterneSchreien's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Nov 2013
Quote:
Originally Posted by dawgdoc View Post
You would have to check the requirements of the ROM you select for flashing.

There are two 4.3 bootloaders discussed in the ROM threads. Either will work with ROMs requiring a 4.3 bootloader. If the ROM you choose requires a 4.3 bootloader you can still go back to 4.1.2 IF YOU CHOOSE WISELY.

The MJ2 bootloader is from the leaked version of the 4.3 update. It will not prevent you from going back to 4.1.2. It does not have Knox.
The MJB bootloader is from the official 4.3 release. It will prevent you from going back to 4.1.2. It does have Knox.
(Both of these are for the AT&T 1747, Canadian variants use different bootloaders. Particulars for those devices are unfamiliar to me.)
Ok, how can I find out the bootloader version from the rom? I found multiple ones for instance here and here. How do I know if they need updated bootloader? And are these roms version-specific unlike CWM which was device-specific?
 
dawgdoc
Old
#15  
Member
Thanks Meter 24
Posts: 79
Join Date: Nov 2013
Quote:
Originally Posted by SterneSchreien View Post
Ok, how can I find out the bootloader version from the rom? I found multiple ones for instance here and here. How do I know if they need updated bootloader? And are these roms version-specific unlike CWM which was device-specific?
I found references to the updated MJB bootloader in the AOKP thread to which you linked. A search and close reading of that thread may tell you if it can also use the MJ2 bootloader. Likewise, you could check the AOKP faq linked to in the ROM thread, also, be sure and check the faq comments.

If a ROM is 4.3 or 4.4.x based it will probably require either the MJ2 or MJB bootloader. If it is 4.2.x or earlier you should be able to use the 4.1.1 (LK3) or 4.1.2 (MG2) bootloaders. It would be best to read and ask questions in the thread of the ROM you intend to install. Don't forget that current requirements of nightlies may vary from those of milestones from a couple of months ago.

---------- Post added at 08:20 PM ---------- Previous post was at 07:52 PM ----------

Looking back at some of the stuff you have posted I see that you are on a Canadian device.

The MJ2 and MJB bootloaders probably don't apply to you. You should currently have a different one on your device, updates will not be to MJ2 or MJB. Some of the Canadian bootloaders don't prevent you from going back to earlier stock ROMs. I don't know if all of them are this way. Meaning I recall seeing that the MK5 bootloader for the Rogers (?) will allow people to go back to 4.1.2 ROMs. Other Canadian bootloaders may or may not let you go back.

---------- Post added at 08:48 PM ---------- Previous post was at 08:20 PM ----------

This thread may help [Canada][Bell/Telus/Rogers/etc] i747m Android 4.3 Jelly Bean available + root method

SGS3 SGH-i747

TW 4.1.2, stock, rooted,
TiBu frozen

Samsung Captivate SGH-i897
Currently CyanogenMod 10.1.3
resurrected from softbrick using 4-2ndtwin's Heimdall OneClick to stock Gingerbread - 2.3.5 - kk4
ROM history Eclair > Froyo > Gingerbread > CM9
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes