App Review: Calculating Your Android Calculator Options

Sure, everyone has a default Calculator and its something that you dont think about … more

MultiROM Once Again Available for the Galaxy S4

Multiboot, or the ability to select betweenmultiple operating systems on a single device at … more

Build an Impractical But Awesome Lego Mindstorm Dock

The vast majority of what we cover here on the XDA-Developers News Portal relates to … more

MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more
Post Reply

Incoming calls

2nd March 2014, 11:42 AM   |  #1  
OP Member
Thanks Meter: 11
 
72 posts
Join Date:Joined: Jul 2013
Starting two days back, my Z1 receives incoming calls on external speakers instead of internal, so every incoming call starts that way. I need to manually put the call in internal speaker mode.

Unrooted, 4.3, the .290 build.

Sent from my C6903 using Tapatalk
2nd March 2014, 07:21 PM   |  #2  
thegios's Avatar
Senior Member
Flag Latina
Thanks Meter: 93
 
1,417 posts
Join Date:Joined: Mar 2006
More
Quote:
Originally Posted by Aegethir

Starting two days back, my Z1 receives incoming calls on external speakers instead of internal, so every incoming call starts that way. I need to manually put the call in internal speaker mode.

Unrooted, 4.3, the .290 build.

Sent from my C6903 using Tapatalk

Same here, seems the priblem is latest Sony Sociallife update.
Try the following: clear cache and data, uninstall updates, deactivate app, restart. Let me know.
The Following User Says Thank You to thegios For This Useful Post: [ View ]
2nd March 2014, 07:46 PM   |  #3  
OP Member
Thanks Meter: 11
 
72 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by thegios

Same here, seems the priblem is latest Sony Sociallife update.
Try the following: clear cache and data, uninstall updates, deactivate app, restart. Let me know.

Well, what I did was have someone call me, and call answering was sent to external speaker as usual. During the conversation, I plugged in the headphones and call went to headphones, and then, during the call, I removed them.

After that, I had another three incoming calls, and everything went back to normal, calls were directed to internal audio, not external.

I did that, because I remember that two days ago I was using Walkman app, headphones on, and phone rang. Answered the call from phone's dialler app, and all was fine. And since then, it all started with calls to external, like the phone did not "remember" that headphones were removed.

But that is just my guess, since it seems this plugging/unplugging headphones now fixed it. But you also might be right, since it's two days ago that I've updated Socialife app indeed.

I will keep monitoring incoming calls' behavior, and if it reverts back to external, I will unistall updates, and clear cache etc.

Oh, and before doing the headphones trick, just plain restarting the phone didn't work.

Let me know if you can pinpoint more exactly the cause of all this.


Sent from my C6903 using Tapatalk
Last edited by Aegethir; 2nd March 2014 at 07:51 PM.
3rd March 2014, 07:28 AM   |  #4  
Senior Member
Thanks Meter: 110
 
436 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by Aegethir

Starting two days back, my Z1 receives incoming calls on external speakers instead of internal, so every incoming call starts that way. I need to manually put the call in internal speaker mode.

Unrooted, 4.3, the .290 build.

Sent from my C6903 using Tapatalk

u place your phone on a flat surface? if its so, than the phone is helping u to use external speaker since u r not not bringing up the phone to your ear.
3rd March 2014, 09:04 AM   |  #5  
Lancerz's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 239
 
1,008 posts
Join Date:Joined: Dec 2008
More
This just started happening to me to, was going to post about it. Going to try some of your suggestions.

Sent from my C6916 using Tapatalk
3rd March 2014, 10:32 AM   |  #6  
OP Member
Thanks Meter: 11
 
72 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by chunlianghere

u place your phone on a flat surface? if its so, than the phone is helping u to use external speaker since u r not not bringing up the phone to your ear.

No, phone is not on a flat surface, it is happening even when I put it to my ear, the call stays on external speaker, and I have to tap the on-screen button to direct it to internal speaker.

Sent from my C6903 using Tapatalk
3rd March 2014, 10:37 AM   |  #7  
OP Member
Thanks Meter: 11
 
72 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by Lancerz

This just started happening to me to, was going to post about it. Going to try some of your suggestions.

Sent from my C6916 using Tapatalk

In my case it seems that the headphones trick did the job (so far), but if it will persist, I will take a closer look at the Socialife app as well.

Sent from my C6903 using Tapatalk
4th March 2014, 12:59 AM   |  #8  
Avantiel's Avatar
Senior Member
Thanks Meter: 26
 
303 posts
Join Date:Joined: Apr 2012
Happening here with me as well. Can anyone confirm if it's socialife?

Sent from my C6903 using XDA Premium 4 mobile app
4th March 2014, 01:21 AM   |  #9  
Senior Member
Flag mullingar
Thanks Meter: 81
 
372 posts
Join Date:Joined: Nov 2011
More
Quote:
Originally Posted by Avantiel

Happening here with me as well. Can anyone confirm if it's socialife?

Sent from my C6903 using XDA Premium 4 mobile app

I can confirm is not haha....I have the app disabled since I got the phone never used it so don't think it's that

Sent from my C6903 using Tapatalk
4th March 2014, 02:44 AM   |  #10  
paullu's Avatar
Senior Member
Flag usa
Thanks Meter: 43
 
890 posts
Join Date:Joined: Aug 2007
More
I have that issue too
But not all the time


Sent from my C6903 using xda app-developers app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z1 Q&A, Help & Troubleshooting by ThreadRank