Battery Charged in 30 Seconds? Maybe in 2016

Phones and tablets are getting more and more power hungry with each passing generation. Their … more

ZArchive Manages Your File Archives

Today smartphones are quite powerful devices that can handle multiple processes at once. In fact, some of … more

Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] WhatsApp Audio MIC Recording garbled?

OP lammi

3rd February 2014, 05:48 PM   |  #1  
OP Junior Member
Thanks Meter: 3
 
26 posts
Join Date:Joined: Dec 2008
Hi All,

I have been having this problem with any firmware based on stock .290 and .136. Be it Whatsapp or Line or Viber. Anything that sends an Audio message comes out garbled, which is extremely annoying.

The weird thing is.. this becomes PERFECTLY fine when I open the the SIM card port.. I seriously fail to see the connection to MIC performance here.. with the port being open! so it's just weird!!

I have downgraded to .257 for now due to this bug.

Can anyone on .290 or .136 try whatsapp audio messages and see if the problem exists for them too?

Thanks all!

LaMMi
Last edited by lammi; 3rd February 2014 at 05:56 PM.
3rd February 2014, 07:02 PM   |  #2  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 616
 
2,984 posts
Join Date:Joined: Jun 2008
You have 2 microphone on Z1, when you record the voice message, speak to the one on top behind Led Notification/Phone Call Speaker.

BTW, Whazzapp always had this problems.
4th February 2014, 04:03 AM   |  #3  
OP Junior Member
Thanks Meter: 3
 
26 posts
Join Date:Joined: Dec 2008
Unfortunately, this doesn't solve the problem neither..

It's really weird because it affects normal phone conversations as well but not as much.. I can use what's and click on the paperclip icon and actually RECORD a voice clip and it will come out fine... just when I use the audio button, it comes out garbled!

So damn weird!
4th February 2014, 06:38 AM   |  #4  
eclyptos's Avatar
Senior Member
Planet Earth
Thanks Meter: 616
 
2,984 posts
Join Date:Joined: Jun 2008
Probably cheap codecs and the option in Whazzapp was always like that and many reported to have problems. Maybe with the next update Whazapp will fix that but now how do that I don't know. Just use different app to record voice messages and send them via whazz.
4th February 2014, 07:44 AM   |  #5  
SleemLDJ's Avatar
Senior Member
Flag London
Thanks Meter: 481
 
2,199 posts
Join Date:Joined: Nov 2011
More
Download the new beta of WhatsApp here before it hits the Playstore.

It seemed to have solve the problem for me
http://www.whatsapp.com/android/

Sent from my C6903 using Tapatalk
4th February 2014, 02:17 PM   |  #6  
Avantiel's Avatar
Senior Member
Thanks Meter: 27
 
308 posts
Join Date:Joined: Apr 2012
http://forum.xda-developers.com/show....php?t=2599838

As stated in this topic. The only alternative is to click the thumbnail icon in a chat, select audio and choose what's app recorder.

That will allow u to send a voice note the old fashioned what's app way without the garble. Even still I've experienced app and phone freezes when trying to listen to voice notes via what's app. So hopefully the next update fixes it.

Sent from my C6903 using XDA Premium 4 mobile app
4th February 2014, 03:10 PM   |  #7  
OP Junior Member
Thanks Meter: 3
 
26 posts
Join Date:Joined: Dec 2008
Thanks all for the replies...

glad to know I am not the only one experiencing this problem.

I will surely report back when I have more details/fixes
4th February 2014, 07:05 PM   |  #8  
OP Junior Member
Thanks Meter: 3
 
26 posts
Join Date:Joined: Dec 2008
Just updated to MonX .136 and installed the beta whatsapp version suggested by slimldj..

whatsapp still has some form of garbled messages but it's 90% fixed.. it's good enough for me to use 4.3 based rom now!

I hope others will find this information useful.

LaMMi
2nd March 2014, 11:54 AM   |  #9  
Junior Member
Flag Monterrey
Thanks Meter: 6
 
9 posts
Join Date:Joined: Apr 2013
More
I was going to post a new topic specifying this exact problem (although my phone doesn't seem to benefit from opening the SIM flap).

This garbled recording is driving me nuts, it worked fine on .257. I'm also in a Z1 (C6906) .290 based rom (iHackers).

Is there some way this problem can be solved? Any help or input will be greatly appreciated.
Last edited by Aldo6; 2nd March 2014 at 11:59 AM. Reason: Typo
3rd March 2014, 04:06 AM   |  #10  
OP Junior Member
Thanks Meter: 3
 
26 posts
Join Date:Joined: Dec 2008
Quote:
Originally Posted by Aldo6

I was going to post a new topic specifying this exact problem (although my phone doesn't seem to benefit from opening the SIM flap).

This garbled recording is driving me nuts, it worked fine on .257. I'm also in a Z1 (C6906) .290 based rom (iHackers).

Is there some way this problem can be solved? Any help or input will be greatly appreciated.



Hiya Aldo!

I was having this problem actually all the way until around 3-4 days ago when Whatsapp got updated. I was using the workaround by "attaching" an audio clip instead of pressing down the button to speak.

Without changing rom (Monx .136), I just updated whatsapp to version 2.11.175 and now it is working 100% fine now.. The audio comes out clear and loud when played back...

Hope this helps, please post back of your results!

LaMMi

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes