5,600,612 Members 34,532 Now Online
XDA Developers Android and Mobile Development Forum

Motorola Moto G XT1032 - wifi doesn't work

Tip us?
 
Chris.G
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Default Motorola Moto G XT1032 - wifi doesn't work

Hi all,


I have visited this forum for some time and always found helpful information.
But this time I messed up this android phone and don't know how to fix it.

Late at night I was flashing custom roms to Motorola XT1032 and couple of other aps, I do it on CWM recovery using adb, so I where operating as root inside of device, had mounted all partition in Read and Write permissions.
Then when I finished applying custom stuff I wanted to delete not needed stuff what I put in /data/local/tmp. At this moment I thougt I am in this path, but I where in / and made "rm * " .
A second later I realized my mistake but that was to late.

Since that I tried to flash custom roms but that did not help to make wifi working again.
After flashing custom roms like ClockworkMod phone is working, mobile reception and bluetooth but no wifi.
I tried to insmod /system/lib/modules/wlan.ko but I got "insmod: init_module '/system/lib/modules/wlan.ko' failed (Operation not permitted)"
I think that need to flash rootfs but not 100% sure and I don't have copy of it.


Please help me.

Chris
 
gerardomt
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
I have the exact same problem and I have no idea how to fix it.

Quote:
Originally Posted by Chris.G View Post
Hi all,


I have visited this forum for some time and always found helpful information.
But this time I messed up this android phone and don't know how to fix it.

Late at night I was flashing custom roms to Motorola XT1032 and couple of other aps, I do it on CWM recovery using adb, so I where operating as root inside of device, had mounted all partition in Read and Write permissions.
Then when I finished applying custom stuff I wanted to delete not needed stuff what I put in /data/local/tmp. At this moment I thougt I am in this path, but I where in / and made "rm * " .
A second later I realized my mistake but that was to late.

Since that I tried to flash custom roms but that did not help to make wifi working again.
After flashing custom roms like ClockworkMod phone is working, mobile reception and bluetooth but no wifi.
I tried to insmod /system/lib/modules/wlan.ko but I got "insmod: init_module '/system/lib/modules/wlan.ko' failed (Operation not permitted)"
I think that need to flash rootfs but not 100% sure and I don't have copy of it.


Please help me.

Chris
 
vientodearena
Old
#3  
Junior Member
Thanks Meter 11
Posts: 16
Join Date: Oct 2010
Same problem, wifi not active.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-02-05-15-50-58.png
Views:	126
Size:	203.1 KB
ID:	2560727  
 
vientodearena
Old
#4  
Junior Member
Thanks Meter 11
Posts: 16
Join Date: Oct 2010
The PID are variable.

02-05 16:25:02.055 1049 1060 D WifiService: setWifiEnabled: true pid=9178, uid=1000

02-05 16:25:32.986 9178 9178 I ActivityManager: Timeline: Activity_launch_request id:com.android.settings time:3774476

02-05 16:25:32.987 1049 1061 I ActivityManager: START u0 {act=android.intent.action.MAIN cmp=com.android.settings/.SubSettings (has extras)} from pid 9178

02-05 16:25:33.023 9178 9178 D SubSettings: Launching fragment com.android.settings.wifi.WifiSettings

02-05 16:25:33.112 1049 1106 I ActivityManager: Displayed com.android.settings/.SubSettings: +115ms

02-05 16:25:33.155 9178 9178 I ActivityManager: Timeline: Activity_idle id: android.os.BinderProxy@41e0a048 time:3774645

02-05 16:25:33.457 1049 1106 I ActivityManager: Timeline: Activity_windows_visible id: ActivityRecord{41e2f0f8 u0 com.android.settings/.SubSettings t38} time:3774947

02-05 16:26:02.185 1049 1365 D WifiService: setWifiEnabled: true pid=9178, uid=1000

02-05 16:26:13.257 9178 9178 D BluetoothAdapter: 1115700712: getState() : mService = null. Returning STATE_OFF

02-05 16:26:13.309 9178 9178 D BluetoothAdapter: 1115700712: getState() : mService = null. Returning STATE_OFF

02-05 16:26:13.363 9178 9178 I ActivityManager: Timeline: Activity_idle id: android.os.BinderProxy@42744250 time:3814853

02-05 16:26:13.714 1049 1106 I ActivityManager: Timeline: Activity_windows_visible id: ActivityRecord{41dd1020 u0 com.android.settings/.Settings t38} time:3815204

02-05 16:26:14.317 1351 1351 I ActivityManager: Timeline: Activity_idle id: android.os.BinderProxy@41b5f068 time:3815806

02-05 16:26:14.688 1049 1106 I ActivityManager: Timeline: Activity_windows_visible id: ActivityRecord{4220d2b0 u0 com.mobint.hololauncher.hd/com.mobint.hololauncher.Launcher t1} time:3816177

02-05 16:26:15.802 1351 1351 I ActivityManager: Timeline: Activity_launch_request id:scd.lcex time:3817291

02-05 16:26:15.803 1049 1061 I ActivityManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=scd.lcex/.LogcatExtreme bnds=[257,680][371,878]} from pid 1351

02-05 16:26:16.060 1049 1334 W InputMethodManagerService: Starting input on non-focused client com.android.internal.view.IInputMethodClient$Stub$ Proxy@420d1c70 (uid=10071 pid=1351)

02-05 16:26:16.094 9393 9393 I ActivityManager: Timeline: Activity_idle id: android.os.BinderProxy@422e09e8 time:3817583

02-05 16:26:16.353 1049 1106 I ActivityManager: Timeline: Activity_windows_visible id: ActivityRecord{41d267a0 u0 scd.lcex/.LogcatExtreme t37} time:3817843

---- 05/02/2014 16:27:23 ----
 
stylboss
Old
#5  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2010
Default same probleme

please help us no wifi after unlock bootloader and format systeme, format data, format cache... . I tried rom paranoid, rom cyanogen 11 and rom GPE (google play edition) and same problem no wifi for all systemes. I wait a solution
 
luismatosdias
Old
(Last edited by luismatosdias; 3rd March 2014 at 04:36 PM.)
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Default Same problem

Quote:
Originally Posted by stylboss View Post
please help us no wifi after unlock bootloader and format systeme, format data, format cache... . I tried rom paranoid, rom cyanogen 11 and rom GPE (google play edition) and same problem no wifi for all systemes. I wait a solution
I got the same problem today i try others roms and wifi is not working. Please some one help us!
Thank you.

SOLVED! SOLUTION WERE- http://forum.xda-developers.com/show....php?t=2619553
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

TasGear: A Tasker Extension for the Samsung Galaxy Gear

With wearable technology taking center stage this year, one can only expect more … more

Intelligently Place Contacts on Your Home Screen with CallWho Widget

There are plenty of ways to get your contacts to show up on your … more

Control TWRP from within Android with TWRP Coordinator

You may recall that back when TWRP2 introduced a couple of years ago, it brought with … more

Keep Track of Everything Your Device Does with Event Logger

Regardless of their OS choice, computing power users generally share one common … more