5,601,062 Members 45,789 Now Online
XDA Developers Android and Mobile Development Forum

Downgraded from 4.4 to 4.3, now Google sync and sign-in fails on device

Tip us?
 
radeon_x
Old
#1  
Senior Member - OP
Thanks Meter 68
Posts: 330
Join Date: Jan 2006
Thumbs down Downgraded from 4.4 to 4.3, now Google sync and sign-in fails on device

Alright, this is an interesting one.

So I was on CM 10.2 for the longest time, then I tried CM 11, then finally used SlimKat for a while. Everything was working pretty well on the 4.4 ROMs, except for occasional LTE drops where it just refused to go back to LTE.

Anyway... I decided to go back to a 4.3 ROM. I flashed SlimBean 4.3 first via TWRP. No issues on boot up, LTE works, IMEI intact, WiFi, data, all working. I'm also able to sign in to my Google account - but it only partially works (see screenshot). I also can't sign into any Google services... Play Store, Play Music, Ingress... I just keep getting the "problem communicating with Google servers" error.

Now, I've since tried CM 10.2 again and I've even Odin'ed back to TW 4.3 (MK5). I've fully wiped each time - including full data and sdcard wipe. Every single 4.3 ROM is giving the connection error. I tried going back to a KitKat ROM (CM11) - and it works! No sign in error!

Any ideas what could be causing this?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-02-27-22-18-55.jpg
Views:	195
Size:	48.2 KB
ID:	2605157   Click image for larger version

Name:	Screenshot_2014-02-27-23-13-58.png
Views:	197
Size:	59.3 KB
ID:	2605158  
i-Mate SP5
 
Lakewell
Old
(Last edited by Lakewell; 28th February 2014 at 06:48 PM.) Reason: spelling
#2  
Lakewell's Avatar
Member
Thanks Meter 7
Posts: 38
Join Date: Nov 2010
Location: North Carolina
This same thing happened to me just last night on my Galaxy Nexus after attempting to go back to 4.2.2. The problem turned out to be something to do with 2-step verification. I went to accounts.google.com and disabled 2-step verification, deleted my account on my phone, rebooted, then added my account again and it worked as it was supposed to.
The Following User Says Thank You to Lakewell For This Useful Post: [ Click to Expand ]
 
radeon_x
Old
(Last edited by radeon_x; 28th February 2014 at 10:56 PM.)
#3  
Senior Member - OP
Thanks Meter 68
Posts: 330
Join Date: Jan 2006
Quote:
Originally Posted by Lakewell View Post
This same thing happened to me just last night on my Galaxy Nexus after attempting to go back to 4.2.2. The problem turned out to be something to do with 2-step verification. I went to accounts.google.com and disabled 2-step verification, deleted my account on my phone, rebooted, then added my account again and it worked as it was supposed to.
Wow, I owe you one. I would never have thought to try that... But that was indeed my problem. Thanks!

Edit: So after setting up my account on my phone, I then re-enabled 2-factor verification and the error comes back. Did you ever manage to re-enable 2-factor for you account and have it work on your non-KitKat phone?
i-Mate SP5
 
Lakewell
Old
#4  
Lakewell's Avatar
Member
Thanks Meter 7
Posts: 38
Join Date: Nov 2010
Location: North Carolina
Quote:
Originally Posted by radeon_x View Post
Wow, I owe you one. I would never have thought to try that... But that was indeed my problem. Thanks!

Edit: So after setting up my account on my phone, I then re-enabled 2-factor verification and the error comes back. Did you ever manage to re-enable 2-factor for you account and have it work on your non-KitKat phone?
I did re-enable it and it works, although I did change it from text message to google authenticator.
 
aEx155
Old
#5  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: May 2011
Hello,

I had to reflash CM 10.2.1-d2att after a failed OTA 4.4 update but I haven't been able to properly sync my Google account with 2-step auth enabled. Wiping and re-flashing new ROMs hasn't fixed anything so my temporary fix has been to disable the 2-step auth. I have tried switching code methods (from app to text message and back) but that hasn't worked. Syncing with password only then enabling 2-step also fails.

Any other suggestions?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes