5,606,722 Members 37,485 Now Online
XDA Developers Android and Mobile Development Forum

Kitkat 4.4.2 Gallery/Camera fix

Tip us?
 
rombsath
Old
(Last edited by rombsath; 3rd March 2014 at 09:41 PM.)
#31  
rombsath's Avatar
Junior Member
Thanks Meter 2
Posts: 12
Join Date: Feb 2014
Location: Lyon
Quote:
Originally Posted by MrMurphysLaw View Post
This seems to be the 4.4.2 version
What is your mobile phone ?

I have got the same version number on my HTC Desire, but the program size is only 820Ko (+2,33Mb for the Gallery) instead of 9,66 MB !!
Maybe this application wont work on my mobile phone ...
 
MrMurphysLaw
Old
(Last edited by MrMurphysLaw; 4th March 2014 at 12:52 AM.)
#32  
Junior Member
Thanks Meter 1
Posts: 24
Join Date: Nov 2013
Quote:
Originally Posted by rombsath View Post
What is your mobile phone ?

I have got the same version number on my HTC Desire, but the program size is only 820Ko (+2,33Mb for the Gallery) instead of 9,66 MB !!
Maybe this application wont work on my mobile phone ...
im using an xperia z1
i installed it through the apk i attached so im not sure if thats why theres a size difference
 
LivinOne
Old
#33  
LivinOne's Avatar
Senior Member
Thanks Meter 7
Posts: 312
Join Date: Mar 2008
Quote:
Originally Posted by goku2778 View Post
I
This method requires Titanium Backup...you can get it on the play store and the free version will work just fine
HERE'S THE CAMERA APK FIX:
-backup your systems "camera" app before doing anything! don't blame me for losing the camera if something fails
-once backed up, uninstall the camera app and if using titanium backup, move the backup files to another location out of the titanium folder located in your INTERNAL storage
-download the camera zip files I made here
-extract the zip file and you'll get a folder named "camera files"...copy and paste the files inside, do not extract any of these files, to your titanium backup folder located on your INTERNAL storage
-once copied over, open up titanium backup and look for the camera apk file with a line through it and should say beneath it "1 backup"...click on it, hit restore and choose app and data, that's it! it should now be there and fully functioning
Guide says to Uninstall the app but no info on how? I tried Titanium and it fails. Little help? thx
SGS3 on AT&T w/ Carbon KitKat 4.4.1
 
tclemens
Old
#34  
tclemens's Avatar
Senior Member
Thanks Meter 885
Posts: 467
Join Date: Oct 2012
Location: Shepherdsville
works exactly as described thanks for this
Sprint Galaxy S3 Flashed to Cricket
TW ROM MOAR 8.0
Kernel DKP
nyfl2004's elegant white theme
tdunham's toggles and statusbar lock

CM based ROM Beanstalk 4.4
Kernel Ktoonz
 
orgon3
Old
#35  
Junior Member
Thanks Meter 1
Posts: 14
Join Date: Sep 2013
Quote:
Originally Posted by rombsath View Post
I've tried to follow your guide, but I couldn't achieve it because the copy of the apk file from sdcard to /system/app doesn't work.
The copy using Root File Manager fails, and the obtained file is only 2,18Mb instead of the initial 4,6 Mb.
There's enough place on memory (450Mb) and permissions are rwx for /system/app
I don't understand why this copy fails ...

I've also tried the first proposed solution, using Titanium Backup. No problem to install, but after reboot, the video recording still doesn't store any video file in gallery !!

Can you help as this issue is the only one using the ROM Beanstalk 4.4.2 Release2 .
Thanks for that !
This means the application is not gaining root privileges. Go to your Android Settings, and scroll down to Developer Options. Scroll down to where it says "Root access". Change this to "Apps only". Under that, make sure "Android debugging" is checked. Then go back and it will work.

My guide is just an exact step-by-step of the original guide posted in the OP. Using the OP's guide, I couldn't get it to work. I uninstalled the apk's but they still remained in the system folder. I didn't know I had to rename them or delete them before I could copy over his apk (Android won't let you just overwrite for some reason). Once I did that, it worked.

On a side not, I am using CM11 0314 nightly D2LTE and the camera works just fine. Well, video recording was broken, but fixed in 0316. Continuous shots, panorama, everything works.
 
thearch1tect
Old
#36  
thearch1tect's Avatar
Senior Member
Thanks Meter 124
Posts: 637
Join Date: Aug 2008
Location: Dallas Tx
Anyone happen to have a copy of the files from the OP? Clicked on the link but it says its been blocked because of high traffic

Sent from my SPH-L710 using xda app-developers app
The Following User Says Thank You to thearch1tect For This Useful Post: [ Click to Expand ]
 
mountainmystic1
Old
#37  
Junior Member
Thanks Meter 6
Posts: 27
Join Date: Jul 2012
OP method worked great on my s3 running du 4.4.2. Thanks!
 
CeloCRF
Old
#38  
CeloCRF's Avatar
Member
Thanks Meter 9
Posts: 56
Join Date: Oct 2010
Will this fix the issue with the front camera causing a reboot if you try using it on third-party apps like (example) Instagram? Seems to be a common issue with most kitkat 4.4.2 roms (except slimkat)
 
fatboykel
Old
#39  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jan 2013
Unhappy Please help

I had followed all the steps of "THE CAMERA APK FIX" and reboot my 'note 2 lte'. Camera works fine but the video shooting. Whenever I try to shoot a video, it hangs and makes the camera broke again( "cant connect to camera" error). What should I do?

P.S. note 2 lte with CM11-20140409-NIGHTLY-t0lte
 
LaRocky
Old
#40  
Junior Member
Thanks Meter 5
Posts: 28
Join Date: Jan 2013
Quote:
Originally Posted by fatboykel View Post
I had followed all the steps of "THE CAMERA APK FIX" and reboot my 'note 2 lte'. Camera works fine but the video shooting. Whenever I try to shoot a video, it hangs and makes the camera broke again( "cant connect to camera" error). What should I do?

P.S. note 2 lte with CM11-20140409-NIGHTLY-t0lte
Do you have the camera set to store on SD card? I had issue with the camera from a custom rom that i noticed if I switched to internal storage, no issue. They eventually fixed the rom. So maybe this is same issue.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes