FORUMS

YotaPhone 2 Pre-Order, Xperia Z1 Price Cut – XDA TV

Android Wear 5.1.1 OTA downloads are now available. That and much more news is … more

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more

Original Moto G Receives Lollipop, OTA Captured

The original Moto G was released almost two years ago. Motorola still continues to … more

Device Review: No.1 X1 Rugged Smartphone

We are almost at the end of Q2 for 2015, and we have seen most of the flagship phones for the … more
Post Reply Subscribe to Thread Email Thread

Huge GPS Problems (P6 B125)

26th January 2014, 09:12 AM |#1  
OP Member
Thanks Meter: 2
 
More
Hey guys,

I really like my P6, but there's one thing that's bugging me to death:
For some reason, sometimes, when I activate a GPS based app (e.g. Google Maps .. or GPS Status), GPS is not activated along with it.
To be more precise, GPS is enabled in settings but no icon is showing up in the status bar.
Usually, when I open a GPS based app, the GPS icon immediately shows and blinks until it has a lock, then it stops blinking.

Now, most of the time, nothing like that happens!! No icon at all, maps is totally lost and GPS status shows 0 satellites.
Sometimes, a reboot will fix it, but sometimes, even then it doesn't work.

Am I doing something wrong? This is totally weird!
 
 
26th January 2014, 05:01 PM |#2  
Senior Member
Flag Nousiainen
Thanks Meter: 106
 
More
Which firmware you on?

Lähetetty minun MediaPad 7 Vogue laitteesta Tapatalkilla
26th January 2014, 05:21 PM |#3  
OP Member
Thanks Meter: 2
 
More
Yeah, I hid that in the title ^^ B125
Some guys in a german support forum also had that problem. Noone could solve it yet.
28th February 2014, 07:07 AM |#4  
sisqoboy's Avatar
Senior Member
Thanks Meter: 6
 
More
Same problem here...
even when I switch to front camera - gallery has stopped error comes up...

Disappointed..



Sent from my HUAWEI P6-U06 using xda app-developers app
28th February 2014, 09:55 AM |#5  
Member
Flag Athens
Thanks Meter: 36
 
More
Quote:
Originally Posted by taurui

Hey guys,

I really like my P6, but there's one thing that's bugging me to death:
For some reason, sometimes, when I activate a GPS based app (e.g. Google Maps .. or GPS Status), GPS is not activated along with it.
To be more precise, GPS is enabled in settings but no icon is showing up in the status bar.
Usually, when I open a GPS based app, the GPS icon immediately shows and blinks until it has a lock, then it stops blinking.

Now, most of the time, nothing like that happens!! No icon at all, maps is totally lost and GPS status shows 0 satellites.
Sometimes, a reboot will fix it, but sometimes, even then it doesn't work.

Am I doing something wrong? This is totally weird!

Quote:
Originally Posted by sisqoboy

Same problem here...
even when I switch to front camera - gallery has stopped error comes up...

Disappointed..



Sent from my HUAWEI P6-U06 using xda app-developers app

I had the exact same problem with you guys. It happened when I force-killed a GPS app I was using. After that I couldn't use the GPS with any app!!
I did a nand restore and everything is ok now. So from my point of view you have 2 solutions.
1. Restore your phone to a previous state where the GPS worked (e.g. TWRP backup) or
2. Reinstall the B.125 rom using the update.app

my 2c
The Following User Says Thank You to halman For This Useful Post: [ View ]
1st March 2014, 09:37 PM |#6  
bokchoi2020's Avatar
Senior Member
Flag Ottawa
Thanks Meter: 208
 
More
Quote:
Originally Posted by sisqoboy

Same problem here...
even when I switch to front camera - gallery has stopped error comes up...

Disappointed..



Sent from my HUAWEI P6-U06 using xda app-developers app

Are you willing to take apart your phone? Because I am pretty sure that you have a loose connector that connects your front camera to the mainboard. I took apart my cellphone entirely yesterday b/c the sim tray wasn't reading the sim card. I cleaned the sim tray and now it works.

If you want to take apart your phone, make sure you check some tutorials like "Huawei p6 disassembly" before you actually start.
TIP: the connector for the front camera is on the left top side of the main board.

Now, I am not responsible if it breaks, just a tip if you want to try it.
5th March 2014, 01:20 AM |#7  
sisqoboy's Avatar
Senior Member
Thanks Meter: 6
 
More
Thanks for the idea. I would rather send it back because I still have warranty on it...


Sent from my HUAWEI P6-U06 using xda app-developers app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes