5,606,588 Members 34,625 Now Online
XDA Developers Android and Mobile Development Forum

VB.NET problem

Tip us?
 
matonja1000
Old
(Last edited by matonja1000; 21st February 2014 at 10:59 AM.) Reason: more info
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Feb 2014
Default VB.NET problem

Hi ,

I just registered to this forum, because I recently I've been starting to use RPI.
Since my best knowledge in programming is VB.net I made my program in Visual Studio 2010.
On my windows computer my program runs just fine.

I found on the internet that I could run that program using MONO on RPI so I installed it.
Few days ago I tried to run some simple forms and programs on RPI with mono (in comand promt : $ mono MyProg.exe)
and it worked.

Now I completed my program, so I copied it on Raspberry Pi and launched it.
Problem is that Form of program shows only for few seconds and also not complete.
After that in Comand Promt shows a lot of lines why this program wasn't properly executed, but I don't really understand it.

I hope someone can help .

With regards

PS: I can also post Comand promt report if it would be helpfull
 
shimp208
Old
#2  
shimp208's Avatar
Recognized Contributor
Thanks Meter 1334
Posts: 1,996
Join Date: Jan 2011
Location: Boston

 
DONATE TO ME
Quote:
Originally Posted by matonja1000 View Post
Hi ,

I just registered to this forum, because I recently I've been starting to use RPI.
Since my best knowledge in programming is VB.net I made my program in Visual Studio 2010.
On my windows computer my program runs just fine.

I found on the internet that I could run that program using MONO on RPI so I installed it.
Few days ago I tried to run some simple forms and programs on RPI with mono (in comand promt : $ mono MyProg.exe)
and it worked.

Now I completed my program, so I copied it on Raspberry Pi and launched it.
Problem is that Form of program shows only for few seconds and also not complete.
After that in Comand Promt shows a lot of lines why this program wasn't properly executed, but I don't really understand it.

I hope someone can help .

With regards

PS: I can also post Comand promt report if it would be helpfull
While I am not a Visual Basic expert if you can post the command prompt report I will be happy to take a look at it for you and see what I can figure out.
 
matonja1000
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Feb 2014
Quote:
Originally Posted by shimp208 View Post
While I am not a Visual Basic expert if you can post the command prompt report I will be happy to take a look at it for you and see what I can figure out.
I'm posting 3 images. One of them also shows how program was starting to launch properly but the chrashed.

Problem is since I'm new I can't post outside link.

shrani.si/f/6/3J/3CDJrNW9/img20140221105920.jpg

shrani.si/f/K/OW/4Sm7AneI/img20140221105903.jpg

shrani.si/f/3J/h6/446I9fs0/img20140221105841.jpg
 
matonja1000
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Feb 2014
Quote:
Originally Posted by matonja1000 View Post
I'm posting 3 images. One of them also shows how program was starting to launch properly but the chrashed.

Problem is since I'm new I can't post outside link.

shrani.si/f/6/3J/3CDJrNW9/img20140221105920.jpg

shrani.si/f/K/OW/4Sm7AneI/img20140221105903.jpg

shrani.si/f/3J/h6/446I9fs0/img20140221105841.jpg

I managed to start it with wine.

Thanks anyway.
 
steentje3
Old
#5  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Mar 2012
Location: Nijmegen
Use Wine,

It is similar to "Mono".

Google for how you can install it.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes