FORUMS

How a HTC Droid Eris Changed a Members Life

Rarely can a member say that Android development or XDA had a profound effect on … more

XDA Office Space: Frankenstein’s Perfect IM Client?

The portal’s decentralized XDA office lies in a Hangouts chatroom, where … more

Which IM Client on Android is best?

With so many different messengers to choose from, it can be tough to find the best one for you and … more

Android Factory Reset Security Flaw and More – XDA TV

Nvidia is releasing a 500Gb SHIELD TV Pro! That and much more news is … more
Post Reply Subscribe to Thread Email Thread

Moto G not detected win 8.1

6th March 2014, 09:46 AM |#1  
abcduploader's Avatar
OP Member
Flag Kolkata
Thanks Meter: 12
 
More
Hi,

I updated my moto g(xt1033) to kitkat as soon as i got the phone .

most of the time i use airdroid to transfer files . But recently when i tried to connect via MTP mode the device was not detected . It was neither detected in camera mode .

In the device manager its showing an error .
The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

Please help .
 
 
6th March 2014, 09:49 AM |#2  
reversegear's Avatar
Senior Member
Thanks Meter: 1,075
 
More
+1
same problem here. though i got adb to work with win 8.1
6th March 2014, 09:53 AM |#3  
robin0800's Avatar
Senior Member
Thanks Meter: 96
 
More
Quote:
Originally Posted by reversegear

+1
same problem here. though i got adb to work with win 8.1

Install Motorola drivers

https://motorola-global-en-uk.custhe...p/30,6720,9050
6th March 2014, 10:41 AM |#4  
reversegear's Avatar
Senior Member
Thanks Meter: 1,075
 
More
Quote:
Originally Posted by robin0800

Install Motorola drivers

https://motorola-global-en-uk.custhe...p/30,6720,9050

tried that still not working
6th March 2014, 10:43 AM |#5  
abcduploader's Avatar
OP Member
Flag Kolkata
Thanks Meter: 12
 
More
Quote:
Originally Posted by reversegear

tried that still not working

+1 tried not working .
6th March 2014, 12:24 PM |#6  
avercros's Avatar
Senior Member
Flag Armenia
Thanks Meter: 76
 
More
For me works like a charm, check your drivers installation.
6th March 2014, 05:54 PM |#7  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by abcduploader

+1 tried not working .

You need to disable some driver enforcement business in Windows 8.1 before you can install the drivers.

http://www.howtogeek.com/167723/how-...igned-drivers/

Refer to the above link, after restarting, install Moto Drivers again. (http://download.clockworkmod.com/dri...iver_5.4.0.exe)

Let me know.
6th March 2014, 07:26 PM |#8  
mr_nooby's Avatar
Senior Member
Thanks Meter: 476
 
Donate to Me
More
Windows 8.1 installs Microsoft USB drivers which won't allow you to use the phone even if you install drivers. You must search for your original USB drivers and install them instead of the windows 8.1 ones.

Sent from my XT1032 using xda app-developers app
6th March 2014, 10:38 PM |#9  
Senior Member
Thanks Meter: 34
 
More
You might need some RNDIS drivers.
7th March 2014, 04:10 AM |#10  
renatoakamur's Avatar
Member
Flag São Paulo - SP
Thanks Meter: 5
 
More
Try a factory reset. Worked for me.

My Moto G (XT1033) was working with some bugs to connect on Win 8.1 before the kit kat. After the update has stopped completely. I did a factory reset and everything is fine now.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes