Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,007 Members 40,810 Now Online
XDA Developers Android and Mobile Development Forum

Moto G not detected win 8.1

Tip us?
 
abcduploader
Old
#1  
abcduploader's Avatar
Junior Member - OP
Thanks Meter 6
Posts: 26
Join Date: Jan 2012
Location: Kolkata
Storage Moto G not detected win 8.1

Hi,

I updated my moto g(xt1033) to kitkat as soon as i got the phone .

most of the time i use airdroid to transfer files . But recently when i tried to connect via MTP mode the device was not detected . It was neither detected in camera mode .

In the device manager its showing an error .
The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

Please help .
 
reversegear
Old
#2  
Senior Member
Thanks Meter 373
Posts: 840
Join Date: Jul 2011
+1
same problem here. though i got adb to work with win 8.1
 
robin0800
Old
#3  
robin0800's Avatar
Senior Member
Thanks Meter 82
Posts: 260
Join Date: Jan 2012
Quote:
Originally Posted by reversegear View Post
+1
same problem here. though i got adb to work with win 8.1
Install Motorola drivers

https://motorola-global-en-uk.custhe...p/30,6720,9050
:
Robin0800
 
reversegear
Old
#4  
Senior Member
Thanks Meter 373
Posts: 840
Join Date: Jul 2011
Quote:
Originally Posted by robin0800 View Post
tried that still not working
 
abcduploader
Old
#5  
abcduploader's Avatar
Junior Member - OP
Thanks Meter 6
Posts: 26
Join Date: Jan 2012
Location: Kolkata
Quote:
Originally Posted by reversegear View Post
tried that still not working
+1 tried not working .
 
avercros
Old
#6  
avercros's Avatar
Senior Member
Thanks Meter 56
Posts: 305
Join Date: Jan 2012
Location: Armenia
For me works like a charm, check your drivers installation.
Current Device: G2
 
craagz
Old
#7  
Junior Member
Thanks Meter 1
Posts: 14
Join Date: Jul 2010
Quote:
Originally Posted by abcduploader View Post
+1 tried not working .
You need to disable some driver enforcement business in Windows 8.1 before you can install the drivers.

http://www.howtogeek.com/167723/how-...igned-drivers/

Refer to the above link, after restarting, install Moto Drivers again. (http://download.clockworkmod.com/dri...iver_5.4.0.exe)

Let me know.
Nexus One - Running 4.3 paranoid android - gave away to cousin
Galaxy Nexus - Running 4.4 SlimROM - with father-in-law
Karbonn S5 Titanium - rooted and running stock 4.1.2 JB ROM - with Mom
Nexus 5 - Running Paranoid Android - with wife
Moto G (XT1033) - Running stock
 
mr_nooby
Old
#8  
mr_nooby's Avatar
Senior Member
Thanks Meter 473
Posts: 1,221
Join Date: Jul 2012

 
DONATE TO ME
Windows 8.1 installs Microsoft USB drivers which won't allow you to use the phone even if you install drivers. You must search for your original USB drivers and install them instead of the windows 8.1 ones.

Sent from my XT1032 using xda app-developers app
 
eastdata
Old
#9  
Senior Member
Thanks Meter 28
Posts: 108
Join Date: Apr 2011
You might need some RNDIS drivers.
 
renatoakamur
Old
#10  
renatoakamur's Avatar
Member
Thanks Meter 4
Posts: 69
Join Date: Aug 2010
Location: São Paulo - SP
Try a factory reset. Worked for me.

My Moto G (XT1033) was working with some bugs to connect on Win 8.1 before the kit kat. After the update has stopped completely. I did a factory reset and everything is fine now.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...