Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Wi-Fi Stuck on 'Turning On'

OP gregsicles

24th January 2014, 09:25 AM   |  #1  
OP Junior Member
Thanks Meter: 0
3 posts
Join Date:Joined: Jan 2014
Hey guys,

so I've been using my Xperia Arc S for over a year with no problems but recently when I try to turn on the wifi it becomes stuck at 'turning on'. The same thing happens with the bluetooth. Sometimes when I restart the phone it works but most of the time it doesn't I've tried factory resetting it and it worked fine for a bit but then became stuck again. I'm running stock 4.0.4 rooted.

It started happening when I went overseas where my sim card didn't work and I had to change the time zone manually in settings. I read somewhere that this happened to someone else who did the same but there was no solution found. Does anyone know how to fix this? Any help will be greatly appreciated, thanks
24th January 2014, 01:02 PM   |  #2  
Thanks Meter: 26
64 posts
Join Date:Joined: Nov 2013
It may be hardware problem or software. If you tried factory reset then you should try a new Rom. If problem keeps going, your phone may be the problem, you should bring it to repair service for diagnosing.
Hope it help!
24th January 2014, 07:32 PM   |  #3  
Someguyfromhell's Avatar
Recognized Contributor
Thanks Meter: 2,039
4,001 posts
Join Date:Joined: Feb 2012
Donate to Me
Repair firmware with PC Companion.
28th January 2014, 05:46 AM   |  #4  
OP Junior Member
Thanks Meter: 0
3 posts
Join Date:Joined: Jan 2014
I tried repairing it with PC Companion but still no luck. I guess it may be a hardware problem like motlanvamaimai suggested.
29th January 2014, 01:22 PM   |  #5  
Junior Member
Thanks Meter: 0
20 posts
Join Date:Joined: May 2013
Same Q
6th March 2014, 01:17 PM   |  #6  
aravindhramachandran's Avatar
Senior Member
Flag Chennai
Thanks Meter: 71
291 posts
Join Date:Joined: Nov 2012
Hey guys.. I faced similar issue in my AMOI 820 based Indian local device Micromax (rooted + custom kernal)

I fixed this stuck wifi problem by uninstalling Google apps in system by removing them using Titanium back up + and again installing them from playstore if needed.. Hangouts(in my case) if it's a system app after getting updated is the culprit .. Try removing it and reboot and test it yourself..
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes