Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,052 Members 43,086 Now Online
XDA Developers Android and Mobile Development Forum

Phone call Speaker problem

Tip us?
 
Mohamed_Aly
Old
#1  
Mohamed_Aly's Avatar
Member - OP
Thanks Meter 2
Posts: 45
Join Date: Feb 2014
Location: Alexandria
Default Phone call Speaker problem

Recently.. Whenever there is a received phone call.. When I answer it, the loud speaker is activated by it's own.. I don't know why.. It didn't do that before.. And it does that only with received calls.. Simple as it is, but it's really annoying and quite embarrassing.. especially when I'm in public transport.. So, any one knows how to fix that.. Or what is the problem??

Sent from my C6903 using XDA Premium 4 mobile app
Nokia 3230 > Nokia N73 Music Edition > Samsung S5230 Star > iPhone 3GS > Samsung Galaxy Ace S5830 > Samsung Galaxy SII I9100 > Sony Xperia Z C6602 > Sony Xperia Z1 C6903
 
Aegethir
Old
#2  
Member
Thanks Meter 9
Posts: 70
Join Date: Jul 2013
It seems that the latest Chrome update causes that glitch, so try to uninstall the updates for it and if it still doesn't work, disable Chrome, restart phone and then use another browser till this is solved another way (another Chrome update that restores functionality).

Sent from my C6903 using Tapatalk
 
ghostman2
Old
#3  
Senior Member
Thanks Meter 19
Posts: 106
Join Date: Mar 2012
Location: Caxias do Sul
Quote:
Originally Posted by Mohamed_Aly View Post
Recently.. Whenever there is a received phone call.. When I answer it, the loud speaker is activated by it's own.. I don't know why.. It didn't do that before.. And it does that only with received calls.. Simple as it is, but it's really annoying and quite embarrassing.. especially when I'm in public transport.. So, any one knows how to fix that.. Or what is the problem??

Sent from my C6903 using XDA Premium 4 mobile app
We have 2 other threads about this issue, looks like is happening with almos everyone, so like our friend above said, deactivate chrome and clear you phone app data and cache, doing this your problem will be solved.
1st Phone - Galaxy Y
2nd Phone - Motorola Quench
3nd Phone - Galaxy S II
4th Phone - Lumia 920
5th Phone - Xperia Z1 (3rd change now without touch issues )
 
KarimSalloum
Old
#4  
KarimSalloum's Avatar
Senior Member
Thanks Meter 18
Posts: 206
Join Date: Apr 2012
Location: Beirut
For what it's worth I deleted Chrome using TB and the problem persists, so it might not work for everyone.
 
Aegethir
Old
#5  
Member
Thanks Meter 9
Posts: 70
Join Date: Jul 2013
Quote:
Originally Posted by KarimSalloum View Post
For what it's worth I deleted Chrome using TB and the problem persists, so it might not work for everyone.
You might be right, for instance, I still didn't disable Chrome, and got three calls today, everything was normal.

What I have disabled though, is Socialife and Smart Connect. Some users mentioned that after a phone restart, only the first incoming call goes to external speaker, the others are fine, after the first call.

Only thing we're sure of, this seems to have started happening to most of us at the same time.

Sent from my C6903 using Tapatalk
 
ghostman2
Old
#6  
Senior Member
Thanks Meter 19
Posts: 106
Join Date: Mar 2012
Location: Caxias do Sul
Remember guys: after disable chrome did you cleaned data and cache from phone app? If you dont do this wont solve your problem.
1st Phone - Galaxy Y
2nd Phone - Motorola Quench
3nd Phone - Galaxy S II
4th Phone - Lumia 920
5th Phone - Xperia Z1 (3rd change now without touch issues )
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Give Your Notification Shade a Facelift with these Modding Guides

Modification has always been one of the strong suits of Android, due in … more

Keep Track of How Much Your Car Truly Costs with Car Logbook

It’s a very well established fact that cars are expensive. In addition to … more

New Nvidia SHIELD Tablet OTA! Moto G 4G Gets Official CyangenMod 11 Nightlies – XDA Developer TV

The Nvidia SHIELD Tablet gets its … more

Prevent Apps from Locking Screen Orientation with HaveOwnOrientation

Most applications on Android play nicely with both landscape and … more