Micromax Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

[Q] Xperia T protoype WIFI and Radio issues

OP steeserious

Prev Previous Post   Next Post Next
7th March 2014, 07:59 PM   |  #1  
OP Member
Thanks Meter: 7
 
35 posts
Join Date:Joined: Nov 2013
The problem: Xperia T prototype (0044 IMEI) will not run stable on most stock firmwares. WIFI only works with the ICS stock WIFI module (7.0.A.1.303 FW or flashing module to other firmwares). Also, baseband and IMEI is blanked out in settings. The radio is not working at all.

So after testing a lot of firmwares and roms (I must've flashed this phone 3,8 billion times by now...), this is the result:

NONE of the stock firmwares I've tried (almost all of them I think...) help
CM 10 seems to be working completely. At least radio and WIFI are fine for now.
CM10.1 and 11: WIFI working, baseband and IMEI are shown, I can scan networks, but can not register in any network.
CM10 is using Baseband 8960A-AAAAANAZQ-10015019-33, while 10.1 and 11 use 8960A-AAAAANAZQ-10015031-47.

So far so good (boy was I happy when I was able to dial a number in CM10!!!).
Now I would like to get a stock ROM working.

The question: How will I get the stock ROMs working? I would have to find out what CM is using that stock isn't. I'm actually quite confused about the fact that even the oldest stock (7.0.A.1.303, couldn't find any older one) would not work, while CM 10 will.

Quote:
Originally Posted by steeserious

I read that some people here are using LT30p prototypes without issues and I'm wondering if any of you guys can help me getting there too.
When I got the phone, it was basically a mess. Service Menu will FC when trying to open configuration, loads of FCs here and there...it wouldn't wake up when the screen turns off, the WIFI wasn't working, Radio not working at all...

I was able to solve WIFI and FC by installing PACMAN v.23. This was mentioned on another forum.
So I'm wondering about the modules, lib, baseband etc that's used in there. Maybe someone can shed some light.
PACMAN shows this baseband: 8960A-AAAAANAZQ-10015031-47
WIFI is also working with 7.0.A.1.303 ICS and 7.0.A.3.223 ICS. Flashing the stock ICS WIFI module to other firmware versions fixes WIFI.

While I can search for networks in PM, I cannot log on to any of them. On stock the phone will detect when a SIM card is inserted and will reboot. After reboot, it will say there's no SIM card installed though.
Also, PAC will show the IMEI in the settings, all the stock firmwares don't.

@godfather4her: I'll mention you here since you might have some info on this .

Last edited by steeserious; 12th March 2014 at 02:10 AM.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes