iNew V3 MTK MT6582 - Battery Issue

3 posts
Thanks Meter: 0
By Galectus, Junior Member on 28th January 2014, 10:39 AM
Post Reply Subscribe to Thread Email Thread
My iNew V3 Battery is insanely draining. Earlier it was working fine for 3 or 4 days, then suddenly it was not charging up to 100% and discharging rapidly in few minutes. I have tried to charge more than 3 hrs but no use. its going to 1% and switching off and showing more than 30 -70% when ever I keep charging in off mode.

I have checked with re-sellers support, they have suggested that firmware update will resolve battery issue. I have updated firmware from cxq_v3_v1.0.6T02 to cxq_v3_inew_v1.0.4. after updating firmware now mobile is charging to 100% but immediately with in 1 or 2 hours, some times in few minutes its going to below 4% and switching off. some times it will charge to 100% with in 30 min.

I have checked battery with multiple battery calibrate apps and find no issue, all are showing healthy and good status. There is no Physical change in appearance/size in battery (like expanding in size). its good as new one.

This is Android software problem or Battery problem ?? can some one please help me or suggest me anything??

30th January 2014, 09:24 PM |#2  
Junior Member
Thanks Meter: 0
Face the same thing here. Rooted mine to freeze some of the bloats but Android System is still at 91% consuming my battery. HElP
8th March 2014, 01:27 PM |#3  
Junior Member
Flag Zurich
Thanks Meter: 0
From what i understood you need to wipe the phone when updating to firmware 1.0.4 - then this problem should be resolved.
my inew v3 is on the way so i cannot tell from personal experience,
but i read on a different forum that this seems to have fixed the problem.

also, check the other thread here about how to get a THL W8 battery working (2000mAh)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes