Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,427 Members 41,133 Now Online
XDA Developers Android and Mobile Development Forum

iNew V3 MTK MT6582 - Battery Issue

Tip us?
 
Galectus
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Question iNew V3 MTK MT6582 - Battery Issue

My iNew V3 Battery is insanely draining. Earlier it was working fine for 3 or 4 days, then suddenly it was not charging up to 100% and discharging rapidly in few minutes. I have tried to charge more than 3 hrs but no use. its going to 1% and switching off and showing more than 30 -70% when ever I keep charging in off mode.

Code:
i42.tinypic.com/21nf4si.jpg

i42.tinypic.com/2nb6hqq.jpg
I have checked with re-sellers support, they have suggested that firmware update will resolve battery issue. I have updated firmware from cxq_v3_v1.0.6T02 to cxq_v3_inew_v1.0.4. after updating firmware now mobile is charging to 100% but immediately with in 1 or 2 hours, some times in few minutes its going to below 4% and switching off. some times it will charge to 100% with in 30 min.

I have checked battery with multiple battery calibrate apps and find no issue, all are showing healthy and good status. There is no Physical change in appearance/size in battery (like expanding in size). its good as new one.

Code:
i42.tinypic.com/mhsi8j.jpg
This is Android software problem or Battery problem ?? can some one please help me or suggest me anything??

Code:
inewmobile.com/media/catalog/product/cache/1//9df78eab33525d08d6e5fb8d27136e95/o/r/original_1830mah_battery_for_inew_v3_mobile_phone_3.jpg
 
mbspalace
Old
#2  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Location: Ongwediva
Face the same thing here. Rooted mine to freeze some of the bloats but Android System is still at 91% consuming my battery. HElP
 
linr_76
Old
#3  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Jan 2011
Location: Zurich
From what i understood you need to wipe the phone when updating to firmware 1.0.4 - then this problem should be resolved.
my inew v3 is on the way so i cannot tell from personal experience,
but i read on a different forum that this seems to have fixed the problem.

also, check the other thread here about how to get a THL W8 battery working (2000mAh)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes