Post Reply

Should I update to 4.3? And some questions

OP bero1608

8th March 2014, 09:30 AM   |  #11  
Sadman Khan's Avatar
Senior Member
Thanks Meter: 236
 
727 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by kyu0911

Wow, I didn't know that updating via SUS wipes your data. Thank you for the info!

"repairing" via PCC also wipes data. In case you didn't know

Sent from my C5303 using XDA Premium 4 mobile app
8th March 2014, 04:33 PM   |  #12  
KaosStorm's Avatar
Member
Flag Guatemala city
Thanks Meter: 6
 
35 posts
Join Date:Joined: Oct 2011
More
From what I've gathered by reading lots of comments about 4.3, the update it's a mixed bag (probably region-dependent) since for me it was one of the best things to happen to my stock SP: it looks better, it feels better, it barely lags, it barely hangs. I flashed the generic US ftf (since the OTA kept failing over and over again) and I'm glad I did it.
8th March 2014, 05:45 PM   |  #13  
mrhnet's Avatar
Senior Member
Thanks Meter: 177
 
300 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by bero1608

Okay I updated, now I will root.
--------------------------------------------
Edit: Couldn't manage to root
I have locked bootloader so I can't root, atm I hope.
I trust in you DooMLoRD
Hope you will find out soon how to root Xperia SP with locked BL

See whether this helps..
-->> http://forum.xda-developers.com/show....php?t=2646904
Same info here: http://forum.xda-developers.com/show....php?t=2648538
(See second part below, for locked BL)
(strictly speaking, this is not "rooting" the stock rom, rather a means of having a rooted stock 4.3 rom, without unlocking the BL).
#I've managed to get it done... For this, I had to downgrade to 4.1.2 (http://forum.xda-developers.com/show...52&postcount=8), root 4.1.2 (http://forum.xda-developers.com/show....php?t=2405933), and install CWM (http://forum.xda-developers.com/show....php?t=2352920), then followed the instructions (to get root 4.3) in above links. Had to erase all data in the process.
*[backed up the TA partition while rooted at 4.1.2, just in case it might be needed later.. (http://forum.xda-developers.com/show...hp?t=2292598)]
My phone model: c5303
#For backing up data WITHOUT root, I used the app "Backup & restore" which comes with stock rom (under 'Tools'). However, it didn't restore my game data properly. Alternatively, can try backup and restore with ADB (http://stackoverflow.com/questions/1...vice-using-adb), but I couldn't try it's restore function yet, so not sure whether it works. If you've backed up the data while at 4.1.2 rooted (initially) with titanium backup, there's not much of a dilemma I suppose..
Dunno whether this provides any solution to your problem, but glad if this helps anyone. Just sharing my experience..
The Following User Says Thank You to mrhnet For This Useful Post: [ View ]
8th March 2014, 05:49 PM   |  #14  
OP Member
Thanks Meter: 12
 
48 posts
Join Date:Joined: Mar 2014
Quote:
Originally Posted by mrhnet

See whether this helps..
-->> http://forum.xda-developers.com/show....php?t=2646904
Same info here: http://forum.xda-developers.com/show....php?t=2648538
(See second part below, for locked BL)
(strictly speaking, this is not "rooting" the stock rom, rather a means of having a rooted stock 4.3 rom, without unlocking the BL).
#I've managed to get it done... For this, I had to downgrade to 4.1.2 (http://forum.xda-developers.com/show...52&postcount=8), root 4.1.2 (http://forum.xda-developers.com/show....php?t=2405933), and install CWM (http://forum.xda-developers.com/show....php?t=2352920), then followed the instructions (to get root 4.3) in above links. Had to erase all data in the process.
*[backed up the TA partition while rooted at 4.1.2, just in case it might be needed later.. (http://forum.xda-developers.com/show...hp?t=2292598)]
My phone model: c5303
#For backing up data WITHOUT root, I used the app "Backup & restore" which comes with stock rom (under 'Tools'). However, it didn't restore my game data properly. Alternatively, can try backup and restore with ADB (http://stackoverflow.com/questions/1...vice-using-adb), but I couldn't try it's restore function yet, so not sure whether it works. If you've backed up the data while at 4.1.2 rooted (initially) with titanium backup, there's not much of a dilemma I suppose..
Dunno whether this provides any solution to your problem, but glad if this helps anyone. Just sharing my experience..

Thanks for reply!

I'm waiting for new firmware so I'm not rooting atm

Thanks anyway
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia SP General by ThreadRank