Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,791 Members 53,376 Now Online
XDA Developers Android and Mobile Development Forum

CM 10.2.1 - play store no longer works

Tip us?
 
LxMxFxD
Old
#1  
Senior Member - OP
Thanks Meter 46
Posts: 255
Join Date: Nov 2009
Location: Texas
Default CM 10.2.1 - play store no longer works

CM 10.2.1-ovation
Android 4.3.1
Date and time: Use network time
Kernel: 3.031-green+

After installing the latest CM "stable" update using the built in CM upgrade system, the google play store no longer works. I get "No connection retry" when loading play store. Prior to 10.2.1 play store functioned normally.

I googled this, and found none of the solutions worked. I've tried:

1. Ensuring network time is set
2. clearing data cache from play store app
3. Uninstalling and reinstalling play store from an apk

Wondering if this is a known issue with a known fix from someone in the community.

Thanks
Current Phone: Sony Xperia Z ultra C6806 Sony Edition

Previous: HTC Touch Diamond, HTC Hero, Evo 4G, Samsung S II, Note 1 intl.
 
HiddenG
Old
#2  
Senior Member
Thanks Meter 44
Posts: 157
Join Date: Nov 2011
Location: Manchester
If you were previously using CM 10.1.3 (Android 4.2.2) and have now upgraded to CM 10.2 (Android 4.3), you need to reinstall GAPPS for your new Android version.

So you'll need to download the latest GAPPS, found here: http://goo.im/gapps (for CM10.2.x) and then boot into CWM Recovery and install GAPPS manually. The automatic CM updater does not install GAPPS unfortunately.

Once you've done that, reboot back into Android and you're good to go. All the best.
 
LxMxFxD
Old
(Last edited by LxMxFxD; 8th March 2014 at 11:17 PM.)
#3  
Senior Member - OP
Thanks Meter 46
Posts: 255
Join Date: Nov 2009
Location: Texas
Quote:
Originally Posted by HiddenG View Post
If you were previously using CM 10.1.3 (Android 4.2.2) and have now upgraded to CM 10.2 (Android 4.3), you need to reinstall GAPPS for your new Android version.

So you'll need to download the latest GAPPS, found here: http://goo.im/gapps (for CM10.2.x) and then boot into CWM Recovery and install GAPPS manually. The automatic CM updater does not install GAPPS unfortunately.

Once you've done that, reboot back into Android and you're good to go. All the best.
Thanks! I did a factory reset and installed gapps. Everything works again. I guess when upgrading android versions using the CM updater, gapps will always have to be reinstalled? This is by design? Weirdly, no other gapps had any issues after the upgrade. Gmail, youtube, etc all worked fine, just not the play store.
Current Phone: Sony Xperia Z ultra C6806 Sony Edition

Previous: HTC Touch Diamond, HTC Hero, Evo 4G, Samsung S II, Note 1 intl.
 
leapinlar
Old
#4  
leapinlar's Avatar
Recognized Contributor
Thanks Meter 3,613
Posts: 8,227
Join Date: Oct 2006

 
DONATE TO ME
Quote:
Originally Posted by LxMxFxD View Post
Thanks! I did a factory reset and installed gapps. Everything works again. I guess when upgrading android versions using the CM updater, gapps will always have to be reinstalled? This is by design? Weirdly, no other gapps had any issues after the upgrade. Gmail, youtube, etc all worked fine, just not the play store.
You only need to update gapps when you do a major update like you did from CM10.1 to CM10.2. But you now have CM10.2 stable so there will be no more updates to it.

Sent from my BN NookHD+ using XDA Premium HD app
See my Nook Color Tips Thread here,
and my Nook Color EMMC Partition Repair Thread here,
and my Nook Color Updated CM SD Installation Instructions here,
and my Nook HD/HD+ stock tips thread here
and my Nook HD/HD+ CWM Root Tools thread here
e.mote's Nook HD/HD+ Dummies Guide for installing CM10.1/CM10.2/CM11 here
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes