View Poll Results: Should AT&T stop locking down our Bootloaders?
Yes 2 66.67%
No 0 0%
No waaaay!!! 0 0%
Are you dense? Heck no !!! 1 33.33%
Voters: 3. You may not vote on this poll

Post Reply

[Q] S4 ATT i337 on Stock MK2.jeboo kernel/rec needed 2 install SHOstock v3.0 ?

OP djmisi99

10th March 2014, 12:18 AM   |  #1  
Hey guys,

I am very familiar with custom roms and your kernels, from always using them on my SGS2 i777 (AT&T), but i just bought an SGS4 i337 AT&T, on MK2 baseband, and everybody suggested I should install the SHOstock v3.0 for the i337 (http://forum.xda-developers.com/show....php?t=2305752).

Problem is, I am sooooo confused now, because there is jeboo kernels: (Jeboo_Kernel_i337_v3_0a-i.zip, Jeboo_Kernel_i337_v3_0a.zip, Jeboo_Kernel_i337_v3_0.zip, Jeboo_Kernel_i337_v2_2.zip)
...than there's your RECOVERY: Jeboo_Recovery_v2_1.zip

so Im very confused now how I should go about installing our most awesome DEV shoman94's SHOstock v3.0) ROM...==> THAT I DUNNO WHAT SHOULD I DO ANYMORE.....

1. Because, on the thread there (http://forum.xda-developers.com/show....php?t=2305752), in POST#1 it says , in the Instructions, that :We must be running a custom recovery using Jeboo's Recovery from Post#4 which is your Jeboo_Recovery_v2_1.zip

2. But how should I run the Jeboo_Recovery_v2_1.zip RECOVERY, if Im on SafeStrap 3.71 (which is a recovery also)???
3. If i flash Jeboo_Recovery_v2_1.zip, wont that brick (or softbrick) the S4?
4. Or if I flash Jeboo_Recovery_v2_1.zip, will I end up having 2 recoveries? Or will I only end up with having only the Jeboo_Recovery_v2_1 ???

5. In POST#3, it says that:
IF YOUR PHONE HAS MF3/MK2 BOOTLOADERS, YOU MUST RUN THE MF3/MK2 STOCK KERNEL. DO NOT TRY INSTALLING ANYTHING BELOW UNLESS YOU HAVE MDB/MDL BOOTLOADERS THAT SUPPORT LOKI!!

So, should I NOT flash your Jeboo_Kernel_i337_v2_2.zip , since I am on MK2 stock kernel/baseband/bootloader....?

Check it out: http://i.imgur.com/cNWijKF.png

7. I mean, what is BELOW MF3/MK2 and ABOVE MDB/MDL? Because it also says, that: All binaries posted here will be loki'd (as signified by the .lok extension).

SO, keeping in mind that Im on Stock MK2 , but also Im ROOTED via SAFEROOT.zip (as you can see in the pic above: (http://i.imgur.com/cNWijKF.png) , can someone please tell me if I should flash this SHOstock v3.0, and more speciafically, WHICH, IF ANY of you jeboo kernels and Jeboo Recovery should I use?

Can I bug any of you to tell me the exact steps on how to get this SHOstock 3.0 on my i337, if I'm on MK2, rooted, and safestrap-ed?

ANy help would be much appreciated
Attached Thumbnails
Click image for larger version

Name:	cNWijKF.png
Views:	78
Size:	196.2 KB
ID:	2622372  
10th March 2014, 12:23 AM   |  #2  
ted77usa's Avatar
Recognized Contributor / Themer
Flag Fog City
Thanks Meter: 3,788
 
2,357 posts
Join Date:Joined: Jan 2010
Donate to Me
More
@djmisi99
U should check this thread..... http://forum.xda-developers.com/show....php?t=2616221 Make sure you check on MK2 section coz that thread also have NB1 section......FYI check SHOStock-v3.1-Safestrap Edition on that link above ....Goodluck:thumbup::thumbup:

Swyped From MK2 Dark Venom SS Edition
Last edited by ted77usa; 10th March 2014 at 12:30 AM.
The Following User Says Thank You to ted77usa For This Useful Post: [ View ]
10th March 2014, 12:27 AM   |  #3  
jd1639's Avatar
Recognized Contributor
Minnetonka, MN
Thanks Meter: 3,532
 
10,240 posts
Join Date:Joined: Sep 2012
You're not very familiar with the s4. You're very limited on what you can do with it

Sent from my Nexus 5
10th March 2014, 05:21 PM   |  #4  
Siill got SS :)
Quote:
Originally Posted by jd1639

You're not very familiar with the s4. You're very limited on what you can do with it

Sent from my Nexus 5

*****************************
Still got SafeStrap ROM...which at this point is 30+ some ROMz...which ain't that bad....considering....
Could of done without the hassle of ONLY SS Romz, much more prefer the CM, PACman, JellyBAM, Paranoid ANdroid, Carbon, AOKP AOSP ROmz...but hey... it's just wasn't in the cards, ya know.....?
Last edited by djmisi99; 10th March 2014 at 06:44 PM.
12th March 2014, 07:34 PM   |  #5  
Quote:
Originally Posted by ted77usa

@djmisi99
U should check this thread..... http://forum.xda-developers.com/show....php?t=2616221 Make sure you check on MK2 section coz that thread also have NB1 section......FYI check SHOStock-v3.1-Safestrap Edition on that link above ....Goodluck:thumbup::thumbup:

Swyped From MK2 Dark Venom SS Edition

THX, bud...I'll give it a shot...
12th March 2014, 07:46 PM   |  #6  
ted77usa's Avatar
Recognized Contributor / Themer
Flag Fog City
Thanks Meter: 3,788
 
2,357 posts
Join Date:Joined: Jan 2010
Donate to Me
More
Quote:
Originally Posted by djmisi99

THX, bud...I'll give it a shot...

@djmisi99
We made history last night ...we able to install our Deadly Venom V3 KitKat edition for Safestrap user ....check my downgrade method thread .....and i would post the guide and link tonight to the public......[emoji106] PM me if u interested to try it...... huge thanks to my team mate @Venom0642 @rebel1699 and Deadly Venom Safestrap tester @Maribou @dave5777 and couples others ...[emoji106]



Swyped From MK2 Dark Venom SS Edition
The Following User Says Thank You to ted77usa For This Useful Post: [ View ]
12th March 2014, 08:40 PM   |  #7  
Quote:
Originally Posted by djmisi99

THX, bud...I'll give it a shot...

Sure i would love to try it, bud...
But can you give me a COMPETE GUIDE of HOW-TO?
Keep in mind, Im on Stock MK2, rooted, safestrap 3.71.
Should I upgrade to NB1 first?
Flash some modules?
Flash some modem?
and compatibility pack?

Once on NB1, can I come back to MK2, just in case?
Some ppl say there is no root, of one is on NB1...is that true?

ANyways, please PM me, or publicly let me know the STEPS....from A to Z

THX, TED!!!!
12th March 2014, 09:17 PM   |  #8  
karate104's Avatar
Senior Member
Thanks Meter: 104
 
354 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by djmisi99

Hey guys,

I am very familiar with custom roms and your kernels, from always using them on my SGS2 i777 (AT&T), but i just bought an SGS4 i337 AT&T, on MK2 baseband, and everybody suggested I should install the SHOstock v3.0 for the i337 (http://forum.xda-developers.com/show....php?t=2305752).

As another user who came from the i777 forums, the biggest thing that wasn't explicitly stated anywhere that tripped me up was that recovery and kernel are NOT linked. That is, you can flash a custom recovery, e.g. Safestrap (which you seem to have already done) without changing the kernel at all. That allows you to flash custom ROMs via the custom recovery, but limits you to ONLY ROMs that can use the stock kernel (they're usually labeled for Safestrap).

As far as being on MK2, an MK2 bootloader cannot be modified with the Loki exploit, therefore you cannot change the stock kernel and thus your phone will remain locked. Thus, Safestrap is your only option. Devs are working on it, but progress has been pretty slow and SS works well in the meantime. It just kinda bites not having the freedom we used to have, but I can't really complain too much.

Just thought I'd share some useful info
The Following User Says Thank You to karate104 For This Useful Post: [ View ]
13th March 2014, 04:59 PM   |  #9  
Quote:
Originally Posted by karate104

As another user who came from the i777 forums, the biggest thing that wasn't explicitly stated anywhere that tripped me up was that recovery and kernel are NOT linked. That is, you can flash a custom recovery, e.g. Safestrap (which you seem to have already done) without changing the kernel at all. That allows you to flash custom ROMs via the custom recovery, but limits you to ONLY ROMs that can use the stock kernel (they're usually labeled for Safestrap).

As far as being on MK2, an MK2 bootloader cannot be modified with the Loki exploit, therefore you cannot change the stock kernel and thus your phone will remain locked. Thus, Safestrap is your only option. Devs are working on it, but progress has been pretty slow and SS works well in the meantime. It just kinda bites not having the freedom we used to have, but I can't really complain too much.

Just thought I'd share some useful info

THX for the insightfull info bud...That was very informative!
I always loved PACman, AOKP, AoCP on my S2, S3, but this AT&T i337 MK2, with locked bootloader...gave me a headache...but that's why we got SadeStrap, thanks for the great DEVS out there...we appreciate your works, and support you with buying you beers and icetea... because we love ur work, guys!
Keep up the good work!
16th March 2014, 05:01 PM   |  #10  
Quote:
Originally Posted by ted77usa

@djmisi99
We made history last night ...we able to install our Deadly Venom V3 KitKat edition for Safestrap user ....check my downgrade method thread .....and i would post the guide and link tonight to the public......[emoji106] PM me if u interested to try it...... huge thanks to my team mate @Venom0642 @rebel1699 and Deadly Venom Safestrap tester @Maribou @dave5777 and couples others ...[emoji106]



Swyped From MK2 Dark Venom SS Edition

Ted,
you said: check my downgrade method thread ....can you give us the link?

THX

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes