Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,098 Members 46,839 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bluetooth poor connexion with wireless heaphones/speakers

Tip us?
 
pascalforget
Old
(Last edited by pascalforget; 10th March 2014 at 03:07 AM.) Reason: Added steps taken + precisions.
#1  
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Mar 2014
Default [Q] Bluetooth poor connexion with wireless heaphones/speakers

Hello. I received my Omate US Version, 8Gb a few days ago, stock version of the system (reinstalled after trying the excellent Lokifish Marz firmware).

The Bluetooth connexion seems very poor for music transmission with Bluetooth headsets or speakers; when I move to watch more than 10 centimeters (about 4 inches) away from the Omate interference starts (the music "stutters") and connection stops completely (disconnects) at about 20-30 centimeters. Can't listen to music consistently while moving my arm (... when I walk).

Could there be an hardware issue with the Bluetooth antenna?

I tried rebooting, turning Bluetooth on and off multiple times, even reinstalling the firmware (the issue was present with the Lokifish Marz firmware).

I'm trying to listen simple 128 kbps mp3 (non VBR). (I discovered the issue while listening 192 kbps vbr, I taught it was the problem...).

The only way I manage to have a smooth playback is by putting the Omate in the same pocket as the receptor of the Bluetooth headset, or with a Bluetooth emitter clipped to the watchband (I tried with three different Bluetooth headsets and also a Bluetooth speaker that works perfectly with my other phones.

Thanks for your advices and suggestions.
 
Lokifish Marz
Old
(Last edited by Lokifish Marz; 10th March 2014 at 05:39 AM.)
#2  
Lokifish Marz's Avatar
Recognized Contributor / Recognized Developer
Thanks Meter 3250
Posts: 3,140
Join Date: Mar 2011
Location: Olympus Mons, Mars

 
DONATE TO ME
Lose antenna connector. Request a replacement.
Ubuntop- U4A/Webtop hybrid for all Tegra2 Motorola phones (Fully integrated Ubuntu Desktop)
Live ROM (One "ROM" over 12 phones) (Featured on XDA Portal and multiple other sites around the world and as base by many devs)
Imperium Initiative Photon (used as base by many Photon devs)
Imperium Initiative LS970 (used as base by many LS970 devs)
Imperium Agent LS970 (LS970 version of Live ROM)
Evo Desktop PC (Featured on XDA Portal and multiple other sites around the world)
(Nexus Q)uantum Singularity Project (Media Center, File Server, Website Server, LinuxonAndroid in little black ball of joy)
Umeox x201 EnSec Enhanced Security Patch and Live ROM Installer (used by multiple devs world wide on over 6 different models/versions of x201's)
Every Android device I've owned since the Hero- Media Center, File Server, Website Server
The Following User Says Thank You to Lokifish Marz For This Useful Post: [ Click to Expand ]
 
flimmyflam
Old
#3  
Junior Member
Thanks Meter 0
Posts: 16
Join Date: Mar 2014
My bluetooth connection to my stereo in my car also stutters and disconnects. I also have a hard time connecting.
 
trent999
Old
#4  
Senior Member
Thanks Meter 52
Posts: 256
Join Date: Nov 2013
Just so folks will not get the wrong idea, on my stock 1/8/1900 TrueSmart with 20140120 firmware, the Bluetooth is excellent for music and phone both in my car or with BT headphones, and BT keyboard. It will also connect to the keyboard and another BT device at the same time. Range is excellent, 15 meters or more.

Lots of other Bluetooth issues, but these reports sound like antenna problems. Assembly on some TrueSmarts was very poorly done.

Sent from my Nexus 7 using Tapatalk
The Following User Says Thank You to trent999 For This Useful Post: [ Click to Expand ]
 
eozdalga
Old
#5  
Senior Member
Thanks Meter 21
Posts: 174
Join Date: Oct 2010
Location: Mountain View
Quote:
Originally Posted by pascalforget View Post
Hello. I received my Omate US Version, 8Gb a few days ago, stock version of the system (reinstalled after trying the excellent Lokifish Marz firmware).

The Bluetooth connexion seems very poor for music transmission with Bluetooth headsets or speakers; when I move to watch more than 10 centimeters (about 4 inches) away from the Omate interference starts (the music "stutters") and connection stops completely (disconnects) at about 20-30 centimeters. Can't listen to music consistently while moving my arm (... when I walk).

Could there be an hardware issue with the Bluetooth antenna?

I tried rebooting, turning Bluetooth on and off multiple times, even reinstalling the firmware (the issue was present with the Lokifish Marz firmware).

I'm trying to listen simple 128 kbps mp3 (non VBR). (I discovered the issue while listening 192 kbps vbr, I taught it was the problem...).

The only way I manage to have a smooth playback is by putting the Omate in the same pocket as the receptor of the Bluetooth headset, or with a Bluetooth emitter clipped to the watchband (I tried with three different Bluetooth headsets and also a Bluetooth speaker that works perfectly with my other phones.

Thanks for your advices and suggestions.
I've only tried to exercise with it once while using Bluetooth and the same thing happened (switched back to my iPod after 2 minutes). I am currently on stock and plan to go back to the newest patch. I will try on both stock and patch and see if it's still happening. I hope this is indeed not an issue of poor assembly.

---------- Post added at 01:21 AM ---------- Previous post was at 12:41 AM ----------

Quote:
Originally Posted by Lokifish Marz View Post
Lose antenna connector. Request a replacement.
Wow, okay just tested (both mp3 and movies stored on both internal and SD). When connect to Bluetooth, any movement causes stutter and pausing. When off bluetooth, no problems.

I've already removed the back cause went I flashed the ROM there were issues that require a battery pull and I installed an SD card. Not to mention, I emailed support over a week ago for another issue (now resolved) and no response.

Hope this can be fixed because this device is worthless if I can't run with it using Bluetooth!
The Following User Says Thank You to eozdalga For This Useful Post: [ Click to Expand ]
 
gigaguy
Old
#6  
Member
Thanks Meter 5
Posts: 71
Join Date: Nov 2006
Location: NC
I have a Jabra Sport BT headset. I've used it with 2 different MotoactV and now this TS. Same signal issue on all of them. So I dont think it's the TS. I always had to wear both my MA and now TS on my right hand when using the headset while running.
Device: Samsung Galaxy S4
Watch: Motoactv 16gb
 
pascalforget
Old
#7  
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Mar 2014
Default Any movement causes stutter and pausing.

Quote:
Originally Posted by eozdalga View Post
Wow, okay just tested (both mp3 and movies stored on both internal and SD). When connect to Bluetooth, any movement causes stutter and pausing. When off bluetooth, no problems.
I agree, I also have the feeling that simply moving the watch increases the interference.
...
Quote:
Originally Posted by eozdalga View Post
Hope this can be fixed because this device is worthless if I can't run with it using Bluetooth!
Same here, I got the Omate Smartwatch specifically to run with music and GPS.

I wrote to support@omate.com, so far no answer.

P.
 
xkongox
Old
#8  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Sep 2006
@Lokifish Marz

is there any way we could try to fix a loose antenna connector?
 
Lokifish Marz
Old
#9  
Lokifish Marz's Avatar
Recognized Contributor / Recognized Developer
Thanks Meter 3250
Posts: 3,140
Join Date: Mar 2011
Location: Olympus Mons, Mars

 
DONATE TO ME
Quote:
Originally Posted by xkongox View Post
@Lokifish Marz

is there any way we could try to fix a loose antenna connector?
Remove the back, battery and plastic insert. Reseat the connectors then reinstall the insert, battery and back.
Ubuntop- U4A/Webtop hybrid for all Tegra2 Motorola phones (Fully integrated Ubuntu Desktop)
Live ROM (One "ROM" over 12 phones) (Featured on XDA Portal and multiple other sites around the world and as base by many devs)
Imperium Initiative Photon (used as base by many Photon devs)
Imperium Initiative LS970 (used as base by many LS970 devs)
Imperium Agent LS970 (LS970 version of Live ROM)
Evo Desktop PC (Featured on XDA Portal and multiple other sites around the world)
(Nexus Q)uantum Singularity Project (Media Center, File Server, Website Server, LinuxonAndroid in little black ball of joy)
Umeox x201 EnSec Enhanced Security Patch and Live ROM Installer (used by multiple devs world wide on over 6 different models/versions of x201's)
Every Android device I've owned since the Hero- Media Center, File Server, Website Server
 
xkongox
Old
#10  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Sep 2006
Which connector is the bluetooth antenna?
Attached Thumbnails
Click image for larger version

Name:	20140310_090151.jpg
Views:	133
Size:	270.7 KB
ID:	2623467  

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes