Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

USB Desktop Charger Roundup – XDA TV

Sometimes you learn one way to do something, and that’s the way you do it forever. You never … more

Samsung Galaxy Grand Duos Receives Early CM12 Port

Samsung Galaxy Grand is a dual-SIM phone with a 5 screen that was announced two years ago. … more

Google Adds New Features to Drive, Sheets, Slides and Docs

In the last few months, Google has been working very hard to adapt all its apps to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Camera failed error!

OP lilpyxie

6th March 2014, 03:03 AM   |  #1  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
Hi all,

I have an ATT samsung galaxy s3, out of warranty period. My phone's camera has stopped working entirely since 2 months. Its really frustrating! I have tried everything from going back to stock roms then custom roms.

A little history:

- I installed an app ipcam to monitor my baby, I left the cam on with flashlight and was gone for half an hour, since then I had cam freezing probs until one day it stopped working.
- I was trying a lot of options and one day the camera worked only for 5 mins. then when i tried again it was not working.

Please help!

I am currently on android 4.3, Intergalactic ROM 4.1 and MJB baseband.

I also had my sd card corrupted during that same time and have started using a new memory card since 1 week.
6th March 2014, 06:29 AM   |  #2  
BammS2's Avatar
Member
Flag Wharton,Texas
Thanks Meter: 29
 
34 posts
Join Date:Joined: Dec 2012
More
Did you try downloading another camera from the play store?
6th March 2014, 11:40 AM   |  #3  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
Yes I tired all sorts of camera apks none work....


Sent from my SAMSUNG-SGH-I747 using xda app-developers app
6th March 2014, 03:02 PM   |  #4  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
Yes I tried all sorts of camera apks none work....

I feel the file system is corrupted or something but I did factory reset and clean system, cache, dalvik cache, before installing roms so that should take care of it, but doesn't seem to help. I was on liquidsmooth 4.4 earlier when my problems began and I had installed some kernel had done dirty flashing, then I did a clean install of stock fw, but the problem still existed.

I read somewhere that switching bootloaders can screw camera files. So how to correct it there must be something I can do. I need to click my rowing baby's pictures I am missing all those moments when you wish you had a good camera at hand to make videos !
6th March 2014, 04:28 PM   |  #5  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by lilpyxie

Yes I tried all sorts of camera apks none work....

I feel the file system is corrupted or something but I did factory reset and clean system, cache, dalvik cache, before installing roms so that should take care of it, but doesn't seem to help. I was on liquidsmooth 4.4 earlier when my problems began and I had installed some kernel had done dirty flashing, then I did a clean install of stock fw, but the problem still existed.

I read somewhere that switching bootloaders can screw camera files. So how to correct it there must be something I can do. I need to click my rowing baby's pictures I am missing all those moments when you wish you had a good camera at hand to make videos !

that really sucks, we just had my little man not to long ago and i take lots of pictures. i had trouble with my N7 after flashing an update to the rom the camera from the gallery app was non existent and i could only take pictures from facebook with their camera app. I tried some apps from play store and other areas and i got the message "camera system not recognized" or something to that extent. I downloaded gallery+ with the camera app included and it's worked ever since. Although i only follow one developer when it comes to the N7 (although i use to switch a lot before hand).


i just got my S3 about 2 weeks ago so i'm not familiar with this gadget but.. maybe you fried your camera's hardware? i really hope i'm wrong and someone more experienced can lend a hand. i swapped bootloaders (we could of took different routes of course), played with just a few roms on the S3 but stopped after i learned more about touchwiz (cant believe i actually like a stock based rom ).

sorry for my story lol, did you try the facebook camera (the take a picture option or something like that), i know it sounds silly but again it was the only thing that worked on my N7 besides the gallery camera app. Hope you get it working again!
The Following User Says Thank You to DazTip For This Useful Post: [ View ]
8th March 2014, 06:56 PM   |  #6  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
I tried the gallery and Facebook app anything that needs camera doesn't work... But thanks for your input... M glad you understand my plight of not being able to take my baby's pics...

I am on mj boot loader and the camera rear fw I found does null null in sys/class/camera I guess that is the problem.. The system is not being able to connect to the camera ...I don't think it's a hardware issue cuz camera worked for five minutes when I had done a clean install..

I was on liquid smooth before that's where problems started I did done update then installed the previous version... Don't remember what was it exactly

I'm so hoping somebody can help me in this someone who has a better knowledge of how the camera files are laid..I have camera 1.5 in my phone if that helps...

Sent from my SAMSUNG-SGH-I747 using xda app-developers app
10th March 2014, 06:44 AM   |  #7  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
Plz anybody suggest something!!

Sent from my SAMSUNG-SGH-I747 using xda app-developers app
10th March 2014, 08:42 AM   |  #8  
kdoggy's Avatar
Senior Member
Thanks Meter: 57
 
582 posts
Join Date:Joined: Jun 2010
Not sure if this will help but I was on 4.1.1 and I flashed to a 4.3 ROM and had nothing but issues. I flashed back to my 4.1.1 and I got the SAME camera error.

Turned out that that the 4.3 ROM included a bootloader update that was not compatible with the 4.1.1 ROM, it broke the camera.

I downgraded back to the 4.1.1 bootloader and the camera started working again.

Please note that some bootloaders can NOT be downgraded and you will brick your phone.
10th March 2014, 12:28 PM   |  #9  
OP Junior Member
Atlanta
Thanks Meter: 0
 
27 posts
Join Date:Joined: Sep 2011
More
Thanks for your reply, I'm on MJB boot loader and I guess one can't downgrade from that to a 4.1.1 system so is there no hope for my camera recovery?
Are there any files that I can copy paste to make it work.. ? What happens when the boot loader changes? Why can't we have a boot loader that would run camera on 4.1.1? ..plz guys I know this can b done.. There must be a way...

Sent from my SAMSUNG-SGH-I747 using xda app-developers app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes