Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,956 Members 49,678 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Galaxy t679 root issues; Dire need of help/advice

Tip us?
 
BobScramit
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
Default [Q] Galaxy t679 root issues; Dire need of help/advice

Okay, so.. Excuse me in advance if I'm in the wrong section of the forums, because this is the only Exhibit section I can find.. And also excuse me for the length of this post, as my problem is a bit detailed.

Long story short, I had issues with my texts not being received. I tried wiping the phone and re-rooting (using root-stock found on this website - I can link if need be?).. Anyway, I went so far as to do a factory data wipe, which clearly wasn't a very good idea (I'm a bit new at this root business)..

Anyway, I ended up to the point where I'd reach the Android Setup Wizard, and start to go through it and it would crash.. Upon reboot, the phone would completely freeze at the second "SAMSUNG" logo (the white lettering). After this, I tried using odin to just flash the stock ROM to the phone via the PC, but neither the PC nor odin actually "see" the phone. (I have the drivers, but PC reads the phone as "USB Hub" for some reason) I moved on to other things...

I used bluetooth to put cwm and root-stock back onto the internal memory after removing my external SD card, and flashed cwm no problem. Everything was going well, and it even said it installed the root-stock (I did a data wipe beforehand).. Upon reboot, I now reach "Samsung Galaxy Exhibit 4G" logo, and it continually reboots in a loop. I can still access recovery mode, but I don't want to proceed any further without some outside input, considering I don't fully understand what's going on.

I'm aware that the phone seems to be "soft-bricked," because before I flashed cwm and root-stock, it was "working" in terms of being able to receive calls (and make them, after opening the contacts from inside a call), as well as send and receive texts via the notification bar. But the weirdest thing is, before I went the route of re-flashing the root/cwm, it wouldn't show me a homescreen of any kind, I couldn't use my menu button, and my home button was pointless to touch because it went nowhere. It was just a black screen (not a background, but completely black void) with a statusbar at the top.

Anyway, I'm currently stuck in a boot-loop and I'm very curious if there's any way I can fix this phone without using odin, because the phone isn't recognized by it or a PC, so I'm stuck using the device itself to do things. I'm VERY hopeful that someone takes the time to read this and offer any input they can, because I'm currently without a device and I have no means of getting another phone at the moment.

Thanks in advance for reading this, and for any input that you guys have to offer. Hopefully some day I'm not so noobish at this >.<
 
Dvarl
Old
#2  
Dvarl's Avatar
Senior Member
Thanks Meter 86
Posts: 253
Join Date: Dec 2009
Location: Orland Park
Ok, I know you've said you wiped but try this then reboot. In CWM wipe data/cache and under advanced wipe dalvik. Also if you have a working CWM you can flash rooted community ROM or flash to stock found here http://forum.xda-developers.com/show....php?t=1686384 scroll down till you see them. But wipe 3x don't know why some people need to but try it.

Note: a working cwm can flash any custom ROM with root pre-installed and you should be fine if you wipe the three I mentioned 3x format system under mounts and storage and format internal sd works wonders too.

Sent from my SGH-T679 using xda app-developers app

---------- Post added at 05:54 PM ---------- Previous post was at 05:53 PM ----------

If you need more help feel free to send me a pm

Sent from my SGH-T679 using xda app-developers app
The Following User Says Thank You to Dvarl For This Useful Post: [ Click to Expand ]
 
BobScramit
Old
(Last edited by BobScramit; 11th March 2014 at 07:56 AM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
Quote:
Originally Posted by Dvarl View Post
Note: a working cwm can flash any custom ROM with root pre-installed and you should be fine if you wipe the three I mentioned 3x format system under mounts and storage and format internal sd works wonders too.
If I do a format of system or internal SD, I won't lose the ROM or CWM off of the system storage? If I lose these, I have no way of putting them back on the phone because I was doing it via bluetooth and the phone doesn't boot in order to do that anymore - The same applies to using a different ROM, sadly >.<

Also, I've already wiped the dalvik and cache several times, because that was the only way I could make the phone boot into a mode I could access anything at all on previous to installing the root again. I haven't tried doing this again as of yet, but I will do so and report back.


Just some extra information, because it wouldn't allow me to do so (being new and having to wait):

When I rebooted after the format (to the original stock rom/recovery, and even from recovery) it gave an "invalid argument" for /preload, saying it was unable to be accessed. It also said it couldn't access tmb/csc/system.. I'm unsure what these actually are, but I'm under the impression they may be at the route of my problem. Will formatting repair or otherwise help with these items being unable to be accessed?
 
jfbs
Old
(Last edited by jfbs; 21st March 2014 at 06:33 AM.)
#4  
Senior Member
Thanks Meter 635
Posts: 279
Join Date: May 2012
Formatting internal will get rid of ROM, but not recovery. You'll be fine if you wipe system and reboot (ed: need to install a rom before reboot).

Try putting your ROM.zip on your external before wiping internal by mounting USB storage and copy ROM to external, then wipe internal and install ROM.
The Following User Says Thank You to jfbs For This Useful Post: [ Click to Expand ]
 
BobScramit
Old
(Last edited by BobScramit; 11th March 2014 at 10:23 PM.)
#5  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
Formatting system (twice) didn't help anything at all - Still gets stuck at Exhibit logo and reboots after about 30 seconds.
Same thing with wiping dalvik/cache, even after 4-5 wipes of each. Should I be rebooting recovery after each of these?

I can't mount usb storage to PC, because PC doesn't recognize the device when I plug it in afterward (or even before mounting). It hasn't recognized the device for quite some time, but it used to act as if it were plug & play when I purchased it, and even well into the time it was rooted. A few months back, I installed the drivers for it (found via Google and ultimately this website), which didn't help it recognize the device. It only recognizes the device when in the "MTP" mode, which allows me to access and transfer data without issues(and I can't do this without being able to access the phone to turn it on ). Otherwise, it says "USB Device Not Recognized - One of the USB devices attached to this computer has malfunctioned and Windows does not recognize it"

I already have the ROM on my PC, but without any means of transfer back to the phone, removing it from internal storage would mean I have no physical way of accessing any ROM in order to restore my phone to working order. I'm at a loss as far as this is concerned, because I have the drivers installed. I'm unsure whether the phone itself is damaged, but I hope this isn't the case and that there's a way to resolve this issue directly.

My biggest concern isn't really the PC not recognizing the device, apart from needing it if I remove the ROM. My main concern is getting the thing to actually boot beyond the logos.. But if I remove the ROM, how will I put it back when it doesn't load to be able to bluetooth anything, and the PC doesn't recognize what it is?

EDIT -

I just realized something... Mounting USB storage doesn't seem to matter as far as moving the ROM, because I can just move them around via the external SD using CWM to flash them - But this is assuming that CWM will remain on the phone after formatting internal SD. Will it stay? If so, I'm going to try rooted community ROM, because the root-stock gives me the impression that it does nothing but apply root. The thread states "otherwise no changes to your phone," which implies (to me) that it doesn't actually include anything the phone needs in order to operate - It only changes certain things to apply root access... Not sure if this is true or not, but it would help explain what the heck is going on.
 
BobScramit
Old
(Last edited by BobScramit; 11th March 2014 at 11:11 PM.)
#6  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
OH MY GOD! YOU GUYS ARE AMAZING!!

Thank you SO, SO MUCH for helping me. My device is no longer a useless paperweight
I wish I could click the "Thanks" button a thousand times!!

Just incase anyone else has this issue and is able to access notification bar, this is what I did from beginning to end, without all the nonsense between times:
1) Turn Bluetooth on
2) Transfer Clockworkmod via bluetooth to internal SD. ((Tip: Use a separate android device to do this, if PC isn't capable) If already installed skip to step 4)
3) Re-flashed Clockworkmod
4) Place Rooted Community ROM (found here) onto external SD and insert SD into device.
5) Boot device into Custom Recovery (CWM)
6) Wipe cache/dalvik (I did it 4-5 times, just to make sure it was clear)
7) Format system AND rom AND SDCard (internal ONLY - I did all 3 times just to be sure)
8) Flashed Rooted Community ROM from external SD card (it takes some time to install - It will say when completed)
9) Rebooted phone via Custom Recovery - When clicking this, be sure to select NO when it asks to fix the root. I clicked "YES" the first time and it DID NOT FIX THE PHONE. It got stuck in another boot-loop.
10) Initial boot took a bit longer than usual (which is normal), but afterwards, I no longer have a phone that's soft-bricked.

I just wanted to say THANK YOU GUYS VERY, VERY MUCH. You've saved my life by helping me sort through this! Very, very appreciative and I hope both of you have a wonderful day
 
jfbs
Old
#7  
Senior Member
Thanks Meter 635
Posts: 279
Join Date: May 2012
Good to know. I think you may have lost PNP from a windows update by samsung. To get that back, uninstall those drivers and look for 1.3.2410 or here if interested.
 
BobScramit
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
Still the same issue. Device isn't recognized with normal MTP (just plugging into the USB), and it acts as if I haven't even plugged it in at all when trying to use "Mass Storage" from the Network settings in the phone.

I just direct installed the drivers from the exe. Am I doing something wrong?
 
jfbs
Old
(Last edited by jfbs; 15th March 2014 at 05:12 PM.)
#9  
Senior Member
Thanks Meter 635
Posts: 279
Join Date: May 2012
Try another port, cable, or machine. It worked before, so it could be a driver or something physical.

ed: When you're booted into your rom, can you change storage connection to ums? cwm might be mass storage instead of mtp.

Also, are you able to receive texts now?
 
BobScramit
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Sep 2013
I'm able to do everything the device is supposed to do out of the box, aside from access MTP.

I only have the one PC, and all ports have pretty much the same reaction to the device. I don't have access to another cable, because I only have the one that came with the device.

Mounting USB Mass Storage through CWM gives the same result on the PC "Device Not Recognized" etc, etc.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Forums Added for the LG G Watch R and Samsung Gear S

A little over a week ago, LG “inadvertently” let the world know about the … more

Secrecy App Goes Open Source, New LG Android Wear Device! – XDA Developer TV

Secrecy encryption app goes open source! That and much … more

Pushbullet Updated with SMS Send Ability

Pushbullet is one of thoseapplications that every Android lover should have installed on his or … more

[OTA] Nvidia Shield Tablet Receives its First Update

The Nvidia Shield Tabletis the latest toy from one of the largest desktop graphics … more