Post Reply

[Q] Part of screen doesn't work (ST15i)

OP nameless987

10th March 2014, 09:39 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Feb 2014
More
I have sony xperia ST15i and parts of my screen doesn't work (Please see attached image, parts that are colored red are not working).
So my question is: How can I fix this?
I tried using some apps for screen recalibration and I tried reflashing stock firmware and nothing seems to help.
Do I need to take it apart and clean the contacts or do I need to change touch screen?
Attached Thumbnails
Click image for larger version

Name:	images.jpg
Views:	184
Size:	15.2 KB
ID:	2623912  
11th March 2014, 02:08 PM   |  #2  
coolancool's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 268
 
631 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by nameless987

I have sony xperia ST15i and parts of my screen doesn't work (Please see attached image, parts that are colored red are not working).
So my question is: How can I fix this?
I tried using some apps for screen recalibration and I tried reflashing stock firmware and nothing seems to help.
Do I need to take it apart and clean the contacts or do I need to change touch screen?

You bricked your touchscreen IMO
It's time to change the digitizer

Sent from my WT19i using XDA Premium 4 mobile app
The Following User Says Thank You to coolancool For This Useful Post: [ View ]
11th March 2014, 02:58 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by coolancool

You bricked your touchscreen IMO
It's time to change the digitizer

Sent from my WT19i using XDA Premium 4 mobile app

Thanks for response.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes