Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,208 Members 37,834 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Link2SD problem on SG S2

Tip us?
 
erehwon
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jun 2007
Default [Q] Link2SD problem on SG S2

I have been using OmniROM KitKat on my Galaxy S2 for a while with no problems. I've recently had a GPS issue (still don't know the cause but that's another issue for another day) so decided to update my ROM to the latest nightly. The update went well, but then I found that I could not access any of my apps that had been copied using Link2SD.

I had created an EXT3 partition on my SD card and linked all files onto there using Link2SD. It had been working perfectly before but the update had obviously changed something in my system. When I run Link2SD, I get the following message:
mount: Device or resource busy

Googling this it looks like the partition is already mounted (a2sd?) or some scripts are missing. (Link2SD still has root permissions) I've had a look in init.d but can't see anything remiss, though I'm moving out of my comfort zone here.

Can anyone tell me what I should do next? Do I need to delete and recreate the EXT3 partition, copying the data back on to it? Would uninstalling and reinstalling Link2SD help, or would that cause even more trouble?

Finally, if I do another ROM update, what should I do to stop this happening again?

Thanks for your help.
 
erehwon
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jun 2007
I've had some success with this. I reformatted the partition to be FAT32 and Link2SD accepted this and created the necessary mount links. I then copied the files (apk etc) back onto the partition and everything is working again.

Now is FAT32 a good option for this partition or is it best to use EXT?

Ta
Tags
link2sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes