FORUMS

Huawei To Sell Honor Smartphones Via Indian Retail Outlets

World’s fourth largest smartphone maker Huawei plans to now sell its … more

Sunday Debate: Are Smaller Bezels Better or Worth It?

Bezels have been getting smaller and smaller as the years go by, and while devices … more

LG G4 First Impressions and Unboxing – XDA TV

The latest in LG’s signature line of “G phones” has been released. … more

Galaxy S6 Weekly Shooting Challenge

Over in our forums this weekend, XDA Forum member DevonSloan has started a thread for talented … more
Post Reply Subscribe to Thread Email Thread

Losing 4G connection

12th March 2014, 04:04 PM |#1  
OP Member
Thanks Meter: 2
 
More
I have the app LTE OnOff which allows you to set Preferred Network Types. This is the list of options:

0 WCDMA preferred
1 GSM only
2 WCDMA only
3 GSM auto (PRL)
4 CDMA auto (PRL)
5 CDMA only
6 EvDo only
7 GSM/WCDMA, CDMA, and EvDo (PRL)
8 CDMA + LTE/EvDo auto
9 GSM/WCDMA/LTE auto
10 CDMA/EvDo/GSM/WCDMA/LTE auto
11 LTE only
12 LTE,CDMA

I have it set to CDMA + LTE/EvDo auto which allows both 3G and 4G. What often happens is that I will lose 4G and the preferred network will switch itself to something else, like CDMA auto (PRL) and stays on 3G until I switch it back to what it was before.

Any explanation for why this is happening?
 
 
13th March 2014, 04:03 AM |#2  
yojoe600's Avatar
Senior Member
Flag Greensboro, NC
Thanks Meter: 451
 
Donate to Me
More
Get a new sim card trust me I had the same problem.
13th March 2014, 04:39 AM |#3  
Senior Member
Flag Mankato, MN
Thanks Meter: 185
 
Donate to Me
More
^ What he said. It will fix it!

Sent from my HTC6500LVW using Tapatalk
13th March 2014, 06:24 PM |#4  
OP Member
Thanks Meter: 2
 
More
OK will do.

Quote:
Originally Posted by mrbracht

^ What he said. It will fix it!

Sent from my HTC6500LVW using Tapatalk

18th October 2014, 04:50 PM |#5  
OP Member
Thanks Meter: 2
 
More
I just wanted to report that I finally got a new SIM card, but the problem still occurs when the LTE OnOff app is set to CDMA + LTE/EvDo auto. So I tried the CDMA/EvDo/GSM/WCDMA/LTE auto setting and so far so good. Maybe this setting would have worked with my old SIM card, I don't know.
21st October 2014, 03:01 PM |#6  
Senior Member
Thanks Meter: 598
 
More
Some roms use certain radio combos. I ran in to that problem on a few roms
21st October 2014, 05:35 PM |#7  
disconnecktie's Avatar
Senior Member
Thanks Meter: 1,320
 
More
Quote:
Originally Posted by legaldeejay

I just wanted to report that I finally got a new SIM card, but the problem still occurs when the LTE OnOff app is set to CDMA + LTE/EvDo auto. So I tried the CDMA/EvDo/GSM/WCDMA/LTE auto setting and so far so good. Maybe this setting would have worked with my old SIM card, I don't know.

Stop using this app. It wasn't meant to be used with the HTC one. It might even be the cause of your issue since it tries to override the default network preferences.
21st October 2014, 06:27 PM |#8  
santod040's Avatar
Recognized Developer / Recognized Contributor
Flag NorCal
Thanks Meter: 16,993
 
Donate to Me
More
Stock rooted rom + Stock recovery + Factory reset = No more problem dropping 4G

That will be the only method to fix your corrupt NV radio partitions.

I would also suggest not using that app, as Disconnecktie said.
22nd October 2014, 12:26 AM |#9  
synisterwolf's Avatar
Recognized Contributor
Thanks Meter: 2,291
 
More
Quote:
Originally Posted by legaldeejay

I just wanted to report that I finally got a new SIM card, but the problem still occurs when the LTE OnOff app is set to CDMA + LTE/EvDo auto. So I tried the CDMA/EvDo/GSM/WCDMA/LTE auto setting and so far so good. Maybe this setting would have worked with my old SIM card, I don't know.

All it does is make a shortcut to the "RadioInfo" process that is stored in settings. You can reach this by going to dialer and typing *#*#4636#*#* > Phone info. You will see the it there. The app is perfectly safe because it doesn't do much but shortcut to a process that is stock on the phone. Held in the settings.apk
I sense removed the app and just made a shortcut myself. Right now i have mine set to LTE/CDMA auto (PRL) and its bee working great for me. Check to see if you have the option to change it to that also.

see attached photo, sorry for the graininess of the photo. guess XDA has a limit on how big of an upload you can do.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-10-21-16-19-21.png
Views:	33
Size:	187.6 KB
ID:	2980251  
22nd October 2014, 01:28 PM |#10  
OP Member
Thanks Meter: 2
 
More
That option does not exist on mine. See my original post where I list all my options
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes