Exclamation [Q] [MT6577] Can't partition unsafe device /dev/block/mmcblk0p1

Hey guys..
I have been using Noir A8 which is another MT6577 device. I have been going through different ROMs (4.0.4, 4.1.1, 4.2.2) but never had any problem migrating between them.
Few days ago, the phone (Android 4.2.2) just hung up and upon restarting, it just stuck at company logo!
I first thought that ROM might have got corrupted, so flashed 4.0.4 with CWMR, but that didn't work out. Still that same logo.
I tried formatting internal storage partition which I read at XDA, but when I tried to push files in /sbin/, it said READ ONLY FILESYSTEM!
Even remounting system as RW from adb shell is not working.
When checked the log CWMR, it said:
Can't partition unsafe device /dev/block/mmcblk0p1
and can't mount external_sd

Flashing ROM from SP-TOOLS is also not working as mobile is always getting stuck at same logo screen whatever I do.

It seems that I can't flash ROM or push files because system has become read-only!
Any help from Android DEVs will be extremely helpful.
I am an iOS dev and have got some knowledge of Android but this has made me crazy as HELL!


CWRM log:
Click image for larger version

Name:	IMG_20140312_231158.jpg
Views:	11
Size:	263.5 KB
ID:	2627127