Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,778 Members 38,358 Now Online
XDA Developers Android and Mobile Development Forum

[Solved] Android OS extreme Data usage.

Tip us?
 
neu - smurph
Old
(Last edited by neu - smurph; 17th March 2014 at 09:08 PM.)
#1  
Senior Member - OP
Thanks Meter 48
Posts: 182
Join Date: May 2013
Default [Solved] Android OS extreme Data usage.

Hey all,

Anyone noticed any recent abnormally high background data utilisation from Android OS (both wifi and mobile?).

UK XT1032, 16GB stock unrooted Tesco firmware currently on 176.44.1. Hangouts, Migrate, Google+, Google Play Music, Google Play Movies & TV, Google Play Games, Google Play Books, & Chrome all disabled. Google Backup and Automatic Restore are on, all of the other Google Services set to Sync automatically. I use Firefox as my browser (with a sync to my laptop Firefox).

I've looked back on the data records for my phone and it looks like the problem started around the 25th of February. This roughly coincides to the last OTA to 176.44.1 which I'm pretty sure I got on the 26th or 27th. The most recent Google Play Services (4.4.43) installed on 1/3/14. The only other thing I can think of is K9 Mail which I installed on the 24th, although I'm struggling to see how a User app could show data used under Android OS.

I've checked my other half's Moto G (8GB UK version - O2 variant, stock unrooted) and she hasn't got this showing up at all. I've compared Sync/Backup settings between the two phones and they are the same, and other than Chrome she has pretty much the same stuff disabled. She doesn't use Firefox, and uses the stock email app with an exchange account.

Wifi

Click image for larger version

Name:	Screenshot_2014-03-13-05-47-50.png
Views:	246
Size:	130.3 KB
ID:	2627939Click image for larger version

Name:	Screenshot_2014-03-13-05-39-11.png
Views:	244
Size:	130.6 KB
ID:	2627934

16/1/14 to 13/2/14 - 311MB (so about 11MB day)
13/2/14 to 25/2/14 - 71.2MB ( about 6 MB day)
25/2/14 to 13/3/14 - 0.93GB ( about 55MB per day)

Mobile Data

Click image for larger version

Name:	Screenshot_2014-03-13-05-47-13.png
Views:	270
Size:	138.7 KB
ID:	2627938Click image for larger version

Name:	Screenshot_2014-03-12-18-10-41.png
Views:	281
Size:	139.7 KB
ID:	2627933

15/1/14 to 15/2/14 - 70.19MB ( about 2.5MB per day)
15/2/14 to 25/2/14 - 21.14MB (about 2MB per day)
25/2/14 to 13/3/14 - 275MB (about 16MB per day)

Possible solutions to try

1) Get rid of K9 email for a while (I use it because the stock email app appears to be incompatible with my talktalk.net ISP email account - it receives but can't send).
2) Cache Wipe in Recovery (although I'm pretty sure I've done this once since the last OTA)
3) Remove and then re add my gmail account.
4) Factory Reset.

Before I commence anyone else experiencing this problem, or even better has had the problem and solved it!
 
rogeriorp
Old
#2  
Senior Member
Thanks Meter 97
Posts: 387
Join Date: Dec 2013
Indeed I have the same issue, the one thing I believe that fixed it was turning off Google backup but I am not sure if is a permanent fix or a fix at all, since I renabled it. Try it!
The Following User Says Thank You to rogeriorp For This Useful Post: [ Click to Expand ]
 
neu - smurph
Old
(Last edited by neu - smurph; 14th March 2014 at 07:00 AM.)
#3  
Senior Member - OP
Thanks Meter 48
Posts: 182
Join Date: May 2013
Thanks, switched off Google Backup this morning, and that seems to have sorted it. Android OS only used 336KB of mobile data over 10 hours or so. I'll try and re-enable it later and see what happens.

Sent from my XT1032 using XDA Premium 4 mobile app
 
neu - smurph
Old
#4  
Senior Member - OP
Thanks Meter 48
Posts: 182
Join Date: May 2013
Quote:
Originally Posted by neu - smurph View Post
Thanks, switched off Google Backup this morning, and that seems to have sorted it. Android OS only used 336KB of mobile data over 10 hours or so. I'll try and re-enable it later and see what happens.

Sent from my XT1032 using XDA Premium 4 mobile app
Bah!

Turned Google Backup back on just before bed (thinking that 6-7 hours on wifi before going to work would be enough for it to do an initial backup) and then headed for work yesterday- Android OS chewed through another 20MB of mobile data in less than 2 hours.

So a simple disable/re-enable isn't the solution. I'll think I'll go for a Factory Reset. Checked my dates again and the problem definitely coincides with the OTA to 176.44.1 - I got it on the 25th.
 
neu - smurph
Old
(Last edited by neu - smurph; 17th March 2014 at 08:58 PM.)
#5  
Senior Member - OP
Thanks Meter 48
Posts: 182
Join Date: May 2013
Issue solved. Nothing to do with the OTA after all, although the factory reset gave me a valuable clue, when I noticed one of the things restored after a factory reset was my static wallpaper.....so Google Backup and Restore backs up the wallpaper, and I've an automation app installed set up to regularly refresh my wallpaper from the gallery. I created the routines on the 24th. Doh. Backup has been uploading multiple wallpapers everyday.

Tested today with the wallpaper switcher disabled and Backup and Restore enabled - no crazy data use and even better battery life than usual. Wallpaper switcher enabled and Backup and Restore disabled all is also fine. Both enabled gives crazy Android OS data use and noticeably more battery drain.



Sent from my XT1032 using XDA Premium 4 mobile app
Tags
anddroid os, data, moto g
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes