Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Nook HD - Updating CM10.1 > CM10.2 - "assert failed" error

OP hellslave

13th March 2014, 06:31 PM   |  #1  
OP Member
Thanks Meter: 1
 
42 posts
Join Date:Joined: Nov 2008
In trying to update my Nook HD from CM10.1 to 10.2, flashing this latest stable 10.2.1 ROM produces the following error:



I followed all the steps accordingly, so I'm stumped. I even redownloaded the ROM .zip and transfered to the sdcard (originally, it was downloaded via CM updater in settings). Should I NOT have flashed the updated recovery?

Any help would be greatly appreciated.
13th March 2014, 07:03 PM   |  #2  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,695
 
8,415 posts
Join Date:Joined: Oct 2006
Donate to Me
More
Quote:
Originally Posted by hellslave

In trying to update my Nook HD from CM10.1 to 10.2, flashing this latest stable 10.2.1 ROM produces the following error:



I followed all the steps accordingly, so I'm stumped. I even redownloaded the ROM .zip and transfered to the sdcard (originally, it was downloaded via CM updater in settings). Should I NOT have flashed the updated recovery?

Any help would be greatly appreciated.

Yes, you are right, you should not have updated your recovery. Version 6045 and newer will not successfully flash CM zips older than CM11. You must go back to an older CWM.

Sent from my BN NookHD+ using XDA Premium HD app
13th March 2014, 07:07 PM   |  #3  
OP Member
Thanks Meter: 1
 
42 posts
Join Date:Joined: Nov 2008
Which version should I get? I tried cwm-recovery-hummingbird-4.zip and that didn't work. To make matters worse, I am now unable to mount the external sd card.

EDIT:

I got past the external sd mounting issue by sticking the recovery image on the internal sdcard. But trying to flash any of the recovery imgs produces the same error as shown in the screenshot above. What the heck do I do now?

EDIT 2:

So I've tried flashing cwm-recovery-hummingbird-1/2/3 and none of them can be flashed; they give me the same error as the screenshot. Flashing cwm-recovery-hummingbird-4 or 5 will work, but won't let me flash the ROM. Is there ANOTHER version of CWM that I can try?
Last edited by hellslave; 13th March 2014 at 07:45 PM.
13th March 2014, 08:05 PM   |  #4  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,695
 
8,415 posts
Join Date:Joined: Oct 2006
Donate to Me
More
Go to my HD/HD+ CWM thread linked in my signature and I have version of CWM 6036 that can be flashed to internal memory with that SD. Then you can use that internal 6036 to flash CM10.2. See item 5.

Sent from my BN NookHD+ using XDA Premium HD app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes