Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Gaming Console with Lollipop? Ouya Gets an Android TV Port

Android is a very flexible platform, and it can be used on a large variety of … more

Android App Review: Manage Your Connections Automagically – XDA TV

Material Design is all the buzz in the Android world right now. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Downgraded To 4.2 Build Number 532...Here Is Why.

OP kanej2006

17th March 2014, 08:15 AM   |  #1  
OP Senior Member
Flag Dubai
Thanks Meter: 95
 
722 posts
Join Date:Joined: Mar 2008
This is the third or fourth time downgrading. Unfortunately I've encountered bugs, performance issues and force closes in various system applications.

Last night, I tried AGAIN to move forward and update. The latest update was 4.3. Unfortunately 4.4 has not yet been released and even if it was it is likely to come with bugs until an update or two rectifies any issues.

Now, these are some problems/bugs experienced with 4.3:

1 - Camera is now laggy whereas on 4.2 is was silky smooth. Only improvements I see on the latest update is a decrease in both noise/iso sensitivity as well as many other various camera effects.

Focusing takes far longer than before.

2 - Sound Settings keeps force closing in the 4.3 update. I'm not able to access or change the xLoud setting. I've cleared data, cache and even re-flashed. Keeps crashing. Downgrading to 4.2 solved this issue. Sound is LOUDER and xLoud works as it should.

3 - Screen - There is a slight delay when finishing from a call. It takes a few seconds for the proximity sensor to wake the screen to end the call. On 4.2 it is instant.

4 - Performance issue. 4.2 was smooth, fluid and instant. 4.3 feels heavier and not as quick as it previously was.

Therefore, with the above issues, I've had no choice but to downgrade. There were more advantages in 4.2 than in 4.3 which had issues, unfortunately.

I hope these problems are solved in the upcoming 4.4 Kitkat. Could other users share any problems caused by the latest updates? Was the stock 4.2 rom any better?
Last edited by kanej2006; 17th March 2014 at 08:18 AM.
17th March 2014, 09:27 AM   |  #2  
Member
Thanks Meter: 14
 
53 posts
Join Date:Joined: Aug 2007
Sorry, pal, I am on 4.3 .136 and the only thing I have observed is the laggy proximity sensor, which was fixed after some calibration (search for Hammdog's post). No traces at all of the other problems you mention. Camera shots are far better, and overall performance is excellent. Is it possible that you experience some sort of software incompatibility due to the apps you use?

Sent from my C6833 using XDA Premium 4 mobile app
Last edited by stopa10; 17th March 2014 at 09:58 AM.
17th March 2014, 10:34 AM   |  #3  
OP Senior Member
Flag Dubai
Thanks Meter: 95
 
722 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by stopa10

Sorry, pal, I am on 4.3 .136 and the only thing I have observed is the laggy proximity sensor, which was fixed after some calibration (search for Hammdog's post). No traces at all of the other problems you mention. Camera shots are far better, and overall performance is excellent. Is it possible that you experience some sort of software incompatibility due to the apps you use?

Sent from my C6833 using XDA Premium 4 mobile app

Ahh, so the laggy proximity sensor was a problem for others, not only me.

In 4.3 .136, the camera is better as you said but I'm experiencing lag, it's slow and takes 3-5 seconds to focus should the light be poor.

4.2 camera was substantially faster. Any reason why my sound settings keep crashing on 4.3?
17th March 2014, 10:44 AM   |  #4  
Saikyo_San's Avatar
Member
Thanks Meter: 10
 
64 posts
Join Date:Joined: Aug 2010
so it crashes even after a CLEAN re-flash or factory reset?
clean as in no app data restored, just pure stock naked rom
17th March 2014, 11:34 AM   |  #5  
OP Senior Member
Flag Dubai
Thanks Meter: 95
 
722 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by Saikyo_San

so it crashes even after a CLEAN re-flash or factory reset?
clean as in no app data restored, just pure stock naked rom

Yes. The ONLY thing crashing is when attempting to open the sound settings and enable the xLoud option. Force closes even after flashing, factory reset, etc.
17th March 2014, 03:05 PM   |  #6  
Saikyo_San's Avatar
Member
Thanks Meter: 10
 
64 posts
Join Date:Joined: Aug 2010
my humble opinion is that in the same situation i'd either stay on 4.2 or just root, get recovery and flash a stock based custom ROM or some AOKP, PA goodness or maybe GPe ROM

i have not encountered this issue before nor have I heard of it
18th March 2014, 07:23 AM   |  #7  
OP Senior Member
Flag Dubai
Thanks Meter: 95
 
722 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by Saikyo_San

my humble opinion is that in the same situation i'd either stay on 4.2 or just root, get recovery and flash a stock based custom ROM or some AOKP, PA goodness or maybe GPe ROM

i have not encountered this issue before nor have I heard of it

GPe Rom sound like a nice idea.

However, I'm thinking to patiently wait for the highly anticipated KitKat to be officially released.

That said, staying on the current 532 Android 4.2 will make rooting easier before upgrading to 4.4.
18th March 2014, 08:53 AM   |  #8  
iBuzman's Avatar
Senior Member
Flag Melbourne
Thanks Meter: 611
 
1,391 posts
Join Date:Joined: Mar 2011
No issues (incl proximity sensor or cam lag) for me on any 4.3 rom. If we were all having xloud fc there would be many threads about it - so it's not a Sony 4.3 issue, it's a @kanej2006 issue (not having a go at you, just saying your problems can't be automatically assumed to be problems for all and therefore flaws in 4.3)

Sent from my C6833 using Tapatalk
18th March 2014, 09:52 AM   |  #9  
OP Senior Member
Flag Dubai
Thanks Meter: 95
 
722 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by iBuzman

No issues (incl proximity sensor or cam lag) for me on any 4.3 rom. If we were all having xloud fc there would be many threads about it - so it's not a Sony 4.3 issue, it's a @kanej2006 issue (not having a go at you, just saying your problems can't be automatically assumed to be problems for all and therefore flaws in 4.3)

Sent from my C6833 using Tapatalk

Very strange as I only had these problems when upgrading to 4.3. Hopefully, these issues will be resolved in the future when upgrading to Kitkat.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes