Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

USB data connection acting strangely

OP timmytucker718

29th January 2014, 03:27 AM   |  #1  
OP Member
Thanks Meter: 1
 
99 posts
Join Date:Joined: May 2013
Most usb cables work to charge my phone, but won't form a data connection with my xt910. I do have ONE that will. I thought it might be the cables, but they form a connection with other devices. Thought I'd mention, it says a usb is connected regardless of which cable I use in ap fastboot.

What is going on????

Also, I just got the usb port replaced thinking this was the issue... i don't get it...
30th January 2014, 03:35 PM   |  #2  
phi7ip's Avatar
Junior Member
Thanks Meter: 7
 
16 posts
Join Date:Joined: Aug 2013
I had this problem with a certain phone before it turned out to be the plug the part that actually goes into the phone was not long enough. you might want to compare the plugs length on the ones that work and dont
15th March 2014, 02:42 AM   |  #3  
OP Member
Thanks Meter: 1
 
99 posts
Join Date:Joined: May 2013
Quote:
Originally Posted by phi7ip

I had this problem with a certain phone before it turned out to be the plug the part that actually goes into the phone was not long enough. you might want to compare the plugs length on the ones that work and dont


Ah, this is it! I guess Motorola makes their port deeper so that consumers have to buy their cables
16th March 2014, 08:35 AM   |  #4  
Junior Member
Thanks Meter: 6
 
25 posts
Join Date:Joined: Mar 2014
Yeah just take a razor and carve off some of the extra rubber around the plug.

Sent from my SGH-M919 using xda app-developers app
17th March 2014, 08:50 AM   |  #5  
ali.bsrn's Avatar
Junior Member
Thanks Meter: 2
 
19 posts
Join Date:Joined: Mar 2014
have you checked adb shell options? (Once I experienced a similar situation and it was due to adb options)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes