5,594,653 Members 33,256 Now Online
XDA Developers Android and Mobile Development Forum

Mk2 modem

Tip us?
 
Android_Monsters
Old
#11  
Android_Monsters's Avatar
Senior Member
Thanks Meter 746
Posts: 2,727
Join Date: Feb 2012
Location: Los Angeles
On the first page of this thread: http://forum.xda-developers.com/show....php?t=2544612

Sent from my SGH-M919 using XDA Premium 4 mobile app
The Following 2 Users Say Thank You to Android_Monsters For This Useful Post: [ Click to Expand ]
 
AUSTIN3:16
Old
#12  
AUSTIN3:16's Avatar
Member
Thanks Meter 8
Posts: 80
Join Date: Mar 2011
Location: San Antonio, TX
Isn't the MK2 modem the new one? If so, then I was looking for the MK2 modem.
 
mnasledov
Old
(Last edited by mnasledov; 20th January 2014 at 05:24 PM.)
#13  
mnasledov's Avatar
Senior Member
Thanks Meter 211
Posts: 183
Join Date: Oct 2010
Location: San Jose, CA
Quote:
Originally Posted by nmccready View Post
What about heimdall? I did,

sudo heimdall flash --MDM modem.bin

but it did not work even though it completed.

---------- Post added at 10:46 PM ---------- Previous post was at 10:33 PM ----------

This is the only combo that worked. (THEY HAD TO BE done at the SAMETIME!)

heimdall flash --MDM modem.bin --APNHLOS NON-HLOS.bin
There's a super hackish way I discovered that works for flashing everything on the M919 but I haven't tried scripting it yet. It totally works though -- I've updated S4 to latest MDL firmware in heimdall without use of Odin at all.

I might just write up a script to guide the process as it requires human intervention at several steps and is a pain.

EDIT: Oh, it's simple. I was already on MDL. Just heimdall flash --MDM modem.bin --no-reboot, hard reboot the phone after flash, run heimdall again to flash but without --no-reboot, and voila.
 
generationxile
Old
#14  
Junior Member
Thanks Meter 4
Posts: 25
Join Date: Feb 2011
Location: WISCONSIN
Default 4.4.2 modem switch

Just want to make sure here. I'm on CM-11-20140210-Snapshot-M3-jfltetmo (T-Mo phone with ATT service) and have the M919UVUFNB4. Im getting network drops and "no service" at home, and intermittently other places.
Rooted, unlocked, don't care about the warranty etc. It's corporate service, so this rom (after lots of testing ROMS) finally was one i can install Lync mobile 2013 and encrypt for my corp email access. Flawlessly operating so far other than that network issue.

I'm seeing that people are flashing modem.bin for the M919 on 4.4.2 but also seeing not to use it unless you are on 4.3 here. So, am curious what modem they flashed and if there was any specific addendum to the instructions they had to follow on a 4.4.2 ROM.

I did try to flash the MK2_NON-HLOS.zip but it didnt change my baseband the first time, so I figured Id rather ask a stupid or already answered q, than have to wipe, flash my ROM yet again.

So if someone could just confirm for me what modem/process they have working with the 4.4.2 I would greatly appreciate it.
Im at work tonight, so if i missed it and the info is already out there, please drop me the link so I can read while I face-palm.
 
Android_Monsters
Old
#15  
Android_Monsters's Avatar
Senior Member
Thanks Meter 746
Posts: 2,727
Join Date: Feb 2012
Location: Los Angeles
Are you on the new baseband and bootloader? Or just the new baseband?

Sent from my SGH-M919 using XDA Premium 4 mobile app
The Following User Says Thank You to Android_Monsters For This Useful Post: [ Click to Expand ]
 
Android_Monsters
Old
#16  
Android_Monsters's Avatar
Senior Member
Thanks Meter 746
Posts: 2,727
Join Date: Feb 2012
Location: Los Angeles
I'd update to the latest cm nightly. And I'm hoping you didn't update to the 4.4.2 bootloader just the baseband. This is what mine looks like. No data drops, etc.

Sent from my SGH-M919 using XDA Premium 4 mobile app
Attached Thumbnails
Click image for larger version

Name:	1395120764343.jpg
Views:	53
Size:	45.6 KB
ID:	2636455  
The Following 2 Users Say Thank You to Android_Monsters For This Useful Post: [ Click to Expand ]
 
generationxile
Old
#17  
Junior Member
Thanks Meter 4
Posts: 25
Join Date: Feb 2011
Location: WISCONSIN
Quote:
Originally Posted by Android_Monsters View Post
Are you on the new baseband and bootloader? Or just the new baseband?

Sent from my SGH-M919 using XDA Premium 4 mobile app
I havent updated the bootloader purposely since I was on 4.3 And only flashed a handful of custom roms like CM. So I believe i should still be on the 4.3

Quote:
Originally Posted by Android_Monsters View Post
I'd update to the latest cm nightly. And I'm hoping you didn't update to the 4.4.2 bootloader just the baseband. This is what mine looks like. No data drops, etc.

Sent from my SGH-M919 using XDA Premium 4 mobile app
I stuck with this build because it didnt have any problems encrypting which i needed for mobileiron to report device compliance etc for corp email. Without being sure that the new builds will encrypt without issue, Ill just wait a while and leave it alone so long as I am not getting drops in service at home.
Which ironically after i posted, it didnt do last night. Ill have to test again tonight and see if it does drop again or if it was a fluke. If so, ill be checking bootloader version, (not sure how to yet but research is my friend) and doing some flashing again. YAY TRIAL AND ERROR!!

thanks btw for the response.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes