5,606,151 Members 35,176 Now Online
XDA Developers Android and Mobile Development Forum

Archos 80 g9 power issue

Tip us?
 
mielman
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Jan 2012
Default Archos 80 g9 power issue

Hey all,

So, I've encountered multiple issues with my Archos 80 g9 lately.
Since I've had it for 2 years now, I know it has it's charming defects from time to time, but all of those were easy to fix.. until now.

Somehow, there is a dysfunction at the charger entry: My tablet only charges if the charger is slightly 'bent' to the left, which isn't so much of a problem on its own, but every time I want to use the device while its charging it keeps 'connecting' and 'disconnecting' the charger. I noticed that if this happens five or six times in a row, the device completely freezes, or just becomes extremely slow. I just don't want to open it up until I'm sure what is wrong.

Also, when I turned of the device last week, like a million times before (it was about 80% charged, btw) it just didn't want to turn on the day after. While I was pretty sure its battery wasn't drained I still tried to charge it: the green led turns on, and that's it.
No other sign of life, no reboot possible, the screen doesnt turn on and as soon as I remove the charger the led turns off and still nothing happens.

Any thoughts on this?

Regards,
mielman
Devices owned:

Sony Xperia S (Jelly Bean Rooted CWM - DooMLoRD)
Archos 80 g9 (Freezenook Rom [BUILD8] Rooted - Freezenook)
 
Djirin
Old
#2  
Member
Thanks Meter 20
Posts: 61
Join Date: Apr 2012
It has been said before that the charger ports on these are not the best thought out. Apparently only held in place by the solder of the pins and nothing else. What it sounds like to me is that the solder joints on yours is starting to become undone. I've heard they are not the easiest to resolder for a DIY repair unless you're really good at it.

As far as the not waking up.. Are you sure the tablet is turning off all the way? I'm using a custom rom on my 101 g9 turbo and I notice that every so often the tablet won't turn off all the way... ie the power LED is still on even though the screen is blank. I have to hold in the power button to force it to turn off.
Archos 101 G9 512mb 1.5ghz Turbo 8GB
 
mielman
Old
(Last edited by mielman; 12th December 2013 at 03:46 PM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Jan 2012
Quote:
Originally Posted by Djirin View Post
It has been said before that the charger ports on these are not the best thought out. Apparently only held in place by the solder of the pins and nothing else. What it sounds like to me is that the solder joints on yours is starting to become undone. I've heard they are not the easiest to resolder for a DIY repair unless you're really good at it.
Then opening up the device it is.
Quote:
As far as the not waking up.. Are you sure the tablet is turning off all the way? I'm using a custom rom on my 101 g9 turbo and I notice that every so often the tablet won't turn off all the way... ie the power LED is still on even though the screen is blank. I have to hold in the power button to force it to turn off.
Yeah, I'm pretty sure it is, since even holding the power butting for approximately 20 seconds doesnt change a thing.
Devices owned:

Sony Xperia S (Jelly Bean Rooted CWM - DooMLoRD)
Archos 80 g9 (Freezenook Rom [BUILD8] Rooted - Freezenook)
 
white-energy
Old
#4  
white-energy's Avatar
Senior Member
Thanks Meter 209
Posts: 595
Join Date: Apr 2010
Location: L'viv
I just ran into the same issue, what have you managed to do ?



"If you cannot find the truth right where you are, where else do you expect to find it?" ~Dogen

 
mielman
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Jan 2012
Quote:
Originally Posted by white-energy View Post
I just ran into the same issue, what have you managed to do ?
Sorry, kinda killed the thread since I forgot to check for any replies.

So far I haven't really been trying to fix the problem, but since I've just bought a new phone charger I thought I might as well give it a try to charge the Archos with it.
I'll check for any changes in a few hours, if nothing changed, I might aswell disassemble it, then I'll notify you what the problem is.
Devices owned:

Sony Xperia S (Jelly Bean Rooted CWM - DooMLoRD)
Archos 80 g9 (Freezenook Rom [BUILD8] Rooted - Freezenook)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes