ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] S4 GT-I9500 IMEI lost, no EFS backup. Help!

OP amit.talukdar

17th January 2014, 05:23 PM   |  #11  
Senior Member
Thanks Meter: 188
 
936 posts
Join Date:Joined: Nov 2008
More
Quote:
Originally Posted by Obagleyfreer

OK, was there really the need to be such a dick?
....

Sorry, did not understood your wording (can be an effect that I grown in different environment what resulted with other than yours standards and wording, apologies for that).
Did you mean, if it was really a reason to be sarcastic, while seeing the totally rubbish post, asking the @op to perform nonsense, useless and irrelevant in his situation actions because its author was not able to read the problem with understanding?
If so, the answer is: yes, indeed, it was a need to be sarcastic. Maybe the author would stop himself from posting nonsenses in the future.
20th January 2014, 11:47 PM   |  #12  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Dec 2012
Solved:Hex Editor Route
1- Flashed Stock android- adonis.pit & I9500XXUEMK9_I9500ODDEMK9_I9500DDUEMK9_HOME.tar

2- Rooted using CF-Auto-Root-ja3g-ja3gxx-gti9500.tar

3- Installed TWRP Recovery using goo

4- Downloaded Hxd (Windows Hex editor- Freeware)

5- Using ES Explorer (Root Mode) copied EFS folder to Windows and started opening all files-

Made following changes-

Change 1: In nv_data.bin change the addresses to this-

00188000: FF FF FF FF 4D 50 20 30 2E 38 30 30 00 00 00 49
00188010: 4E 55 00 00 00 00 47 54 2D 49 39 35 30 30 5A 4B
00188020: 41 49 4E 55 00 00 00 00 00 00 FF FF FF FF FF FF

This reads as - MP 0.800...INU....GT-I9500ZKAINU......

Change 2: efs\FactoryApp\ serial_no

Put the serial no in hex and changed permission to system and removed write access from system. After reboot it reverted to zero so made it read only for system (changed permissions from with in ES file manager)

Rebooted and it worked

I know.. I am lucky to get it back working.. have made 4 backups from dropbox to google drive now
The Following User Says Thank You to amit.talukdar For This Useful Post: [ View ]
20th March 2014, 12:11 AM   |  #13  
ygor.almeida's Avatar
Member
Flag Sao Paulo
Thanks Meter: 9
 
66 posts
Join Date:Joined: Nov 2009
More
I got one board replacement ... but it comes with generic IMEI - how do i write a new one ( i have the one that was corrupted board ) i want to write that imei to the new board ? how to do ?! hexedit will work ?!
20th March 2014, 01:39 AM   |  #14  
Velcis Ribeiro's Avatar
Senior Member
Flag Porto Alegre
Thanks Meter: 207
 
410 posts
Join Date:Joined: Jan 2012
More
You have the IMEI at under battery spot, so get the number than change the IMEi with IMEi Changer.

Take a look on google for a app for this.
Or with Notepad + ADB

Cya!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes