5,595,000 Members 39,446 Now Online
XDA Developers Android and Mobile Development Forum

[APP][4.0+] SwiP - Switch profiles intelligently 0.2.6 [Beta]

Tip us?
 
Flow-Chi
Old
#61  
Junior Member - OP
Thanks Meter 54
Posts: 28
Join Date: Apr 2013
Location: Salzburg, AT
Quote:
Originally Posted by User_99 View Post
Still have problems with the app using in CM based ROM. Profiles won't be active sometime. First start all is fine, but then the trigger won't activate the selected profile.
This happens when SwiP gets killed by the system.. somehow the BroadcastReceiver gets unregistered then, although the service is still running.
For more information check out the issue here: https://bitbucket.org/FlorianSchrofner/swip/issue/9/

We'll try to fix this as soon as we can.

Quote:
Originally Posted by pt0 View Post
The phone is rooted, SWIP is installed as a system app. It basically gets the phone into the airplane mode, but when switching to another profile, which sets airplane to disabled, has no effects. So I am not quite sure if I missed something or this is just an issue, since the app is still developed
I've never experienced this issue.. which Android version are you using?
It's pretty strange, that enabling airplane mode works and disabling doesn't.. we are using the same method for both
 
pt0
Old
#62  
Junior Member
Thanks Meter 3
Posts: 23
Join Date: Jan 2013
Quote:
Originally Posted by Flow-Chi View Post
This happens when SwiP gets killed by the system.. somehow the BroadcastReceiver gets unregistered then, although the service is still running.
For more information check out the issue here: https://bitbucket.org/FlorianSchrofner/swip/issue/9/

We'll try to fix this as soon as we can.



I've never experienced this issue.. which Android version are you using?
It's pretty strange, that enabling airplane mode works and disabling doesn't.. we are using the same method for both
It is 4.1.2. After the profile sets the airplane mode to disabled, the icon, that indicates the network coverage is inactive (with the red cross). Everything indicates that the mode is still on. I do have installed the xposed framework but without the Airmode helper (I could not install it anyway).

Any guess what it may be?
 
User_99
Old
#63  
User_99's Avatar
Senior Member
Thanks Meter 853
Posts: 2,077
Join Date: Jul 2009
Quote:
Originally Posted by Flow-Chi View Post
This happens when SwiP gets killed by the system.. somehow the BroadcastReceiver gets unregistered then, although the service is still running.
For more information check out the issue here: https://bitbucket.org/FlorianSchrofner/swip/issue/9/

We'll try to fix this as soon as we can.
Confirmed. Thx for your effort!
Device: Sony Ericsson xPeria Arc S -- Rom: CM10Hasty@10-11-2013 -- Base: CM 10 - Linaro/O3/BIONIC Optimization - GCC 4.9 -- Radio: 77 -- Kernel: 2.6.32.60
Device: Samsung Galaxy Note GT-7000 -- Rom: Paranoid 2.56@20-12-2012 -- Base: CM 10-PA -- Radio: BOLT1 -- Kernel: #35
Device: Samsung Galaxy Note 8 GT-N5100 -- Rom: Stock 4.1.2 -- Base: Stock -- Radio: Stock -- Kernel: Stock
Tags
automation, nfc, open source, profile, trigger
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes