Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,784,161 Members 41,735 Now Online
XDA Developers Android and Mobile Development Forum

Xperia play doesnt work

Tip us?
 
ĦOM3GA!
Old
(Last edited by ĦOM3GA!; 8th January 2014 at 12:05 PM.)
#1  
ĦOM3GA!'s Avatar
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Feb 2013
Default Xperia play doesnt work

I have a R800x Xperia play and it doesnt work no more.

Before whenever the battery would die out all the way to 0% and turn off automatically, it would take like 5 minutes of charging before it can reboot.(I would never let it go to zero but i let people use it and everytime they let it drain all the way and it bugs the sh*t! out of me, that cant even ask me for a charger!!)

anyways this last time it took over an hour of charging (with led indicator on) to be able to boot up. and before that i had left the charger on overnight and the led never turned on and i wasnt able to turn it on. And when it did start working it itwas out of nowhere after plugging it in multiple times.

This last time it was on yellow battery and i fell asleep using it so when i woke up it was drained all the way. (also i found it on the ground so it fell from my bed, but the screen is not cracked so idk if this has anything to do with the problem). I put the phone to charge and after like an hour nothing happened. 3, 4, 5 hours and same thing. i left it all night and still nothing no led no vibration! i bought a new battery thinking i might have messed up the old one letting it drain all the way (the extended battery for a r800i, dont know if that will affect it) and put it in, and nothing still. tried charging and still no led light.

i think that mayb the miniusb port is messed up and both my batteries are drained all the way! even the new one because this is an old device and they probably manufactured the battery a long time ago.

i have taken the phone apart and see nothing wrong, except for the flex cable looks a little damaged, i will upload a pic asap

So any suggestions on how to fix it myself?

thank you for any help!
 
Denzof
Old
#2  
Denzof's Avatar
Senior Member
Thanks Meter 11
Posts: 118
Join Date: Sep 2012
Do you have a custom rom installed if so which one ?
The Following User Says Thank You to Denzof For This Useful Post: [ Click to Expand ]
 
ĦOM3GA!
Old
#3  
ĦOM3GA!'s Avatar
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Feb 2013
Quote:
Originally Posted by Denzof View Post
Do you have a custom rom installed if so which one ?
thanks for reply. no i don,t i forgot to add that it is rooted and that the date on the phone was forwarded to like 2 months ahead of time (dont know if this will cuase any software issues)
i have 2.3.2 installed and could not update because i bought it off contract to use as a tablet/gaming.
i see a lot of mistakes on my original post n will correct em, lol thats wat happens when u up late
 
ĦOM3GA!
Old
#4  
ĦOM3GA!'s Avatar
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Feb 2013
took my phone to get fixed and they said it was the usb port they charged $10 for the diagnosis, and told me they dont fix usb ports but that they could recommend someone and that it was gonna be $60. they sold me a universal seat charger and now it works!

I found a usb port replacement online for $6. Ive done a lil soldering in the past but not real good. does anybody have any tips, how to's, vids? ive searched online and havent hound anything.
 
WhiteWashed
Old
#5  
WhiteWashed's Avatar
Senior Member
Thanks Meter 33
Posts: 118
Join Date: Jan 2014
Quote:
Originally Posted by ĦOM3GA! View Post
took my phone to get fixed and they said it was the usb port they charged $10 for the diagnosis, and told me they dont fix usb ports but that they could recommend someone and that it was gonna be $60. they sold me a universal seat charger and now it works!

I found a usb port replacement online for $6. Ive done a lil soldering in the past but not real good. does anybody have any tips, how to's, vids? ive searched online and havent hound anything.
You can find on youtube videos of how to dissamble the Xplay.
Anyway if it's the miniusb port broken, why doesn't the phone boot up ?
 
ĦOM3GA!
Old
#6  
ĦOM3GA!'s Avatar
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Feb 2013
Quote:
Originally Posted by WhiteWashed View Post
You can find on youtube videos of how to dissamble the Xplay.
Anyway if it's the miniusb port broken, why doesn't the phone boot up ?
the battery was completely drained. n ithink the xperia play is one of those devices where it has to be ON to charge. now it charges through the port. i have let it die again, and it wont charge no more through the port. if i use the battery seat charger and as long as it has a lil bit of charge, it'll charge thru the port. but connecting the xperia with the pc, the xperia isnt recognized. so the usb port IS messed up, it'll charge but wont sync
Tags
black screen, no l.e.d., r800x, verizon, xperia play
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Prevent Apps from Locking Screen Orientation with HaveOwnOrientation

Most applications on Android play nicely with both landscape and … more

Create Your Own Launcher with HTMLauncher

There are hundreds of launcher replacement applications available for Android. Most of them are … more

First ROMs Appear for the Nvidia Shield Tablet

TheNvidia Shield Tablethas only been available for a little over a month. In that short time, … more

How to Root the LG G Watch – XDA Developer TV

In this episode, XDA Developer TV Producer RootJunky Tom shows you how to root and unlock … more